For those that have the rough 2-1 downshift in "S" mode - Page 3 - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #21 of 68 (permalink) Old 01-27-2008, 04:45 PM Thread Starter
BenzWorld Member
 
Date registered: May 2006
Vehicle: Eurocharged ECU E500, OE Tuning ECU/Speedriven TCU SL600 V12TT, 2007 Range Rover Supercharged
Location: Frederick, Maryland
Posts: 235
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via AIM to Benz-O-Rama
(Thread Starter)
FWIW....

Mine is still silky smooth after 2 weeks of getting this done.

2004 E500 - Eurocharged ECU, VRP headers and E55 exhaust. #1 record holder on dragtimes ([email protected])
2005 SL600 - OE Tuning ECU/ Speedriven TCU - #1 record holder on dragtimes ([email protected])


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Powered by:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Benz-O-Rama is offline  
Sponsored Links
Advertisement
 
post #22 of 68 (permalink) Old 01-31-2008, 06:35 PM
BenzWorld Senior Member
 
mitaka's Avatar
 
Date registered: May 2007
Location: NY/NJ Metro
Posts: 557
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
I took my R 320 CDI to get checked with the valve body checked. The dealer confirmed that Mercedes is replacing faulty valve bodies. Mine 2007 had the most current valve body and software. Basically if you do not have the most current valve body you cannot have the latest software version installed. They double checked my car.

2012 E550 P1, Driver Assist Pkg, Sport Pkg 18' OEM AMG Wheels, Distronic

Other/ Previous cars:

14 Volvo XC60 T6 AWD
09 R350
07 R320 CDI
Audi A8 4.2 Quattro
mitaka is offline  
post #23 of 68 (permalink) Old 02-03-2008, 02:56 PM
BenzWorld Elite
 
Date registered: Jan 2007
Vehicle: 2002 honda civic (sold), 2009 Mercedes ML350
Location: Miami, florida
Posts: 1,344
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
Quote:
Originally Posted by mitaka View Post
I spent a lot of time researching this issue. There is a software update that fixes these issues but it works only on the newer valve body. In other words if you have the old valve body you cannot use this current software version.
thats mainly correct but here is why. older cars have either a 112 or 113 engine and after about 06-07 software, nothing newer is available. all the newer cars with the 272 and 273 engine newer software is available every new software release. and when you replace a valve body in a car with a 112 or 113 engine you have to use the 07 software release to flash it, flashing it with a 10 or 11 software with cause the car to hesitate.

10 or 11 software refers to year 2007, it starts over at the beginning of the year, 01/2008 software is currently the newest one.
Streetglower is offline  
Sponsored Links
Advertisement
 
post #24 of 68 (permalink) Old 02-03-2008, 04:23 PM
BenzWorld Senior Member
 
mitaka's Avatar
 
Date registered: May 2007
Location: NY/NJ Metro
Posts: 557
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
I still do not understand what valve body they installed in Benz-O-Rama's car.
My car is '07 production date 9/06. Can they put the newest valve body that is designed for the 08 models in my car and latest software 01/2008 to further improve shifting quality...

2012 E550 P1, Driver Assist Pkg, Sport Pkg 18' OEM AMG Wheels, Distronic

Other/ Previous cars:

14 Volvo XC60 T6 AWD
09 R350
07 R320 CDI
Audi A8 4.2 Quattro

Last edited by mitaka; 02-03-2008 at 06:16 PM.
mitaka is offline  
post #25 of 68 (permalink) Old 02-20-2008, 08:24 AM
BenzWorld Member
 
gst500's Avatar
 
Date registered: Sep 2007
Posts: 95
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
i had the same exact thing benz-o-rama had done and it is really shifting smooth. I had more of a rough shifting from 1-2 and occasionally the downshift from 2-1. Now it really shifts silky smooth. I printed out a copy of the tread with benz-o-rama's service a
sheet and they looked at it and just had to gey approval. Now if i can get around paying $34 a day for a Sonata. Lol ! Does anyone know how long it takes for the reprogramming of the trans to adapt to my driving habits and locked it in ?
gst500 is offline  
post #26 of 68 (permalink) Old 02-20-2008, 09:35 AM Thread Starter
BenzWorld Member
 
Date registered: May 2006
Vehicle: Eurocharged ECU E500, OE Tuning ECU/Speedriven TCU SL600 V12TT, 2007 Range Rover Supercharged
Location: Frederick, Maryland
Posts: 235
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via AIM to Benz-O-Rama
(Thread Starter)
Quote:
Originally Posted by gst500 View Post
i had the same exact thing benz-o-rama had done and it is really shifting smooth. I had more of a rough shifting from 1-2 and occasionally the downshift from 2-1. Now it really shifts silky smooth. I printed out a copy of the tread with benz-o-rama's service a
sheet and they looked at it and just had to gey approval. Now if i can get around paying $34 a day for a Sonata. Lol ! Does anyone know how long it takes for the reprogramming of the trans to adapt to my driving habits and locked it in ?
Sweet! Mine is still as silky smooth as the day I got this done. It shouldn't take more than a couple of hours to do, once they start.

The adaptation doesn't really 'lock-in' to your habits. It is constantly adapting to whomever is driving. But, after they reset it, it shouldn't take more than a day or two to adapt. That's a complete guess though.

2004 E500 - Eurocharged ECU, VRP headers and E55 exhaust. #1 record holder on dragtimes ([email protected])
2005 SL600 - OE Tuning ECU/ Speedriven TCU - #1 record holder on dragtimes ([email protected])


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Powered by:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Benz-O-Rama is offline  
post #27 of 68 (permalink) Old 06-05-2008, 07:36 PM Thread Starter
BenzWorld Member
 
Date registered: May 2006
Vehicle: Eurocharged ECU E500, OE Tuning ECU/Speedriven TCU SL600 V12TT, 2007 Range Rover Supercharged
Location: Frederick, Maryland
Posts: 235
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via AIM to Benz-O-Rama
(Thread Starter)
Bump for the newbs.....

Mine is still perfect after this.

2004 E500 - Eurocharged ECU, VRP headers and E55 exhaust. #1 record holder on dragtimes ([email protected])
2005 SL600 - OE Tuning ECU/ Speedriven TCU - #1 record holder on dragtimes ([email protected])


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Powered by:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Benz-O-Rama is offline  
post #28 of 68 (permalink) Old 06-07-2008, 06:31 PM
BenzWorld Junior Member
 
billythec's Avatar
 
Date registered: Aug 2006
Posts: 42
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
My R320 just started doing this, I'll ask for the fix when i go in!
Oddly, my wife complained about it.
billythec is offline  
post #29 of 68 (permalink) Old 07-15-2008, 06:46 AM
BenzWorld Junior Member
 
forbell's Avatar
 
Date registered: Mar 2007
Vehicle: 2008 C350 (his) and 2006 R350 (hers)
Location: Cincinnati, Ohio
Posts: 30
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Actually sitting at the dealer now for a inconsistent downshifting jerk (when slowing down to a stop - for a stop sign, etc.).

Of course the tech and I went out and it wouldn't do it, but both my wife and I have felt it.

They're currently checking the software on the computer and checking for fault codes.

I'll ask them about the valve body in a bit.....
forbell is offline  
post #30 of 68 (permalink) Old 08-05-2008, 12:54 PM
BenzWorld Member
 
f-rod's Avatar
 
Date registered: May 2003
Vehicle: 2002 E430 SE - Gone but not forgotten :-(
Location: Reading, PA
Posts: 95
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
I just called my dealer and am taking mine in Friday to get the software checked. I'm also taking this posting info to show them. The downshift is really anoying, but mine only happens when i drive downhill leaving my home.

I cost to the stop sign at about 20mph and touch the brake very lightly, then BAM! It is driving me nuts.
f-rod is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > W251 R-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Thud from "Comfort to Sport" Mode & Memory Power Seats CHLUTES W203 C-Class 7 10-21-2007 03:22 PM
"Manual" mode on 7 speed auto SLK350 PhilD73 R170 SLK-Class 1 04-24-2006 06:15 AM
Your SLK "Primary" or "Secondary" mode of transportation? 2000 SLK 230 LM R170 SLK-Class 23 05-05-2004 09:35 AM
one touch sunroof & "tunnel mode"? dan2003 W203 C-Class 8 05-18-2003 09:23 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome