Fuel Filling Issues - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 01-14-2019, 10:26 AM Thread Starter
BenzWorld Senior Member
 
PKariCL600's Avatar
 
Date registered: Nov 2006
Vehicle: 2015 S550 Sport ; 1999 S500 ; 1999 CL600 **RIP**
Location: Albany, NY, to Orange County CA
Posts: 516
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Garage
(Thread Starter)
Fuel Filling Issues

Hey everyone...

Does everyone experience issues while trying to fuel their vehicles...
Everytime I go to fill it the pump keeps stopping and I have to pull the nozzle out for a sec and then start again...this happens every time...I can't just lock the handle in place and let it fuel on its own.

Anyone else have this issue?
PKariCL600 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 01-14-2019, 11:43 AM
Outstanding Contributor
 
konigstiger's Avatar
 
Date registered: Jan 2007
Vehicle: '71 Pinto
Location: North Scottsdale, AZ
Posts: 4,000
Mentioned: 13 Post(s)
Quoted: 377 Post(s)
If it happens at different filling stations, a bit early for 222 but could be fuel evaporation system (i.e.: charcoal canister/associated valve, etc.) have it checked under warranty.
konigstiger is offline  
post #3 of 6 (permalink) Old 01-19-2019, 11:08 AM Thread Starter
BenzWorld Senior Member
 
PKariCL600's Avatar
 
Date registered: Nov 2006
Vehicle: 2015 S550 Sport ; 1999 S500 ; 1999 CL600 **RIP**
Location: Albany, NY, to Orange County CA
Posts: 516
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Garage
(Thread Starter)
Great thank you!! I actually just tried holding the nozzle upside down and it works perfectly but I will be taking it in for warranty just to check it out..thanks again
PKariCL600 is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 01-26-2019, 08:56 PM
Outstanding Contributor
 
konigstiger's Avatar
 
Date registered: Jan 2007
Vehicle: '71 Pinto
Location: North Scottsdale, AZ
Posts: 4,000
Mentioned: 13 Post(s)
Quoted: 377 Post(s)
See attachments if all is found to be fine.
Attached Files
File Type: pdf LI47.00-P-058235_Ver_3.pdf (32.7 KB, 50 views)
File Type: pdf 058235.pdf (517.9 KB, 51 views)
konigstiger is offline  
post #5 of 6 (permalink) Old 01-30-2019, 09:00 AM Thread Starter
BenzWorld Senior Member
 
PKariCL600's Avatar
 
Date registered: Nov 2006
Vehicle: 2015 S550 Sport ; 1999 S500 ; 1999 CL600 **RIP**
Location: Albany, NY, to Orange County CA
Posts: 516
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Garage
(Thread Starter)
Quote:
Originally Posted by konigstiger View Post
See attachments if all is found to be fine.
This is great!!
Thank you!
PKariCL600 is offline  
post #6 of 6 (permalink) Old 05-23-2019, 08:43 AM
BenzWorld Junior Member
 
Date registered: Dec 2008
Posts: 5
Mentioned: 1 Post(s)
Quoted: 2 Post(s)
The problem is probably the charcoal cannister. The problem can start if the fuel tank has been topped off or overfilled. I had mine replaced under warranty and it fixed the problem.

I initially took my S550 in to the dealer and he gave me the MB notification regarding the pump design and that I should insert fully and then tilt down. However, this did not fix the problem. I took my car back and demonstrated the problem to the service advisor at the gas station.

No problems after the cannister was repaired.
PKariCL600 likes this.
bkdc is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W222 S-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome