W221 - 2007 S600 Seat Belt Warning Error - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 10-31-2017, 07:39 PM Thread Starter
BenzWorld Member
 
Tifosi1's Avatar
 
Date registered: May 2010
Vehicle: 2007 S600, 2011 GL550, 1989 560SEC, 2003 G500
Location: Montana
Posts: 55
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
(Thread Starter)
W221 - 2007 S600 Seat Belt Warning Error

Recently my 2007 S600 seat belt warning light and chime started going off even though I was wearing my belt - I was/am the only one in the car when this happens. I cleaned the buckle latch thinking it was a bit dirty, whatever - no luck, through some trial and error I've found I can make it go off if I also buckle the empty passenger belt... weird huh? The passenger seat airbag occupancy sensor seems to work - the dash light goes on and off as it should, and I get informed of passenger airbag enabled/disabled via the dash messages. So I'm confused the car seems to think there is someone in passenger seat concerning the belts, but not the airbags... Anyway it's quite frustrating, so any ideas or experiences or solutions would be appreciated. Thanks - Nick
Tifosi1 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 11-01-2017, 06:41 AM
Moderator
 
Skylaw's Avatar
 
Date registered: Oct 2004
Vehicle: 2013 S550
Location: Tampa, Florida
Posts: 10,815
Mentioned: 40 Post(s)
Quoted: 453 Post(s)
Lifetime Premium Member
Garage
Check and clean the seat belt wiring connector that is below the seat. At least in the W220, that was often the cause of such indications.

Other than that, it may be the seat occupancy sensor, as you probably suspect.

Warren

2013 S550

Formerly:
2010 S550
2005 S500 4-Matic
2000 S500
1978 450SL
Skylaw is offline  
post #3 of 5 (permalink) Old 11-03-2017, 09:01 AM Thread Starter
BenzWorld Member
 
Tifosi1's Avatar
 
Date registered: May 2010
Vehicle: 2007 S600, 2011 GL550, 1989 560SEC, 2003 G500
Location: Montana
Posts: 55
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
(Thread Starter)
Yes I do suspect the WSS sensor - also seems like there are a couple of types of those. One mounted to the seat frame and one integrated to the seat cushion. I believe mine is the older frame mounted version (but I have yet to confirm) - and unfortunately seems as if those might be NLA and are to be upgraded to the cushion type. Easy enough, except that requires DAS/STAR/Xentry PC and software, which I don't have.
The second option appears to be using a WSS emulator which fakes the CPU into thinking all is well - except that the airbag is always active - which for me is not big deal. Just curious if anyone has experience with these emulators.

Like this:
http://airbag360.com/usa-mercedes-s-...only-496-p.asp

Thanks again - Nick









;

Last edited by Tifosi1; 11-03-2017 at 09:15 AM. Reason: wrong link...
Tifosi1 is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 11-04-2017, 04:49 PM
Moderator
 
Skylaw's Avatar
 
Date registered: Oct 2004
Vehicle: 2013 S550
Location: Tampa, Florida
Posts: 10,815
Mentioned: 40 Post(s)
Quoted: 453 Post(s)
Lifetime Premium Member
Garage
It is not much of a problem for you, because you are aware of it - but a subsequent owner may not be, and lack of such knowledge could cause a fatality under some circumstances.

Warren

2013 S550

Formerly:
2010 S550
2005 S500 4-Matic
2000 S500
1978 450SL
Skylaw is offline  
post #5 of 5 (permalink) Old 06-09-2019, 05:09 AM
BenzWorld Member
 
Date registered: Dec 2017
Vehicle: 2001 210.082 +494, 2008 221.176 +494
Location: USA
Posts: 95
Mentioned: 3 Post(s)
Quoted: 9 Post(s)
Quote:
Originally Posted by Tifosi1 View Post
The passenger seat airbag occupancy sensor seems to work - the dash light goes on and off as it should, and I get informed of passenger airbag enabled/disabled via the dash messages.
This is not normal. It sounds benign, but it should not inform you when it has enabled safety features. This indicates the WSS is out of calibration. This will need to be done at the dealer using specific weights and their diagnostic tool.
TiffanyTwisted is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W221 S-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome