Instrument cluster went dark - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 21 (permalink) Old 07-03-2019, 03:09 PM Thread Starter
BenzWorld Member
 
Date registered: Dec 2003
Posts: 50
Mentioned: 2 Post(s)
Quoted: 11 Post(s)
Send a message via AIM to 2k2s430
(Thread Starter)
Instrument cluster went dark

Today while driving I hit a pot hole, the instrument cluster went dim, then a few mile later it went completely dark. The trunk release from the drivers door and the steering wheel radio controls stopped functioning as well. This car is stored in a garage and has 53,000 miles. I tried searching the forum, however the search function using for the forum never works properly when using mi iPhone
2k2s430 is online now  
Sponsored Links
Advertisement
 
post #2 of 21 (permalink) Old 07-04-2019, 01:08 PM
BenzWorld Elite
 
Date registered: Feb 2008
Vehicle: Too many to list
Location: USA
Posts: 8,277
Mentioned: 67 Post(s)
Quoted: 1532 Post(s)
Interesting , I’m guessing you ripped an electrical cable . Better get it to a mechanic and up on a lift before it dies completely in the garage
tusabes is online now  
post #3 of 21 (permalink) Old 07-04-2019, 05:04 PM Thread Starter
BenzWorld Member
 
Date registered: Dec 2003
Posts: 50
Mentioned: 2 Post(s)
Quoted: 11 Post(s)
Send a message via AIM to 2k2s430
(Thread Starter)
Quote:
Originally Posted by tusabes View Post
Interesting , Iím guessing you ripped an electrical cable . Better get it to a mechanic and up on a lift before it dies completely in the garage


You donít think it could be a cluster failure?
2k2s430 is online now  
Sponsored Links
Advertisement
 
post #4 of 21 (permalink) Old 07-05-2019, 12:20 AM
Moderator
 
Dave2302's Avatar
 
Date registered: Nov 2013
Vehicle: V220 Ambiente S500 W220 SLK320 R170 C200 CDI W203 Peugeot Expert Van
Location: NW Scotland Near Eilean Donan Castle
Posts: 5,191
Mentioned: 72 Post(s)
Quoted: 715 Post(s)
Lifetime Premium Member
Hi,

I know that Cluster can affect the Steering Wheel Buttons, it is also possible it may affect the Trunk Button Function, especially if there was an option for altering that switches function within your cluster menus

HTH,

Cheers Dave


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Dave


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Dave2302 is offline  
post #5 of 21 (permalink) Old 07-05-2019, 07:37 AM Thread Starter
BenzWorld Member
 
Date registered: Dec 2003
Posts: 50
Mentioned: 2 Post(s)
Quoted: 11 Post(s)
Send a message via AIM to 2k2s430
(Thread Starter)
Quote:
Originally Posted by Dave2302 View Post
Hi,

I know that Cluster can affect the Steering Wheel Buttons, it is also possible it may affect the Trunk Button Function, especially if there was an option for altering that switches function within your cluster menus

HTH,

Cheers Dave


Thank you Dave, thankfully I searched google and realized that this issue can be repaired. Then I also realized that I have a good friend who is an automotive electrical engineer whose area of expertise is circuit boards etc..
Dave2302 likes this.
2k2s430 is online now  
post #6 of 21 (permalink) Old 07-08-2019, 11:37 AM
BenzWorld Elite
 
Date registered: Dec 2012
Vehicle: 2003 S430
Location: Georgia, USA
Posts: 2,308
Mentioned: 95 Post(s)
Quoted: 377 Post(s)
We would like to know the final diagnosis and repair...

Wally
wallyp is offline  
post #7 of 21 (permalink) Old 07-09-2019, 12:09 AM
Moderator
 
Dave2302's Avatar
 
Date registered: Nov 2013
Vehicle: V220 Ambiente S500 W220 SLK320 R170 C200 CDI W203 Peugeot Expert Van
Location: NW Scotland Near Eilean Donan Castle
Posts: 5,191
Mentioned: 72 Post(s)
Quoted: 715 Post(s)
Lifetime Premium Member
Hi @wallyp ,

Sadly it looks like one of the other few cases we get of "I know what was wrong and you don't"

Yes @2k2s430

It is always nice for an OP to post up an idea of what exactly was done to repair etc, so that others may benefit from this in the future.

HTH,


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Dave


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Dave2302 is offline  
post #8 of 21 (permalink) Old 07-09-2019, 04:48 AM Thread Starter
BenzWorld Member
 
Date registered: Dec 2003
Posts: 50
Mentioned: 2 Post(s)
Quoted: 11 Post(s)
Send a message via AIM to 2k2s430
(Thread Starter)
Quote:
Originally Posted by Dave2302 View Post
Hi @wallyp ,

Sadly it looks like one of the other few cases we get of "I know what was wrong and you don't"

Yes @2k2s430

It is always nice for an OP to post up an idea of what exactly was done to repair etc, so that others may benefit from this in the future.

HTH,


As soon as I find out for sure, what is wrong, and how it was repaired I will most definitely share. I just have toooo many things going on at this time. Rest assured everyone I am not one of the cases of ďI know what was wrong, and donítĒ. It is a case of I have wayyyy to many things going on at one time, and my car can wait lol
Dave2302 likes this.
2k2s430 is online now  
post #9 of 21 (permalink) Old 07-09-2019, 11:03 AM Thread Starter
BenzWorld Member
 
Date registered: Dec 2003
Posts: 50
Mentioned: 2 Post(s)
Quoted: 11 Post(s)
Send a message via AIM to 2k2s430
(Thread Starter)
Only update I have is that I ordered a set of cluster removal keys, that way if as we suspect it is in need of having the transformer(s) replaces in the cluster I can do so with the quickness
2k2s430 is online now  
post #10 of 21 (permalink) Old 07-10-2019, 12:43 AM
Moderator
 
Dave2302's Avatar
 
Date registered: Nov 2013
Vehicle: V220 Ambiente S500 W220 SLK320 R170 C200 CDI W203 Peugeot Expert Van
Location: NW Scotland Near Eilean Donan Castle
Posts: 5,191
Mentioned: 72 Post(s)
Quoted: 715 Post(s)
Lifetime Premium Member
Hi,

Get the full kit if your friend is going to do it, there is Power Transistors and a few other bits known to give trouble as well as the transformer ..................

I don't know exactly, I send them to a specialist as I know of many folks who have ruined them trying to repair them ..................

SMD Soldering is not one of my better skills, due to ageing eyesight, but I am now doing simpler stuff like 8 leg chip swaps etc

Thanks for the update btw

Cheers Dave


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Dave


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Dave2302 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W220 S-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 3 (0 members and 3 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome