2006 S 600 - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 06-13-2019, 04:28 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Jun 2019
Vehicle: 2006 S600
Location: Springboro Ohio
Posts: 5
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
(Thread Starter)
2006 S 600

recently had battery issues had to jump car from passnger side floor board area because battery was completely dead keys in the trunk "comedy of errors" Any way Replaced battery cranks up and runs just fine.

However when I open the door no lights come on inside the car and the entire dash is completely black to include radio and Nav no door chimes nothing.
Driverside door panel is dead as well no lock window heat etc.
In addtion the wipers dont work now either. Oddly enough passenger side control function as normal Check fuses replaced a total from 5 to 20 amps.

Perplexed any ideas on what could be wrong ?????
Jv Lewis is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 06-13-2019, 04:45 PM
BenzWorld Elite
 
Michael Pillay's Avatar
 
Date registered: Oct 2003
Vehicle: 500SE AMG, E350 4matic, GL 450
Location: Michigan
Posts: 5,569
Mentioned: 0 Post(s)
Quoted: 129 Post(s)
You probably want the w220 forum
unavita likes this.

Mike
Michael Pillay is offline  
post #3 of 3 (permalink) Old 06-14-2019, 12:30 AM
Moderator
 
ianrandom's Avatar
 
Date registered: Jul 2008
Vehicle: 1986/1990 W126
Location: Berkshire & Devon, UK
Posts: 12,920
Mentioned: 28 Post(s)
Quoted: 1171 Post(s)
Lifetime Premium Member
Yes I think W220. Moving for you, hope you get it sorted. And welcome to the forum.

Thanks Ian, thread now locked as there is already one running here on W220 Forum for this problem

'86 420SE
'90 420SEC


Daily transport 9spd Giant DH Comp downhill bike

Last edited by Dave2302; 06-14-2019 at 02:21 AM.
ianrandom is offline  
Sponsored Links
Advertisement
 
Closed Thread

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W220 S-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome