EGR how do I get MAF out of the way? - Page 2 - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #11 of 16 (permalink) Old 06-08-2019, 04:41 PM
BenzWorld Member
 
Date registered: Feb 2009
Vehicle: '04 S430
Location: Murphy, TX
Posts: 252
Mentioned: 13 Post(s)
Quoted: 29 Post(s)
I used a wobble head extension to get the bold bolts.
ARES 70330 | 9-Piece Wobble Extension Set | Premium Chrome Vanadium Steel Construction | 1/4-inch, 3/8-inch and 1/2-inch Drive Sizes Included | Storage Tray Included https://www.amazon.com/dp/B07BW1764L..._7Be.CbWFWVQZF

I don't have that set in particular - just linked for reference. I got my set from Harbor Freight (cheap). It allows you to access bolts at an angle.

Sent from my Pixel 3 XL using Tapatalk
Dave2302 likes this.

-04 S430
-04 Terminator
-16 T&C (whole family van)
Huachipato is offline  
Sponsored Links
Advertisement
 
post #12 of 16 (permalink) Old 06-08-2019, 05:22 PM
BenzWorld Elite
 
Witek_M's Avatar
 
Date registered: Sep 2008
Vehicle: 1972
Location: Dallas, Texas
Posts: 6,362
Mentioned: 15 Post(s)
Quoted: 885 Post(s)
Quote:
Originally Posted by bmoe100 View Post
Got MAF out of the way. The main tube was fairly clean. One of 2 vacuum lines was old( I did not see a hole but it crumbled taking it off) so replaced both. I drove 60 miles but error code still on. In order to take EGR out(since check engine light still on) I need to access E or star socket underneath the round metal pipe that is running from 6 to 3 o clock. How do I access it? Is there a trick? The round pipe would seem to be hard to get off. To get the yellow clip off do I squeeze the wires or pull them apart?
Are Pierburg EGR valves ok?
Thanks
EGR function is evaluated by MAP sensor on front if intake manifold. Remove air pump and check, replace vacuum lines leading to MAP and SAI valve.

To remove EGR valve you need 1/4 E10 swivel socket.
Dave2302 likes this.

1972 280SEL 4.5
1999 ML320
2000 E320
2003 ML350
Witek_M is offline  
post #13 of 16 (permalink) Old 06-09-2019, 02:26 AM
Moderator
 
Dave2302's Avatar
 
Date registered: Nov 2013
Vehicle: V220 Ambiente S500 W220 SLK320 R170 C200 CDI W203 Peugeot Expert Van
Location: NW Scotland Near Eilean Donan Castle
Posts: 5,202
Mentioned: 73 Post(s)
Quoted: 720 Post(s)
Lifetime Premium Member
Pierburg are an OEM, yep fine


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Dave


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Dave2302 is offline  
Sponsored Links
Advertisement
 
post #14 of 16 (permalink) Old 06-10-2019, 05:17 PM Thread Starter
BenzWorld Member
 
Date registered: Apr 2015
Posts: 50
Mentioned: 0 Post(s)
Quoted: 13 Post(s)
(Thread Starter)
Thanks everyone
Pierburg is fine if I need it
so I need a wobble extension
I drove another 80 miles and light went out. The degraded hose may have been a factor. Will see.
Witek If error code comes back will try to find air pump and related hoses before changing EGR
bmoe100 is offline  
post #15 of 16 (permalink) Old 06-11-2019, 08:01 AM
BenzWorld Member
 
Date registered: May 2011
Vehicle: 2005 S600
Location: Virginia Beach
Posts: 371
Mentioned: 14 Post(s)
Quoted: 54 Post(s)
In addition to wobble extensions, and universal joints/extension, I have this set, purchased just to enable me to get at things on the MB:

https://www.amazon.com/gp/product/B0...?ie=UTF8&psc=1

Universal sockets are compact enough to get in spaces where a socket + universal extension, or socket + wobble extension cannot.
Dave2302 likes this.

Current Fleet:
2016 Tundra 1794
2005 MB S600 (100K, Michelin AS3+, M1 0W40)
2002 V70-XC (228K Castrol 0W40)
2002 V70-T5 (198K, Mobil 1 0W40)
1932 Packard Sedan (straight 8, dual sidemount spares, original paint and interior, Shell Rotella 15W40)
Astro14 is offline  
post #16 of 16 (permalink) Old 06-12-2019, 05:49 AM
BenzWorld Elite
 
Witek_M's Avatar
 
Date registered: Sep 2008
Vehicle: 1972
Location: Dallas, Texas
Posts: 6,362
Mentioned: 15 Post(s)
Quoted: 885 Post(s)
Quote:
Originally Posted by bmoe100 View Post
If error code comes back will try to find air pump and related hoses before changing EGR
Remove air pump (5) and replace vacuum hoses 119. Going back don't forget to put air pump ground wire over bolt 23.
Attached Thumbnails
Click image for larger version

Name:	2019-06-12_072936.jpg
Views:	7
Size:	133.4 KB
ID:	2519698  
Dave2302 likes this.

1972 280SEL 4.5
1999 ML320
2000 E320
2003 ML350
Witek_M is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W220 S-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome