2006 S55 AMG not seeing any Sam Module from MKII - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 58 (permalink) Old 05-10-2019, 01:09 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Apr 2019
Vehicle: 2006 S55 AMG, 2011 R350 Bluetec
Location: Orange County California
Posts: 24
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
(Thread Starter)
2006 S55 AMG not seeing any Sam Module from MKII

Hi All,

I recently purchased a 2006 S55 AMG and at first everything seem to be ok then now the car seems to be haunted. I start the car and I get ABC rising and SRS error, Display error, and the fuel gauge go up then down. So I purchased an MKII reader and thought it would read all the modules and it seems not to be reading any of the SAM modules. Should I take it to a Mercedes dealership and let them diagnose it?

mpninc is offline  
Sponsored Links
Advertisement
 
post #2 of 58 (permalink) Old 05-10-2019, 01:20 PM
BenzWorld Member
 
Date registered: Feb 2009
Vehicle: '04 S430
Location: Murphy, TX
Posts: 252
Mentioned: 13 Post(s)
Quoted: 29 Post(s)
Test your Battery and charging system (alternator).

-04 S430
-04 Terminator
-16 T&C (whole family van)
Huachipato is offline  
post #3 of 58 (permalink) Old 05-10-2019, 01:24 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Apr 2019
Vehicle: 2006 S55 AMG, 2011 R350 Bluetec
Location: Orange County California
Posts: 24
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
(Thread Starter)
Huachipato - Oh I thought that was the case too so I replaced the alternator and still the same problem.
mpninc is offline  
Sponsored Links
Advertisement
 
post #4 of 58 (permalink) Old 05-10-2019, 01:26 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Apr 2019
Vehicle: 2006 S55 AMG, 2011 R350 Bluetec
Location: Orange County California
Posts: 24
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
(Thread Starter)
Do you think I would need to reprogram the ECU if I replaced the alternator?
mpninc is offline  
post #5 of 58 (permalink) Old 05-10-2019, 01:31 PM
BenzWorld Member
 
Date registered: Feb 2009
Vehicle: '04 S430
Location: Murphy, TX
Posts: 252
Mentioned: 13 Post(s)
Quoted: 29 Post(s)
Still could be a bad battery. I think the charging system in my car is good to but I still had this happen when I brought the car to a complete stop:

I got the car to behave normal after putting a charger on the battery for a few hours.

-04 S430
-04 Terminator
-16 T&C (whole family van)
Huachipato is offline  
post #6 of 58 (permalink) Old 05-10-2019, 01:34 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Apr 2019
Vehicle: 2006 S55 AMG, 2011 R350 Bluetec
Location: Orange County California
Posts: 24
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
(Thread Starter)
ok I will try that. thanks!
mpninc is offline  
post #7 of 58 (permalink) Old 05-10-2019, 02:55 PM
BenzWorld Elite
 
Date registered: Feb 2008
Vehicle: Too many to list
Location: USA
Posts: 8,280
Mentioned: 67 Post(s)
Quoted: 1533 Post(s)
What is the date code on the battery ? It may not be strong enough to hold the charge or have a bad cell. Take it to auto parts store they can check it in the car.

If it’s more than 3 years old Just get a new battery

Also have you left it outside in the rain or been through a car wash ? These cars are notorious for water damage to SAM from rain or car wash

Lastly are your power windows having trouble operating ? The door control module is interconnected and known for causing these haunted electrical issues too

Last edited by tusabes; 05-10-2019 at 03:12 PM.
tusabes is online now  
post #8 of 58 (permalink) Old 05-10-2019, 03:26 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Apr 2019
Vehicle: 2006 S55 AMG, 2011 R350 Bluetec
Location: Orange County California
Posts: 24
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
(Thread Starter)
My battery is fairly new just a couple months old.
mpninc is offline  
post #9 of 58 (permalink) Old 05-10-2019, 03:30 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Apr 2019
Vehicle: 2006 S55 AMG, 2011 R350 Bluetec
Location: Orange County California
Posts: 24
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
(Thread Starter)
Also forgot to mention that the car will start and run but as I am driving it, it would seem like the ECU would reboot and check everything and start to work and it would continue to do this. Also, my headlight clicks on and off during the day but if it is night t would come on and stay on.
mpninc is offline  
post #10 of 58 (permalink) Old 05-10-2019, 04:48 PM
BenzWorld Member
 
Date registered: Feb 2009
Vehicle: '04 S430
Location: Murphy, TX
Posts: 252
Mentioned: 13 Post(s)
Quoted: 29 Post(s)
You can try the battery voltage display. Car on, engine off- milage display. Hit the "R" button 3 times real quick. The display should change to battery voltage.

Start car and see what it shows. It ideally should always be over 13 volts.

Car starting should not drop below 10.5 on a good battery (so I've read on these here forums anyways).

Sent from my Pixel 3 XL using Tapatalk

-04 S430
-04 Terminator
-16 T&C (whole family van)
Huachipato is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W220 S-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
2006 Mercedes-Benz S55 AMG For Sale Scarlet_Pimpernel For Sale/Wanted/Trade/Giveaway 0 02-12-2014 12:55 PM
Useful links 4 new members - repost Bazzle R170 SLK-Class 79 02-06-2011 09:45 PM
Sultan of Brunei's MBenz SL's [VIN] collection _S3C_ R129 SL-Class 27 01-04-2011 08:57 AM
Mercedes-Benz Unveils R63 AMG and ML63 AMG Models Wolfgang W251 R-Class 1 02-11-2006 01:30 PM
Long sucess history Zé Bocaina G-Class 3 05-27-2005 01:19 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome