Thumping and Rattling on New Strut Installation - Page 4 - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #31 of 39 (permalink) Old 06-06-2019, 12:15 AM
Moderator
 
Dave2302's Avatar
 
Date registered: Nov 2013
Vehicle: V220 Ambiente S500 W220 SLK320 R170 C200 CDI W203 Peugeot Expert Van
Location: NW Scotland Near Eilean Donan Castle
Posts: 5,219
Mentioned: 73 Post(s)
Quoted: 728 Post(s)
Lifetime Premium Member
Quote:
Originally Posted by Triple cranks View Post
While doing a service (expansion hose - arggg!!!) I noticed both front strut boots are split. It must have just recently happened as both are impeccably clean inside. Are just the boots available and is it pretty straight forward?

I'm without SDS again. The Windows activation is acting up again so no WIS to work with until I get that sorted. Already have a few hours invested not to mention over $900 trying to get it up and running again. Thinking of just tossing the works and going the C4 route.
Hi TC,

I don't think it has anything to do with C3 or C4, I've had Windows Activation become a royal pain when I've simply done a RAM upgrade, BIOS Upgrade etc ...................

Fear not young man, there is an easy fix, go on EBay and buy another Windows Activation code which will be emailed to you, generally I pay around 3.00 to 6.00 depending how quick I want it and what is available at the time. Switch off the Updates, (XP and Win 7), don't go on internet unless you really have to, (like to do new activation), and she'll be good for years.
I do believe each time Windows does an update it becomes a little nearer extinction due to the "Windows" folk wanting you to upgrade to 10 so they / whoever gradually bomb your 'pooter until the average Joe just buys a new one, and then can then spy on you more.

I have many machines, which I loaded up originally, then switched off all updates and switched off Wi Fi never to go on t'internet again ........................

They run faultlessly and have done for years.

The ones that I get grief with are the ones I use on the Internet, especially each time they do an update ................ Haven't found a way to turn of Windows 10 updates, I don't think you actually can do this

This is one "Mothership" I really do detest, and lots of it on my Win 10 "Daily Driver" is to do with Skype updates and I use skype a lot so have to have it on that one !!

I expect @cowboyt will be able to tell us more about this

Quote:
Originally Posted by 4DGeorge View Post
I replaced one of my front strut boots. It's fairly easy. All you need to do is take off the lower rear control arm. Once it's unhooked from the bottom of the strut, you can unclip and slide the old boot off.
I noticed the strut casing felt a little rough where the air bag would come in contact. A few minutes of elbow grease + 1200 grit smoothed things out.
Sliding the new boot up only took a little bit of work as the smallest end had to be stretched slightly to get on.
I bought 2 replacement boots from Alibaba. $7.50
https://m.alibaba.com/product/608549...46e16a95iEkQuT
Hi 4DG,

Thank you for that

I'm glad to hear they actually go over the Valve at the bottom ok, I've never done one, but I will now before my W220 hits the road for good, as it has 2 with small splits, the other 2 struts are new MB


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Dave


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Dave2302 is offline  
Sponsored Links
Advertisement
 
post #32 of 39 (permalink) Old 06-06-2019, 05:15 AM Thread Starter
BenzWorld Elite
 
Date registered: Dec 2012
Vehicle: 2003 S430
Location: Georgia, USA
Posts: 2,315
Mentioned: 96 Post(s)
Quoted: 377 Post(s)
(Thread Starter)
"I'm without SDS again. The Windows activation is acting up again so no WIS to work with until I get that sorted. Already have a few hours invested not to mention over $900 trying to get it up and running again. Thinking of just tossing the works and going the C4 route."

I have now installed and used four different versions of SDS - none have needed any Windows activation nor upgrades. As Dave says, install the software, kill internet access and drive on. This is the best argument for using a dedicated DAS-only laptop.
Dave2302 likes this.

Wally
wallyp is online now  
post #33 of 39 (permalink) Old 06-06-2019, 08:01 AM
BenzWorld Elite
 
Date registered: May 2016
Vehicle: 2000 S430, 2003 S430, 2003 S600 TT, and 2005 E320 CDI
Location: USA
Posts: 3,836
Mentioned: 170 Post(s)
Quoted: 965 Post(s)
My SDS runs on Windoze XP. It does *not* touch the Internet. It does *not* get hooked up to anything other than the MUX. It will *not* contact the Micro$oft Mother$hip, and it will *not* get upgraded to Winblow$ 10.

For Skype updates, it can be done, offline. It requires good ol' sneakernet (i. e. a USB thumb drive or a CD-ROM). You'd download the Skype installation program to your offline medium, walk it over to your box, and then do the install. Problem: to actually use Skype, you need to be on the Internet anyway, so you're in a Catch-22. Soon as you hook up to make that call, your box is going to call the Mother$hip. There are ways, with packet-sniffers (e. g. Wireshark), to find out the IP address ranges that Micro$oft uses for this, but that's pretty high-level technical stuff.

This, BTW, is why I run GNU/Linux or BSD on everything other than my SDS box. In the case of my "daily driver" workstation, it's Kubuntu 18.04 "Bionic Beaver", currently the latest Long-Term-Support version. I love it.
Dave2302 likes this.

2000 S430 (Dad's car, used for special occasions)
2000 S500 (wife's DD: my first W220 project car)
2003 S600 ("sex on wheels"--second w220 project car)
2003 S430 (one of two current DD's--third W220 project car)
2005 E320 CDI (the other current DD--first W211 project car)
cowboyt is offline  
Sponsored Links
Advertisement
 
post #34 of 39 (permalink) Old 06-06-2019, 08:08 AM
Moderator
 
Dave2302's Avatar
 
Date registered: Nov 2013
Vehicle: V220 Ambiente S500 W220 SLK320 R170 C200 CDI W203 Peugeot Expert Van
Location: NW Scotland Near Eilean Donan Castle
Posts: 5,219
Mentioned: 73 Post(s)
Quoted: 728 Post(s)
Lifetime Premium Member
All of my Dell's for Diagnostic machines, Disco machines, and now my Programming Laptop (wooo-hooo) , are on Windows 7 and they do need activation code, but once installed and updated they never go back on the net, (well except if doing a TV with someone and I know the s/w is ok with that), but Win 7 you can actually make sure it doesn't update itself

I have a "Master HDD" which is all installed with Win 7 Pro, and was updated to Jan this year, (it will get no more), it also has A19 Dell Bios Upgrader, Java, MS Office Suite, my HP Printer/ Scanner s/w, Adobe, VLC, Photo Shop, Endoscope s/w etc and each time I build a new machine I just take an Acronis Clone of that one and add whatever s/w I want, saves having to do all the installing [email protected] each time

Each time I do an install, I buy an EBay Windows Activation Key, go online and Activate, then switch off the Internet Wireless once done, the Printer is on a Private "Workshop" Wireless Network as is my C4 Mux and a few other goodies.

Note that on the ones that never go on the Internet I do not even install an Antivirus Prog as some Diagnostic and Programming s/w doesn't play well with AV !!

HTH,


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Dave


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Dave2302 is offline  
post #35 of 39 (permalink) Old 06-06-2019, 09:01 AM
BenzWorld Elite
 
Date registered: May 2016
Vehicle: 2000 S430, 2003 S430, 2003 S600 TT, and 2005 E320 CDI
Location: USA
Posts: 3,836
Mentioned: 170 Post(s)
Quoted: 965 Post(s)
Quote:
Originally Posted by 4DGeorge View Post
By the way, I did receive the core refund when I sent in my failed 1yr old Chinesium rear strut to FCPEuro. Now I'm starting to hear that tel-tale thumping coming from the other rear strut. (FYI those were installed by the previous owner right before I bought the car) Dang those Chinesium things are cheap! Same goes for the front ball joints I threw on right after getting the vehicle (last February). So last weekend I replaced both front ball joints with Lemforder. No more squeaking!
As for the one Arnott rear strut I installed, as far as I can tell it still has the active damping and switches between the three settings (Comfort, Sport 1, and Sport 2).
I just checked the prices on RockAuto for the Bilstein vs Arnott. (base model air springs, w/o ABC, non-4MATIC) $128 difference for the rear ones, same price for the front ones. However, FCPEuro still has a far cheaper price for the Arnott than on RockAuto. But FCPEuro's Bilsteins are way more expensive.
Welcome to the Light Side of the Force. :-)

Fortunately, it's generally the front AIRmatic springs that need replacing the most often, and it makes sense to go Bilstein at those (RockAuto) prices. I have yet to have to do a rear, but eventually the time will come. FCPEuro has always been pricey for Bilstein-brand springs.

BTW, the replacement Arnott front right spring appears to be working great. No more code. So, yeah, one may fail on occasion, but the warranty service is on point. Gotta respect that, too.

Interesting little anecdote: there's a local-ish guy who's been trying to sell a Strutmasters coil-over conversion kit, apparently with the computer module, for several months now. It's specific to the S430 and S500 cars. He eventually dropped the price to something somewhat reasonable. So, I called him one morning, and his whole attitude was that he was doing me some sort of favour by making time for me to see them (it's actually a shop, he said). I called him again later early afternoon to see about going to have a look at 'em. He says, "I'm not available today." Silence. Oh, really, and it's a shop, which is open until 7pm on Saturday? Sounds like he doesn't really want to sell this set, and I tell him so. I end the call right as he's saying, "well, I'm available tomorrow". Too late, pal, I don't like your attitude, you're too difficult to deal with. What is up with some sellers?
Dave2302 likes this.

2000 S430 (Dad's car, used for special occasions)
2000 S500 (wife's DD: my first W220 project car)
2003 S600 ("sex on wheels"--second w220 project car)
2003 S430 (one of two current DD's--third W220 project car)
2005 E320 CDI (the other current DD--first W211 project car)
cowboyt is offline  
post #36 of 39 (permalink) Old 06-06-2019, 09:13 AM
Lifetime Premium Member
 
4DGeorge's Avatar
 
Date registered: Jan 2018
Vehicle: 2006 S500 (W220, Designo Espresso, AMG Sport, LWB)
Location: Houston, Texas, USA
Posts: 312
Mentioned: 15 Post(s)
Quoted: 41 Post(s)
Lifetime Premium Member
Garage
Quote:
Originally Posted by cowboyt View Post
Welcome to the Light Side of the Force. :-)


What is up with some sellers?
Some sellers apparently need a little "thumping and rattling."
Dave2302 likes this.
4DGeorge is offline  
post #37 of 39 (permalink) Old 06-09-2019, 09:13 PM
BenzWorld Senior Member
 
Date registered: Jun 2018
Vehicle: 2005 SL65 plus 13 other non MB toys
Location: Maryland
Posts: 567
Mentioned: 16 Post(s)
Quoted: 84 Post(s)
Thanks for the link. However, my car has the ABC suspension not air. Still looking for the dust cover. Alibaba doesn't carry it. 🤔
Triple cranks is offline  
post #38 of 39 (permalink) Old 06-10-2019, 09:21 AM
Lifetime Premium Member
 
4DGeorge's Avatar
 
Date registered: Jan 2018
Vehicle: 2006 S500 (W220, Designo Espresso, AMG Sport, LWB)
Location: Houston, Texas, USA
Posts: 312
Mentioned: 15 Post(s)
Quoted: 41 Post(s)
Lifetime Premium Member
Garage
Quote:
Originally Posted by Triple cranks View Post
Thanks for the link. However, my car has the ABC suspension not air. Still looking for the dust cover. Alibaba doesn't carry it. ��
Um....well...er... Did you search for "ABC Dust Cover Mercedes W220?" I was presented with pages of them when I did. ;-)
https://www.alibaba.com/trade/search...+Mercedes+W220
Given how inexpensive they are, I would suggest buying an extra pair ... just in case.
Dave2302 likes this.
4DGeorge is offline  
post #39 of 39 (permalink) Old 06-15-2019, 05:25 AM
BenzWorld Senior Member
 
Date registered: Jun 2018
Vehicle: 2005 SL65 plus 13 other non MB toys
Location: Maryland
Posts: 567
Mentioned: 16 Post(s)
Quoted: 84 Post(s)
I guess I overlooked the obvious. I searched SL65. Thanks again for the link.
4DGeorge likes this.
Triple cranks is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W220 S-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
300TD Loud thumping noise in rear hthmo W123 E,CE,D,CD,TD,TE Class 5 08-27-2008 04:31 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome