Android head unit install, anyone have questions? - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 331 (permalink) Old 05-02-2018, 07:38 AM Thread Starter
BenzWorld Veteran
 
Date registered: Oct 2005
Vehicle: 13 GLK350, 03 c320 wagon, 90 560sec
Location: Normandy Park, WA
Posts: 765
Mentioned: 3 Post(s)
Quoted: 81 Post(s)
(Thread Starter)
Android head unit install, anyone have questions?

jjcarrs Android Install Threads in Encyclopaedia Post #5 here:-

https://www.benzworld.org/forums/w220...ml#post4298905

I'm going to install one of these in my 03 s500. Anybody have any install/usage questions? I figure if I know before I do the install I can take pics or remember to note details about the question while doing it. Will probably install in the next few weeks.
Attached Thumbnails
Click image for larger version

Name:	s-l1600.jpg
Views:	348
Size:	61.9 KB
ID:	2424339  

Last edited by Dave2302; 07-09-2018 at 12:44 AM.
jjcarr is offline  
Sponsored Links
Advertisement
 
post #2 of 331 (permalink) Old 05-02-2018, 07:47 AM
BenzWorld Member
 
Date registered: Feb 2009
Vehicle: '04 S430
Location: Murphy, TX
Posts: 252
Mentioned: 13 Post(s)
Quoted: 29 Post(s)
I'm interested in doing this with my car. I'd like a detailed install if you can make it. I'm curious how it interfaces with the fiber optic system - if it uses the stock amps/speakers - does it work well with the instrument cluster... etc....

You have a 2003, isn't that a one off year for that radio design? Or is it the same interface with '04 - '06?

-04 S430
-04 Terminator
-16 T&C (whole family van)
Huachipato is offline  
post #3 of 331 (permalink) Old 05-02-2018, 07:58 AM
BenzWorld Member
 
Date registered: Jan 2018
Vehicle: '04 S500 4Matic
Location: Toronto, Canada
Posts: 303
Mentioned: 4 Post(s)
Quoted: 44 Post(s)
This is really interesting. I have thought about doing this but I was concerned about potential battery drain with things not going to sleep properly.
For the physical install I am interested to hear what else has to be done other than removing the old unit and installing the new one.
Thanks
Oliver
oliverp is offline  
Sponsored Links
Advertisement
 
post #4 of 331 (permalink) Old 05-02-2018, 08:12 AM
BenzWorld Junior Member
 
Date registered: Mar 2017
Vehicle: 2003 S55
Location: Newhall CA
Posts: 7
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
All good questions that I would like to know too.... My 03 could really use something like this!

Sent from my LG-H932 using Tapatalk
nckwltn is offline  
post #5 of 331 (permalink) Old 05-02-2018, 08:21 AM Thread Starter
BenzWorld Veteran
 
Date registered: Oct 2005
Vehicle: 13 GLK350, 03 c320 wagon, 90 560sec
Location: Normandy Park, WA
Posts: 765
Mentioned: 3 Post(s)
Quoted: 81 Post(s)
(Thread Starter)
Quote:
Originally Posted by Huachipato View Post
You have a 2003, isn't that a one off year for that radio design? Or is it the same interface with '04 - '06?
03 is a different interface protocol. I think this head unit will interface more directly with the 04-06. I fully expect I'll have to use an external amplifier in my 03 and skip the optical interface. The eBay ad "claims" it works with 2000-2006, but I assumed it's really 04+. I doubt I'll be able to make it work with the steering wheel controls on my car, but on an 04+ it should work.
jjcarr is offline  
post #6 of 331 (permalink) Old 05-02-2018, 08:22 AM Thread Starter
BenzWorld Veteran
 
Date registered: Oct 2005
Vehicle: 13 GLK350, 03 c320 wagon, 90 560sec
Location: Normandy Park, WA
Posts: 765
Mentioned: 3 Post(s)
Quoted: 81 Post(s)
(Thread Starter)
BTW, it's worth noting that I ordered it on Saturday and received it on Tuesday, all the way from China. Shipping was impressively fast.
Dave2302 likes this.
jjcarr is offline  
post #7 of 331 (permalink) Old 05-02-2018, 08:38 AM
BenzWorld Junior Member
 
Date registered: Apr 2018
Vehicle: 1966 250s 02 s430 01 e430
Location: ROSENBERG TEXAS
Posts: 44
Mentioned: 0 Post(s)
Quoted: 8 Post(s)
post a video of its operation and user interface once your complete
Dave2302 and jlexvold like this.
Anil Rehmatullah is offline  
post #8 of 331 (permalink) Old 05-02-2018, 09:11 AM
BenzWorld Elite
 
Date registered: May 2016
Vehicle: 2000 S430, 2003 S430, 2003 S600 TT, and 2005 E320 CDI
Location: USA
Posts: 3,828
Mentioned: 169 Post(s)
Quoted: 962 Post(s)
My Dad's car will eventually get a new head unit. Not sure whether it'll be a new Android unit or a DOPF factory unit; still deciding. It's an '00 S430, which, like your '03 S500, uses D2B.
Dave2302 likes this.

2000 S430 (Dad's car, used for special occasions)
2000 S500 (wife's DD: my first W220 project car)
2003 S600 ("sex on wheels"--second w220 project car)
2003 S430 (one of two current DD's--third W220 project car)
2005 E320 CDI (the other current DD--first W211 project car)
cowboyt is offline  
post #9 of 331 (permalink) Old 05-02-2018, 10:04 AM
Moderator
 
Dave2302's Avatar
 
Date registered: Nov 2013
Vehicle: V220 Ambiente S500 W220 SLK320 R170 C200 CDI W203 Peugeot Expert Van
Location: NW Scotland Near Eilean Donan Castle
Posts: 5,191
Mentioned: 72 Post(s)
Quoted: 715 Post(s)
Lifetime Premium Member
Hi Guys,

This has been covered in depth loads on benzworld, search search search.

I have written a load about it too.

FO will only work with later system post 2003 IIRC.

The newest ones are now ERISIN Android 8.0 with 8Gb and potentially 4X 32Gb Media (2 SD Cards and 2 USB).

If you go for a decent Amplifier you can forget the F/O and use a 32Gb SD Card for all your Music, dump that ailing and dated CD Player and Navi Drive.

Without COMAND you will not get a Battery Drain, on Post Facelift Cars you may have to code COMAND not present in CGW, never done Post Facelift

Most all Steering Wheel Buttons will work with it if it is wired up correctly and Menu's configured right.
Steering Wheel buttons for the rest of the Cars functions remain working.
Same for some of the Dash Cluster info, it will display Radio and Track Info.
It doesn't display Nav Info on the dash, but it does have a nice big Screen compared to the clunky old COMAND !!

A load of people say they don't work because they don't understand that if CAN Bus is wired right you do not have to connect up a lot of the wires !! If you blindly connect everything then you will get conflicts.

The Motherboard / Main Board is generic and used in other shaped Head Units, so it comes with these wires, but you simply don't connect them on CAN Bus Cars like a Benz

Final Icing on the Cake is the FM Radio and Navi will work with the good MB Amplified Antennas, the TV and DAB probably will too, I went in depth with that too a while back

Sadly I've not yet tried the TV and DAB as I am too busy right now to finish my Car off

What with my busy Business and the current "Family Crisis" that is now destroying yet another year of Mels' and my own life, after the previous 3 years of In Laws I thought I'd at least get a break

How dumb was I

Anyway, yeah, great units, get one and get stuck in, take pix, post up an Install diary, and if you get really stuck ask and I'll help if I can

Mine is also having 2 Headrests with DVD / Monitors as well as all the Cameras and TPMS, Internet etc when I finally get to it, it is all sat waiting patiently in a box in my Workshop

HTH,

Cheers Dave
Tiger_one and MikeKerr like this.

Last edited by Dave2302; 05-02-2018 at 10:07 AM.
Dave2302 is offline  
post #10 of 331 (permalink) Old 05-04-2018, 09:32 AM
BenzWorld Junior Member
 
Date registered: Mar 2018
Vehicle: 2005 S55 AMG
Location: California
Posts: 46
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
I plan to eventually install one of these into my '05 AMG as well. Initially I'll just to the head unit and leave everything else factory. The 2nd stage will be proper components up front and multiple amplifiers.

I use bluetooth almost exclusively, so I'd like your feedback on sound quality in general and specifically through BT. I stream all my music, so I know I won't be getting audiophile quality.
Hubbard 0 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W220 S-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 5 (0 members and 5 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome