Airmatic Complete Failure - s430 2001 - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 08-24-2016, 07:38 AM Thread Starter
BenzWorld Newbie
 
Date registered: Aug 2016
Posts: 1
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
(Thread Starter)
Airmatic Complete Failure - s430 2001

Hello all,

Hopefully I am not overwriting a thread, but I have looked for a good 20 min and not found anything similar to my issue.

I recently successfully replaced the front 2 airmatic shocks on my s430 as they had trouble holding air for any amount of prolonged time. The installation was generally smooth and I was pleased with the results. For about 3 weeks I had no problems, then one night I came out to find that my rear shock was fully down. It raised back up and I was able to get home. I figure I needed to do the rear shocks as well just didn't expect it so soon.

My question comes from today. This morning I walked out and all 4 struts were completely down. I can not figure out any explanation for this, unless I had all 4 shocks fail at the same time. From my understanding each of the struts are independent of each other in the way that they are filled up, is this correct?

Has anyone seen this before? I am sad to see this car be such a pain as I have had such good luck with my previous Mercedes.

Thanks!
Toby Cain is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 08-25-2016, 11:59 AM
BenzWorld Member
 
Date registered: Oct 2010
Vehicle: 2004 S500 4Matic Granite Grey
Location: Evergreen, CO
Posts: 90
Mentioned: 0 Post(s)
Quoted: 12 Post(s)
My understanding is that this is generally a valve block leak. That is the common part for all of the shocks. If you search for that you may find testing procedures for the valve block.

G.
Ghanziang is offline  
post #3 of 4 (permalink) Old 08-25-2016, 08:46 PM
BenzWorld Junior Member
 
txmercedeslover's Avatar
 
Date registered: Apr 2012
Vehicle: 2004 S500 4Matic
Location: Austin, Texas
Posts: 23
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
Garage
Since it sounds like a central issue, it has to be the valve block. Have you received an Airmatic warning? Regardless, you should have the codes read to determine exactly what's happening so that you don't continue replacing parts unnecessarily.
txmercedeslover is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 08-28-2016, 04:43 AM
BenzWorld Extremist
 
salman108's Avatar
 
Date registered: Mar 2011
Vehicle: Mercedes S500 - W140 && S500 W220.
Location: Middle East
Posts: 817
Mentioned: 4 Post(s)
Quoted: 75 Post(s)
You should have been able to search relevant threads,

Nevertheless,

You need access to STAR diagnostic computer, it has an elaborate set of tests that will help you identify which portion exactly is leaking
from the pump uptil the distribution lines and shocks.

PS: it is common that if 1 or 2 shocks are leaking, they will cause the whole system to loose pressure. that does not mean the other shocks are bad it is just that there isn't enough pressure left in the central reservoir to support them.



Quote:
Originally Posted by Toby Cain View Post
Hello all,

Hopefully I am not overwriting a thread, but I have looked for a good 20 min and not found anything similar to my issue.

I recently successfully replaced the front 2 airmatic shocks on my s430 as they had trouble holding air for any amount of prolonged time. The installation was generally smooth and I was pleased with the results. For about 3 weeks I had no problems, then one night I came out to find that my rear shock was fully down. It raised back up and I was able to get home. I figure I needed to do the rear shocks as well just didn't expect it so soon.

My question comes from today. This morning I walked out and all 4 struts were completely down. I can not figure out any explanation for this, unless I had all 4 shocks fail at the same time. From my understanding each of the struts are independent of each other in the way that they are filled up, is this correct?

Has anyone seen this before? I am sad to see this car be such a pain as I have had such good luck with my previous Mercedes.

Thanks!

Proudly cruising in W-140, 1998 S-500
salman108 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W220 S-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome