S500 W220 Automatic trunk opener fix - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 28 (permalink) Old 08-10-2012, 11:52 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Dec 2009
Posts: 12
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
S500 W220 Automatic trunk opener fix

Hi guys, have a S55 AMG and my automatic power trunk opener stopped working. First it started only lifting the trunk half way, then it quit alltogether. Heard a groaning noise coming from the hydrolic cylinder under the side trunk trim. Benz dealer told me I need to replace the whole pump/cylinder assembly. $1,100. GASP. took the car home and pulled the pump out from by the battery. It has a resevior to hold hydro fluid. Looking further I notice little to no fluid in that resevior. Took the clamp off and twisted the resevior off, (only sealed by an "O" ring) it was empty. Took some ATF/ power steering fluid and filled it up, slid back on, replace clamp......WORKS as new! I did not find this procedure anywhere so I decided to give this shout out. There may be a small leak by the hydro cylinder where it was loosing the fluid. I bet it lasts for years though. Hopefully this can help someone to do it yourself, service, not replace!
StigHelmer likes this.
craigndee is offline  
Sponsored Links
Advertisement
 
post #2 of 28 (permalink) Old 08-10-2012, 12:30 PM
BenzWorld Member
 
Date registered: Jul 2011
Vehicle: S320 W220
Location: Lebanon
Posts: 117
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
Sounds interesting and cool your DIY though I don't have the automatic trunk opener feature.
Thanks for sharing!
mghaz is offline  
post #3 of 28 (permalink) Old 10-08-2012, 12:49 PM
BenzWorld Member
 
TxML320's Avatar
 
Date registered: Jan 2003
Vehicle: 2002 S430, 2002 Camaro SS, 2010 Navigator
Location: Austin, TX
Posts: 111
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
I am having this same issue with my hydrolic pump for the Trunk opener, I will try this fix as the dealership quoted me $800 to replace the pump as it was a non-serviceable part! I noticed the clamp holding the reservoir and it was only half full, but they told me it was a sealed system and the fluid could not be topped off. Thanks for the info!!

2002 S430 Black with Java Leather. Keyless Go, Rear Side and Back Window Roller Blinds, Electronic Trunk Opener, S3 Comfort Package, Integrated Motorola V60 (now replaced with Motorola Bluetooth Puck) with Voice Control, and CD changer. Chrome AMG split spoke wheels witth Michelin Pilot A/S Plus tires

2010 Lincoln Navigator Tuxedo Black Metallic Black Leather Interior, every option.

2002 Silver Camaro SS #8539 Ebony Leather, every option. 496 RWHP 536 Torque
TxML320 is offline  
Sponsored Links
Advertisement
 
post #4 of 28 (permalink) Old 10-08-2012, 03:11 PM
BenzWorld Senior Member
 
Date registered: Jan 2008
Vehicle: 98 ML320, 01 S500, 15 GL350
Posts: 584
Mentioned: 0 Post(s)
Quoted: 7 Post(s)
Can someone post a picture of the pump?
idahombz is offline  
post #5 of 28 (permalink) Old 10-08-2012, 04:53 PM
BenzWorld Junior Member
 
Date registered: Jan 2007
Vehicle: 2003 S55K, 2002 W220 S430 (RIP), 1999 W163 ML430, 2004 W230 SL500 Sport
Location: Northern CA USA
Posts: 49
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Thanks for Sharing the information. I will check my fluid. Mine intermittently when the trunk is raised will start to go down after a few seconds. It started doing it but not all the time. From the ssound of it maybe i have a small leak in the supposedly "sealed" system. Now I know where the reservoir is. Thanks.
wsy3benz is offline  
post #6 of 28 (permalink) Old 10-08-2012, 05:37 PM
BenzWorld Member
 
TxML320's Avatar
 
Date registered: Jan 2003
Vehicle: 2002 S430, 2002 Camaro SS, 2010 Navigator
Location: Austin, TX
Posts: 111
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
I just filled my reservoir all the way up with power steering fluid and now my trunk goes all the way up quickly and stays up until I push the button to make it go back down, that's so much Craig for finding and posting this fix!!! This issue has been driving me crazy for years, but not $800 crazy! Lol

2002 S430 Black with Java Leather. Keyless Go, Rear Side and Back Window Roller Blinds, Electronic Trunk Opener, S3 Comfort Package, Integrated Motorola V60 (now replaced with Motorola Bluetooth Puck) with Voice Control, and CD changer. Chrome AMG split spoke wheels witth Michelin Pilot A/S Plus tires

2010 Lincoln Navigator Tuxedo Black Metallic Black Leather Interior, every option.

2002 Silver Camaro SS #8539 Ebony Leather, every option. 496 RWHP 536 Torque
TxML320 is offline  
post #7 of 28 (permalink) Old 10-08-2012, 08:09 PM
BenzWorld Senior Member
 
Date registered: Jan 2008
Vehicle: 98 ML320, 01 S500, 15 GL350
Posts: 584
Mentioned: 0 Post(s)
Quoted: 7 Post(s)
Quote:
Originally Posted by TxML320 View Post
I just filled my reservoir all the way up with power steering fluid and now my trunk goes all the way up quickly and stays up until I push the button to make it go back down, that's so much Craig for finding and posting this fix!!! This issue has been driving me crazy for years, but not $800 crazy! Lol
Where is the reservoir? in Trunk? Thanks!
idahombz is offline  
post #8 of 28 (permalink) Old 10-08-2012, 08:12 PM
BenzWorld Member
 
TxML320's Avatar
 
Date registered: Jan 2003
Vehicle: 2002 S430, 2002 Camaro SS, 2010 Navigator
Location: Austin, TX
Posts: 111
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
In the trunk next to the battery under some foam. This is only if you have the automatic trunk opener/closing option.

2002 S430 Black with Java Leather. Keyless Go, Rear Side and Back Window Roller Blinds, Electronic Trunk Opener, S3 Comfort Package, Integrated Motorola V60 (now replaced with Motorola Bluetooth Puck) with Voice Control, and CD changer. Chrome AMG split spoke wheels witth Michelin Pilot A/S Plus tires

2010 Lincoln Navigator Tuxedo Black Metallic Black Leather Interior, every option.

2002 Silver Camaro SS #8539 Ebony Leather, every option. 496 RWHP 536 Torque
TxML320 is offline  
post #9 of 28 (permalink) Old 10-08-2012, 08:39 PM
BenzWorld Senior Member
 
Date registered: Jan 2008
Vehicle: 98 ML320, 01 S500, 15 GL350
Posts: 584
Mentioned: 0 Post(s)
Quoted: 7 Post(s)
Quote:
Originally Posted by TxML320 View Post
In the trunk next to the battery under some foam. This is only if you have the automatic trunk opener/closing option.
Thanks! I took a look, there is nothing next to the battery! I have open trunk button on the remote but no auto closing. Maybe I do not have that feature....

Trunk can not be opened fully though!
idahombz is offline  
post #10 of 28 (permalink) Old 11-13-2012, 10:46 AM
BenzWorld Member
 
Date registered: Feb 2010
Vehicle: 2010 GL350 Bluetec
Location: Pittsburgh, PA
Posts: 59
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
I am having the same issue. I just went out to the car and pulled the pump out. There is good bit of fluid in the reservoir. Should I open it, drain the fluid and refill it completely with new fluid?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Jason


2010 GL350 Bluetec
2000 C230 Kompressor
2004 S500 4-matic
1995 S500 254K and going strong!
Sold
1983 380SEL 1st Benz!
1989 420SEL
1989 190E 87K Miles
1998 E300 Turbo Diesel
1992 400E 189K
1995 C220 Died
1986 260E
JB380SEL is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W220 S-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome