1985 300D Sunroof Issue - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 03-31-2019, 10:13 AM Thread Starter
BenzWorld Member
 
Jan T's Avatar
 
Date registered: Jan 2007
Vehicle: SL65, SL600 RENNtech, 300D, LP640 & Panteras
Posts: 160
Mentioned: 0 Post(s)
Quoted: 18 Post(s)
(Thread Starter)
1985 300D Sunroof Issue

Have not been here for a while, probably because the 300D is so reliable so nothing to post. But recently my sunroof stopped working. So I went into the drivers side trunk and took a 16mm to the bolt shown in the photo to gently try and manually work it. It seems it turns pretty easily to open and close it with the socket. Then I also found that when I have it open manually, when I go to work the switch in the car the roof closes fine. But at any position with the roof open when I try to open it further with the switch it will not move. Maybe a bad portion on switch that operates the opening function, or I burned something out by trying to work the roof with the switch? Also I don't hear anything when trying to open it with the switch.
Attached Thumbnails
Click image for larger version

Name:	IMG_4040.jpg
Views:	5
Size:	72.0 KB
ID:	2500462  

Photos:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by Jan T; 03-31-2019 at 10:16 AM.
Jan T is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 04-15-2019, 04:04 PM Thread Starter
BenzWorld Member
 
Jan T's Avatar
 
Date registered: Jan 2007
Vehicle: SL65, SL600 RENNtech, 300D, LP640 & Panteras
Posts: 160
Mentioned: 0 Post(s)
Quoted: 18 Post(s)
(Thread Starter)
I in the trunk I unhooked the wire connector that plugs into the roof motor and hooked up my volt meter to that connection and tried the dash switch and got 11+ volts when operating the switch to open and close. So I know there is power going from the dash switch in the open and close position along the lines to the sunroof motor so to me that seems to mean the dash switch is good. Then I did several things before hooking the trunk plug wire back to the sunroof motor, such as moving around all the fuses in the engine bay as kind of a maintenance thing, and I also giggled the sunroof switch wires around some and also manually opened the roof again just like I had before. However just by chance I thought I would try the roof again with the switch and it opened and closed the roof fine. I did it a few times to be sure and it now opens and closes fine. So in conclusion I am not sure what fixed it, but I guess I determined the switch was good. Maybe it just needed to be worked some once I was able to get it moving with the switch. Not sure of the cure, time will tell if it acts up again.

Photos:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Jan T is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W213 E-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
FS - 1985 300D Turbo Diesel - 1 Family owned / No Rust /Excellent Condition MBDieselFan For Sale/Wanted/Trade/Giveaway 1 09-20-2017 02:36 PM
Sunroof issue S320 Limousine W221 S-Class 2 12-22-2016 01:34 PM
1985 300D headlights on 1985 500SEL ethandco W126 S,SE,SEC,SEL,SD,SDL Class 2 03-16-2015 02:37 PM
Sunroof seal issue Aitch W124 E,CE,D,TD Class 8 08-26-2011 08:07 AM
1985 300D hard upshift issue... sean46953 W123 E,CE,D,CD,TD,TE Class 1 03-25-2009 05:16 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome