LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 09-18-2016, 08:36 AM Thread Starter
Forum Administrator
RC Colas® & Moon Pies®
 
Digmenow's Avatar
 
Date registered: Oct 2006
Vehicle: 1981 380SL 151K: 2005 S500 116K
Location: The Land of Pleasant Living
Posts: 39,129
Mentioned: 17 Post(s)
Quoted: 2233 Post(s)
Lifetime Premium Member
Garage
(Thread Starter)
New Model Forum


Quis custodiet ipsos custodes?
Digmenow is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 09-20-2016, 03:26 AM
Purple Moderator
 
Date registered: Jul 2005
Vehicle: 99 ML430, 00 ML320, 05 E500 4matic Wagon
Location: WI
Posts: 21,402
Mentioned: 33 Post(s)
Quoted: 1481 Post(s)
Lifetime Premium Member
Welcome to any and all new W213 owners. Looking forward to reading about owner experiences of this new model of the E class.
Noodles is offline  
post #3 of 8 (permalink) Old 10-13-2016, 07:57 AM
BenzWorld Junior Member
 
Date registered: Jun 2013
Vehicle: 2010 E350 Mars Red/Almond Beige, 2017 E300 Selenite Grey/Black
Location: USA
Posts: 18
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Thanks for opening the W213 forum
bmeC207 is offline  
Sponsored Links
Advertisement
 
post #4 of 8 (permalink) Old 04-27-2019, 09:52 PM
BenzWorld Junior Member
 
Date registered: Feb 2016
Vehicle: 2018 E300
Location: Laguna Beach, CA
Posts: 10
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
The only two complaints I have is when you're slowing down in D3 and at about 15-20 MPH you lightly step on the gas there is a very uncomfortable pause before it starts to accelerate that even the passengers would notice. The other is when the compass points to the east the letter W shows up and when it points to the west the letter E shows up.....
Icebreaker991 is offline  
post #5 of 8 (permalink) Old 05-03-2019, 04:31 PM
BenzWorld Member
 
Helo pilot's Avatar
 
Date registered: Oct 2011
Vehicle: 2019 E300 & 2016 GLE350 4Matic
Location: Oklahoma
Posts: 61
Mentioned: 2 Post(s)
Quoted: 4 Post(s)
I have a 2019 E300 and the red end of the compass always points "north" and the letter shows what direction I am driving and it is correct.

Maybe your computer needs an update.

Regards.
Helo pilot is offline  
post #6 of 8 (permalink) Old 05-03-2019, 09:27 PM
BenzWorld Junior Member
 
Date registered: Feb 2016
Vehicle: 2018 E300
Location: Laguna Beach, CA
Posts: 10
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Thanks for the reply. If your red always points North it is not working right. Mine will point North when it's going North, but will point West when it's going East.....
Attached Thumbnails
Click image for larger version

Name:	IMG_4092.jpg
Views:	4
Size:	31.3 KB
ID:	2509614   Click image for larger version

Name:	IMG_4093.jpg
Views:	3
Size:	43.5 KB
ID:	2509616  

Last edited by Icebreaker991; 05-03-2019 at 09:37 PM. Reason: add images
Icebreaker991 is offline  
post #7 of 8 (permalink) Old 05-04-2019, 04:29 AM
BenzWorld Member
 
Helo pilot's Avatar
 
Date registered: Oct 2011
Vehicle: 2019 E300 & 2016 GLE350 4Matic
Location: Oklahoma
Posts: 61
Mentioned: 2 Post(s)
Quoted: 4 Post(s)
This might help........the E indicates you are driving East, if you are driving East that is correct but the red end of the compass needle will always point North no matter what direction you are driving.

If the red end of the needle is pointing any direction but North then there is something wrong. Time for a dealership visit.

Regards.
Helo pilot is offline  
post #8 of 8 (permalink) Old 05-04-2019, 10:44 AM
BenzWorld Junior Member
 
Date registered: Feb 2016
Vehicle: 2018 E300
Location: Laguna Beach, CA
Posts: 10
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
I think it may be you that needs to take your car to the dealer as on page 305 and 308 of the 2018 E300 manual, it clearly shows that the needle moves with the direction.........
Attached Thumbnails
Click image for larger version

Name:	IMG_4693.jpg
Views:	7
Size:	44.4 KB
ID:	2509692   Click image for larger version

Name:	IMG_4692.jpg
Views:	5
Size:	48.3 KB
ID:	2509694  
Icebreaker991 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W213 E-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome