W211 (2005) noise when brake pedal depressed - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 08-31-2018, 11:25 AM Thread Starter
BenzWorld Newbie
 
Date registered: Aug 2018
Vehicle: 2005 E200 automatic (W211)
Location: England
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
W211 (2005) noise when brake pedal depressed

Hi,

I picked up a cheap 2005 w211 but its got a noise on the brakes that I can't locate. I've tried new pads but they didnt help.

Whenever I fully depress the brake pedal there's a whirling noise from the front which lasts a second maybe two, then stops. It sounds almost like a compressor or motor starting up. There's also a 'clattering' type noise coming from the front driver side wheel when pressing the brake pedal and again on release.

I figured maybe a loose brake pad / disc - The pads looked pretty new but I've now replaced the pads which made no difference. I will say I didnt have to move the pistons as the pads replaced were full.

Does this sound like a stuck piston? I assume there noise is the brake pump trying to force the fluid down and then giving up.

Braking is fine btw, car drives fine and brakes fine just this noise is really starting to bug me. Especially when sitting hold the brake at traffic lights, its loud enough that people walking by take a look lol

thanks

Richard
richardcarter is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 08-31-2018, 11:45 AM
BenzWorld Elite
 
noetico's Avatar
 
Date registered: Feb 2015
Vehicle: 2002 Mercedes ML320, Mercedes 190E 2.3L (sold), 2001 Mercedes c320(gone)
Location: Abuja, Nigeria
Posts: 1,277
Mentioned: 10 Post(s)
Quoted: 220 Post(s)
Garage
Maybe have someone hold the brakes with the car properly wedged for safety; while you listen for the source of the sound carefully, if it's that loud it may be fairly easy to spot by listening around the engine bay.


Sent from my iPhone using Tapatalk

Kent
noetico is offline  
post #3 of 3 (permalink) Old 04-24-2019, 11:07 PM
BenzWorld Junior Member
 
Date registered: Jun 2008
Posts: 13
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Your sbc is acting up, replace the sbc and do a fluid flush


Sent from my iPhone using Tapatalk
bdragomir is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz AMG Forums > W211 E55 AMG, E63 AMG

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome