identification of valeo radiator w211 - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 04-14-2019, 03:31 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Apr 2019
Posts: 12
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
(Thread Starter)
identification of valeo radiator w211

im gonna buy a w211 E280 cdi, i dont know exactly when it was registered for the first time since its imported and registered for the first time in my country in 2007, but it says its a 2005 atleast. i have been trying it for a few days now and i experienced a really harsh jerking / thugging while accelerating from low speeds, so bad i almost hit my head on the steering wheel. happened 2 times in the 3 days i tried it. is this related to the valeo problem or do anyone have any ideas? if it helps the VIN is : WDB2112201A865247
GlennNorway is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 04-14-2019, 08:59 PM
BenzWorld Elite
 
tjts1's Avatar
 
Date registered: Apr 2009
Vehicle: 87 300D 5 speed
Location: The slums of Beverly Hills
Posts: 5,137
Mentioned: 5 Post(s)
Quoted: 688 Post(s)
Quote:
Originally Posted by GlennNorway View Post
im gonna buy a w211 E280 cdi, i dont know exactly when it was registered for the first time since its imported and registered for the first time in my country in 2007, but it says its a 2005 atleast. i have been trying it for a few days now and i experienced a really harsh jerking / thugging while accelerating from low speeds, so bad i almost hit my head on the steering wheel. happened 2 times in the 3 days i tried it. is this related to the valeo problem or do anyone have any ideas? if it helps the VIN is : WDB2112201A865247
Do you have any oil in the coolant? Any coolant in the ATF? If not you have a failing torque converter clutch solenoid and damper.
https://youtu.be/LdF5DnGwz7E

Triggering religious fanatics since 1969

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
tjts1 is offline  
post #3 of 6 (permalink) Old 04-14-2019, 11:01 PM
BenzWorld Member
 
albi.ad8's Avatar
 
Date registered: Dec 2015
Vehicle: w211 e220 cdi 2005
Location: Tirana,Albania
Posts: 228
Mentioned: 0 Post(s)
Quoted: 30 Post(s)
Did the same research when i purchased my w211 built in 10/2004. Try checking in front of the car and you should have a letter on top of the radiator that should rear BEHR( thats what says on mine). The issues with the VALEO radiator happened only for 2002-2003 and early 2004 models so that should not be your issue. Try checking the torque converter clutch solenoid as stated before.
Benzyle likes this.
albi.ad8 is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 04-14-2019, 11:15 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Apr 2019
Posts: 12
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
(Thread Starter)
Quote:
Originally Posted by tjts1 View Post
Quote:
Originally Posted by GlennNorway View Post
im gonna buy a w211 E280 cdi, i dont know exactly when it was registered for the first time since its imported and registered for the first time in my country in 2007, but it says its a 2005 atleast. i have been trying it for a few days now and i experienced a really harsh jerking / thugging while accelerating from low speeds, so bad i almost hit my head on the steering wheel. happened 2 times in the 3 days i tried it. is this related to the valeo problem or do anyone have any ideas? if it helps the VIN is : WDB2112201A865247
Do you have any oil in the coolant? Any coolant in the ATF? If not you have a failing torque converter clutch solenoid and damper.
https://youtu.be/LdF5DnGwz7E
Is the trans in that video Even the same as i have? Think i have the 722.9
GlennNorway is offline  
post #5 of 6 (permalink) Old 04-14-2019, 11:36 PM
BenzWorld Elite
 
tjts1's Avatar
 
Date registered: Apr 2009
Vehicle: 87 300D 5 speed
Location: The slums of Beverly Hills
Posts: 5,137
Mentioned: 5 Post(s)
Quoted: 688 Post(s)
Quote:
Originally Posted by GlennNorway View Post
Quote:
Originally Posted by tjts1 View Post
Quote:
Originally Posted by GlennNorway View Post
im gonna buy a w211 E280 cdi, i dont know exactly when it was registered for the first time since its imported and registered for the first time in my country in 2007, but it says its a 2005 atleast. i have been trying it for a few days now and i experienced a really harsh jerking / thugging while accelerating from low speeds, so bad i almost hit my head on the steering wheel. happened 2 times in the 3 days i tried it. is this related to the valeo problem or do anyone have any ideas? if it helps the VIN is : WDB2112201A865247
Do you have any oil in the coolant? Any coolant in the ATF? If not you have a failing torque converter clutch solenoid and damper.
https://youtu.be/LdF5DnGwz7E
Is the trans in that video Even the same as i have? Think i have the 722.9
How are we supposed to know that?

Triggering religious fanatics since 1969

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
tjts1 is offline  
post #6 of 6 (permalink) Old 04-15-2019, 12:09 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Apr 2019
Posts: 12
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
(Thread Starter)
Quote:
Originally Posted by tjts1 View Post
Quote:
Originally Posted by GlennNorway View Post
Quote:
Originally Posted by tjts1 View Post
Quote:
Originally Posted by GlennNorway View Post
im gonna buy a w211 E280 cdi, i dont know exactly when it was registered for the first time since its imported and registered for the first time in my country in 2007, but it says its a 2005 atleast. i have been trying it for a few days now and i experienced a really harsh jerking / thugging while accelerating from low speeds, so bad i almost hit my head on the steering wheel. happened 2 times in the 3 days i tried it. is this related to the valeo problem or do anyone have any ideas? if it helps the VIN is : WDB2112201A865247
Do you have any oil in the coolant? Any coolant in the ATF? If not you have a failing torque converter clutch solenoid and damper.
https://youtu.be/LdF5DnGwz7E
Is the trans in that video Even the same as i have? Think i have the 722.9
How are we supposed to know that?
I used vin decoder and it says i have 722.9 trans
GlennNorway is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W211 E-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
W210 VALEO VOLTAGE REGULATORS FOR W210 SG12B024 ALTERNATOR oem.motor.sales For Sale/Wanted/Trade/Giveaway 0 12-14-2013 04:54 PM
C230 Alternator: Valeo or Bosch? mikehelms W203 C-Class 11 01-31-2011 07:14 AM
Troublesome Valeo Radiator (leaking) Question jjleonard W211 E-Class 1 05-12-2010 11:55 PM
Valeo Radiator Identification Help indigowhale W211 E-Class 17 01-15-2010 04:34 AM
Valeo Voltage Regulators: Anyone w/ Interchange Experience? jerk_chicken General Mercedes-Benz 2 09-20-2009 07:43 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome