Center speaker distortion - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 05-18-2015, 07:27 AM Thread Starter
BenzWorld Elite
 
ps2cho's Avatar
 
Date registered: Oct 2006
Vehicle: 2008 E350 4M, 1988 300TE
Location: Chandler, AZ
Posts: 5,411
Mentioned: 9 Post(s)
Quoted: 344 Post(s)
(Thread Starter)
Center speaker distortion

So I got my aux input installed and with the engine off I can hear the center speaker is distorted and is fuzzy. I didn't notice this before on lower quality radio.

Is there any repair or is it replacement only? Any aftermarket or is it typical MB oddball sizes?

Thanks!
ps2cho is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 05-18-2015, 08:54 PM Thread Starter
BenzWorld Elite
 
ps2cho's Avatar
 
Date registered: Oct 2006
Vehicle: 2008 E350 4M, 1988 300TE
Location: Chandler, AZ
Posts: 5,411
Mentioned: 9 Post(s)
Quoted: 344 Post(s)
(Thread Starter)
I pulled the top off the dash today and it seems that the speaker has separated from the metal frame. I called the dealer and they wanted $157 plus tax!!! Insane....
Until I can order one off ECSTuning which is only $103, I put a layer of glue all around the outside to hold the speaker to the frame. We will see tomorrow once its dried if it holds me over.

I wonder if the exposure to the sun/heat is the reason why this one failed quickly?

2016 Monsoon Gray Audi Allroad - 26k
2008 Black Mercedes E350 4Matic Sport P1 - 140k
2014 Jeep Wranger Unlimited Sahara - 90k
2003 Silver ML350 - 135k

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
ps2cho is offline  
post #3 of 11 (permalink) Old 05-18-2015, 10:34 PM
Purple Moderator
 
Date registered: Jul 2005
Vehicle: 99 ML430, 00 ML320, 05 E500 4matic Wagon
Location: WI
Posts: 21,521
Mentioned: 35 Post(s)
Quoted: 1507 Post(s)
Lifetime Premium Member
That is the reason. Other users have used an adhesive that stays flexible after it cures for the repair and reported a good success rate.
Noodles is offline  
Sponsored Links
Advertisement
 
post #4 of 11 (permalink) Old 05-19-2015, 07:24 AM Thread Starter
BenzWorld Elite
 
ps2cho's Avatar
 
Date registered: Oct 2006
Vehicle: 2008 E350 4M, 1988 300TE
Location: Chandler, AZ
Posts: 5,411
Mentioned: 9 Post(s)
Quoted: 344 Post(s)
(Thread Starter)
Well it seems to have fixed the problem!
The song that it would always buzz and hiss at was John Mayer - Stitched Up. It has a huge range that always nailed that speaker while 90% of all my other songs would give no indication.

Glad it was a cheap fix and next time I hear an issue I'll replace it with a new one!
ps2cho is offline  
post #5 of 11 (permalink) Old 05-21-2015, 08:39 AM
BenzWorld Veteran
 
dtsdig's Avatar
 
Date registered: Feb 2011
Vehicle: 1994 Mercedes E320 Sedan 97K, 1995 Mercedes E320 Wagon 156K, 2009 VW EOS 45K (Wife's car)
Location: Upstate New York
Posts: 720
Mentioned: 0 Post(s)
Quoted: 103 Post(s)
Send a message via Skype™ to dtsdig
@ps2cho , Since I have taken my 95 E320 off the road, I have been looking for what's next in my driveway and got curious about the W211 wagons. Since you own both, can I hit you up for some insight?
dtsdig is offline  
post #6 of 11 (permalink) Old 10-20-2017, 09:27 AM
BenzWorld Member
 
Date registered: Mar 2011
Vehicle: 2007 E350 SP1 (M211.056/E272.964)
Location: Orange County, Ca
Posts: 122
Mentioned: 0 Post(s)
Quoted: 21 Post(s)
Just wonder if anyone successfully replaced center speaker with an aftermarket one?
btv94 is offline  
post #7 of 11 (permalink) Old 10-20-2017, 02:42 PM Thread Starter
BenzWorld Elite
 
ps2cho's Avatar
 
Date registered: Oct 2006
Vehicle: 2008 E350 4M, 1988 300TE
Location: Chandler, AZ
Posts: 5,411
Mentioned: 9 Post(s)
Quoted: 344 Post(s)
(Thread Starter)
Quote:
Originally Posted by btv94 View Post
Just wonder if anyone successfully replaced center speaker with an aftermarket one?
Itís been 2-years since my glue repair and speaker still works fine. Anything can be done, but there is no direct swap with the correct ohms
ps2cho is offline  
post #8 of 11 (permalink) Old 10-20-2017, 03:01 PM
BenzWorld Member
 
Date registered: Mar 2011
Vehicle: 2007 E350 SP1 (M211.056/E272.964)
Location: Orange County, Ca
Posts: 122
Mentioned: 0 Post(s)
Quoted: 21 Post(s)
Quote:
Originally Posted by ps2cho View Post
Itís been 2-years since my glue repair and speaker still works fine. Anything can be done, but there is no direct swap with the correct ohms
I try to fix the speaker itself, but in my case the lower material/cone has also separated from the rubber part. Just purchased new one from OE discount parts.
btv94 is offline  
post #9 of 11 (permalink) Old 01-30-2018, 12:17 PM
BenzWorld Junior Member
 
Date registered: Feb 2017
Vehicle: 2007 E320
Location: Washington, United States
Posts: 6
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
I had the same center speaker distortion on my 07 E320. I ended up pulling the speaker out and running a bead of silicone around the speaker where the speaker material meets the metal frame. After letting it dry for a day the speaker sounds great! What a cheap fix! I think this is a common problem for W211.
2007w211 is offline  
post #10 of 11 (permalink) Old 01-30-2018, 02:09 PM
BenzWorld Senior Member
 
LasCondes's Avatar
 
Date registered: Jul 2011
Vehicle: 2013 E350, 212.059, Avantgarde, Engine: 276.952, Gearbox 722.906
Location: Berkeley, CA
Posts: 505
Mentioned: 0 Post(s)
Quoted: 75 Post(s)
Quote:
Originally Posted by 2007w211 View Post
I had the same center speaker distortion on my 07 E320. I ended up pulling the speaker out and running a bead of silicone around the speaker where the speaker material meets the metal frame. After letting it dry for a day the speaker sounds great! What a cheap fix! I think this is a common problem for W211.
Do you recall what silicone you used, many varieties out there! I'd rather go with something that's been tried and proven. Thanks.

History of:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


1968 280 S
1985 300 D Turbodiesel
1990 300 E
1995 E320
1999 E320
2005 E320
LasCondes is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W211 E-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome