Hello all - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 02-06-2018, 07:59 AM Thread Starter
BenzWorld Member
 
neo297's Avatar
 
Date registered: Oct 2011
Vehicle: 1987 560SL
Location: East Texas
Posts: 50
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Garage
(Thread Starter)
Hello all

I have been a member for a while. This forum helped me when I first got my 560sl and my clk320. I have now added a 2001 E55 to my stable. I love it!!. I had to replace the led screens in the instrument cluster and a few rubber vacuum lines under the hood. My big issue was the 19 inch rims the PO had put on the car the rear 275/40s rubbed on the fender. I wasn't sure if suspension parts or just tire size was the issue. I have replaced all the rear thrust arms and control arm bushings and am waiting on my koni shocks to come in. I ended up putting 275/30 rear tires on , on the 19 in rims these were equivalent tire diameter as the stock tires on the 18 in rims and no longer get any rub. I can say having the proper bushing removal tool is invaluable.My next and hopefully last task are issues I believe are related to the pse pump. First my trunk won't unlock from the key fob or the interior switch. If I take the wires from the pse pump and disconnect and reconnect it will work temporarily. The other possibly related issue is the courtesy lights on the bottom of the front and rear passenger side doors never turn off and the interior lights stay on with door open and close for the extended time frame before turning off. Of course when I get in I just manually turn them off. I think the system thinks a door is still open. I checked continuity through the door push switches and they seem to work properly but pushing them manually or closing the door does nothing. I need to find where the switch is in the trunck to check it as well. The driver's side door lights work as they are supposed to. So the light situation is my next project any thoughts would be appreciated. In the meantime I happy there are no issues with how the car is running it is a powerful fun car that's comfortable for my 6 foot 290lb frame even driving it 600 to 700 miles in a day, longest trip so far. Here are some pics these are with the bigger rear tires 19x9 front rims and 19x10 in rear.
Attached Thumbnails
Click image for larger version

Name:	IMG_20171001_144313693_HDR_1517932622469.jpg
Views:	51
Size:	67.9 KB
ID:	2369417   Click image for larger version

Name:	IMG_20171001_144404661_HDR_1517932680093.jpg
Views:	40
Size:	61.9 KB
ID:	2369425   Click image for larger version

Name:	IMG_20171001_182517298_1517932725919.jpg
Views:	43
Size:	46.6 KB
ID:	2369465   Click image for larger version

Name:	IMG_20171001_182443661_1517932763737.jpg
Views:	40
Size:	31.3 KB
ID:	2369473  

Paul
neo297 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 07-08-2018, 12:59 PM
BenzWorld Junior Member
 
Date registered: Jul 2018
Vehicle: 2001 Mercedes-Benz E55 AMG
Location: PA
Posts: 16
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
Nice car, I have its twin. Mine doesn't have the Navigation and 19" wheels. You'll enjoy it, nice cruiser.
range96 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz AMG Forums > W210 E50 AMG, E55 AMG

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome