alternative w210 tail light fix - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 09-26-2015, 02:40 PM Thread Starter
BenzWorld Member
 
pt_700's Avatar
 
Date registered: Apr 2012
Vehicle: 1998 e430
Location: san jose, ca
Posts: 308
Mentioned: 1 Post(s)
Quoted: 54 Post(s)
(Thread Starter)
alternative w210 tail light fix

many of these cars show warnings about lamps out but, the bulbs are fine. it's the poor contact between the socket and metal part of the tail light housing. some put foil there or try to bend the contacts on the socket to assure a more reliable flow of electrons. these seem temporary (at least in my experience).

i saw mjhawkins fix here;

https://www.benzworld.org/forums/w210...on-errors.html

liked it but, am lazy so i tried this.

put a dab of solder on the contact points of the socket. there's a little tab to push in towards the center of the socket to remove the metal contacts from the plastic housing. once they're out, hold 'em in something that won't melt and you're ready to solder.

did both tail lights and they've been good for a month so far. the reverse lights are pictured here.
Attached Thumbnails
Click image for larger version

Name:	IMG_0071.jpg
Views:	478
Size:	58.8 KB
ID:	1623689   Click image for larger version

Name:	IMG_0072.jpg
Views:	475
Size:	71.2 KB
ID:	1623697   Click image for larger version

Name:	IMG_0075.jpg
Views:	441
Size:	63.5 KB
ID:	1623705   Click image for larger version

Name:	IMG_0077.jpg
Views:	453
Size:	65.4 KB
ID:	1623713  

Last edited by pt_700; 09-28-2015 at 01:26 PM.
pt_700 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 10-07-2015, 11:43 AM Thread Starter
BenzWorld Member
 
pt_700's Avatar
 
Date registered: Apr 2012
Vehicle: 1998 e430
Location: san jose, ca
Posts: 308
Mentioned: 1 Post(s)
Quoted: 54 Post(s)
(Thread Starter)
if the mods think it appropriate, please move this to the w210 section.

almost everywhere i look, w210's without tail lights...
pt_700 is offline  
post #3 of 8 (permalink) Old 12-30-2015, 09:23 PM
BenzWorld Member
 
Date registered: Aug 2009
Vehicle: 2007 SL550, 1996 E300 Diesel, 1959 220SE, 1965 Unimog 404.115-Sold
Location: Oakdale, California
Posts: 306
Mentioned: 1 Post(s)
Quoted: 11 Post(s)
Quote:
Originally Posted by pt_700 View Post
many of these cars show warnings about lamps out but, the bulbs are fine. it's the poor contact between the socket and metal part of the tail light housing. some put foil there or try to bend the contacts on the socket to assure a more reliable flow of electrons. these seem temporary (at least in my experience).

i saw mjhawkins fix here;

https://www.benzworld.org/forums/w210...on-errors.html

liked it but, am lazy so i tried this.

put a dab of solder on the contact points of the socket. there's a little tab to push in towards the center of the socket to remove the metal contacts from the plastic housing. once they're out, hold 'em in something that won't melt and you're ready to solder.

did both tail lights and they've been good for a month so far. the reverse lights are pictured here.
Great job. I just did this to my 1996 W210 and I believe my brake light issues are finally over.

2007 SL550
1996 E300 Diesel
1959 220SE Fuel Injected
compconsult is offline  
Sponsored Links
Advertisement
 
post #4 of 8 (permalink) Old 12-31-2015, 07:31 AM Thread Starter
BenzWorld Member
 
pt_700's Avatar
 
Date registered: Apr 2012
Vehicle: 1998 e430
Location: san jose, ca
Posts: 308
Mentioned: 1 Post(s)
Quoted: 54 Post(s)
(Thread Starter)
glad to hear this, compconsult!

there's a w210 in my neighborhood with a dark tail light, i've been tempted to follow him home and introduce myself...

what is this sickness?!
pt_700 is offline  
post #5 of 8 (permalink) Old 04-19-2017, 05:23 AM
BenzWorld Member
 
Date registered: Jun 2010
Vehicle: 06 ML500
Location: Wilm DE
Posts: 61
Mentioned: 1 Post(s)
Quoted: 10 Post(s)
Quote:
Originally Posted by pt_700 View Post

..... but, am lazy so i tried this...
I just wanted to say thank you, this worked awesome for me. You're a gentleman and a scholar.


mike
2006 ML500
Left blinker
ChosenWon is offline  
post #6 of 8 (permalink) Old 04-19-2017, 07:21 AM Thread Starter
BenzWorld Member
 
pt_700's Avatar
 
Date registered: Apr 2012
Vehicle: 1998 e430
Location: san jose, ca
Posts: 308
Mentioned: 1 Post(s)
Quoted: 54 Post(s)
(Thread Starter)
glad to hear this, mike!

as my problems have not re-surfaced, i now consider this a long-term fix.
pt_700 is offline  
post #7 of 8 (permalink) Old 04-21-2017, 04:58 PM
BenzWorld Member
 
Date registered: Aug 2009
Vehicle: 2007 SL550, 1996 E300 Diesel, 1959 220SE, 1965 Unimog 404.115-Sold
Location: Oakdale, California
Posts: 306
Mentioned: 1 Post(s)
Quoted: 11 Post(s)
Yes I will agree as mine also has not happened again since i fixed them

2007 SL550
1996 E300 Diesel
1959 220SE Fuel Injected
compconsult is offline  
post #8 of 8 (permalink) Old 04-13-2019, 05:15 PM
BenzWorld Member
 
99EBenz's Avatar
 
Date registered: Mar 2008
Vehicle: 1999 MB E320 - Brilliant Silver/Ash 135K
Location: Sweet Home
Posts: 241
Mentioned: 1 Post(s)
Quoted: 9 Post(s)
Applied this fix this afternoon. Fingers are crossed for positive result. Thanks
99EBenz is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz AMG Forums > W210 E50 AMG, E55 AMG

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome