Steering wheel airbag - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 07-10-2019, 11:46 PM Thread Starter
BenzWorld Member
 
Mercedesist's Avatar
 
Date registered: Mar 2017
Vehicle: 1999 Mercedes-Benz E-Class Estate 2.7CDi 125kW
Location: Riga, Latvia
Posts: 68
Mentioned: 0 Post(s)
Quoted: 8 Post(s)
(Thread Starter)
Steering wheel airbag

Hello!

So, I was planning on removing my steering wheel, because it's worn, to get it refurbished. Watched several tutorials how to do it and it's pretty straight forward - 2 screws, airbag is off and then the center nut for steering wheel.

Everything would be great, except there are no airbag bolts, just empty holes, but the airbag is still holding in it's place. I assume, that in the past some smart people have glued airbag to the steering wheel itself.

Question is - how to get it off and is it even worth it?
Attached Thumbnails
Click image for larger version

Name:	Screenshot_20190711-093420_Gallery.jpg
Views:	8
Size:	1.74 MB
ID:	2526998   Click image for larger version

Name:	20190622_143035.jpg
Views:	9
Size:	3.61 MB
ID:	2527000  
Mercedesist is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 07-10-2019, 11:53 PM
BenzWorld Elite
 
Benzyle's Avatar
 
Date registered: Nov 2013
Vehicle: MY05 CLK55 AMG , MY05 CLK320,Former,C180 Kompressor,Jensen Healey,Ford Capri V6,Alfa GTV.
Location: Australia's East Coast
Posts: 1,401
Mentioned: 3 Post(s)
Quoted: 300 Post(s)
Probably you would have to prise ,lever and pull the airbag section away,,,
only you can decide if you want to do it ,,how badly do you want to fix it ?,,
if you do , maybe better to fit a used /replacement wheel which has the bolts in place,,,as far as I know they are captive bolts.
Benzyle is offline  
post #3 of 7 (permalink) Old 07-11-2019, 05:52 AM
BenzWorld Elite
 
Witek_M's Avatar
 
Date registered: Sep 2008
Vehicle: 1972
Location: Dallas, Texas
Posts: 6,384
Mentioned: 15 Post(s)
Quoted: 890 Post(s)
Bolts for air bag a a lot deeper then your picture. You need 2 inch long T30 Torx bit to reach them.

1972 280SEL 4.5
1999 ML320
2000 E320
2003 ML350
Witek_M is offline  
Sponsored Links
Advertisement
 
post #4 of 7 (permalink) Old 07-11-2019, 03:12 PM
BenzWorld Elite
 
Benzyle's Avatar
 
Date registered: Nov 2013
Vehicle: MY05 CLK55 AMG , MY05 CLK320,Former,C180 Kompressor,Jensen Healey,Ford Capri V6,Alfa GTV.
Location: Australia's East Coast
Posts: 1,401
Mentioned: 3 Post(s)
Quoted: 300 Post(s)
Ah yes well spotted witek..M

Yes they are deep in behind the plastic...
Benzyle is offline  
post #5 of 7 (permalink) Old 07-12-2019, 02:48 PM Thread Starter
BenzWorld Member
 
Mercedesist's Avatar
 
Date registered: Mar 2017
Vehicle: 1999 Mercedes-Benz E-Class Estate 2.7CDi 125kW
Location: Riga, Latvia
Posts: 68
Mentioned: 0 Post(s)
Quoted: 8 Post(s)
(Thread Starter)
Thank you for responses. Turns out there are bolts. Made a toll that works in that small hole and everything unscrews!
Mercedesist is offline  
post #6 of 7 (permalink) Old 07-12-2019, 07:30 PM
BenzWorld Elite
 
Witek_M's Avatar
 
Date registered: Sep 2008
Vehicle: 1972
Location: Dallas, Texas
Posts: 6,384
Mentioned: 15 Post(s)
Quoted: 890 Post(s)
Quote:
Originally Posted by Mercedesist View Post
Thank you for responses. Turns out there are bolts. Made a toll that works in that small hole and everything unscrews!
So, now that you got your answers it would be nice to document the procedure. Close ups of tools used and such.

1972 280SEL 4.5
1999 ML320
2000 E320
2003 ML350
Witek_M is offline  
post #7 of 7 (permalink) Old 07-13-2019, 07:38 AM
BenzWorld Extremist
 
Date registered: Mar 2010
Vehicle: 88 560SL - 01 C240 - 02 E320 4matic Wagon
Location: PA
Posts: 1,041
Mentioned: 6 Post(s)
Quoted: 72 Post(s)
I had a few tork screwdrivers and none of them worked. All the thin shaft ones being too short .. all the long ones too thick to fit in the hole.

I went to harbor freight and was able to find a kit that just worked -- once you remove the screws the bag comes off and the connector is behind. I had the battery disconnected and did not reconnect until I had it all together again.

I was taking mine off to replace the multi switch
yeldogt is online now  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W210 E-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome