E430 ticking sound - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 13 (permalink) Old 05-31-2019, 09:26 AM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2019
Posts: 6
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
(Thread Starter)
E430 ticking sound

Hey all. I have question. Theres ticking sound coming out from my engine. Some times it stops but it’s on most of the time.
Tumi4390 is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 05-31-2019, 09:27 AM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2019
Posts: 6
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
(Thread Starter)
I can add if there more RPMs faster ticking sound
Tumi4390 is offline  
post #3 of 13 (permalink) Old 05-31-2019, 09:56 AM
BenzWorld Member
 
Black Swan's Avatar
 
Date registered: Sep 2015
Vehicle: 2010 E3504matic , 1998 E320
Location: Easton, MA
Posts: 52
Mentioned: 0 Post(s)
Quoted: 15 Post(s)
Quote:
Originally Posted by Tumi4390 View Post
Hey all. I have question. Theres ticking sound coming out from my engine. Some times it stops but itís on most of the time.

I thought the same thing when I got my first Merc, but it's perfectly normal. I'll post again once I remember what the part is.
Black Swan is offline  
Sponsored Links
Advertisement
 
post #4 of 13 (permalink) Old 05-31-2019, 10:09 AM
Outstanding Contributor
 
Date registered: Jun 2012
Vehicle: 1998 E320 base sedan @ 160kmiles
Location: Boca Raton, FL
Posts: 5,060
Mentioned: 78 Post(s)
Quoted: 1138 Post(s)
Send a message via Skype™ to mrboca
Quote:
Originally Posted by Tumi4390 View Post
I can add if there more RPMs faster ticking sound
It is best to record the video with sound at different rpms, and post it here.

There is a purge valve that ticks from time to time, but I do not think it is rpm related.

Do you have any fault codes ? Check engine light ? warnings on the dash ?
Black Swan likes this.
mrboca is online now  
post #5 of 13 (permalink) Old 05-31-2019, 11:00 AM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2019
Posts: 6
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
(Thread Starter)
That’s the link to the video. No codes, nothing on dashboard
Tumi4390 is offline  
post #6 of 13 (permalink) Old 05-31-2019, 11:12 AM
BenzWorld Member
 
Black Swan's Avatar
 
Date registered: Sep 2015
Vehicle: 2010 E3504matic , 1998 E320
Location: Easton, MA
Posts: 52
Mentioned: 0 Post(s)
Quoted: 15 Post(s)
Yeah that sounds a little bit louder than the ticking I was talking about. You can use a screwdriver as a stethoscope to isolate exactly where the noise is coming from. Hold the plastic end to your ear and move the metal end onto different areas. It'll help you, and us, determine what the ticking is.
Black Swan is offline  
post #7 of 13 (permalink) Old 05-31-2019, 11:28 AM
BenzWorld Elite
 
wlb50's Avatar
 
Date registered: Mar 2013
Vehicle: 1996 SL500, 2000 E430
Location: Sacramento, California
Posts: 3,573
Mentioned: 15 Post(s)
Quoted: 671 Post(s)
Could be lifter(s). My M119 SL had it but use of M1 and a good changing schedule seems to have eliminated it.
wlb50 is online now  
post #8 of 13 (permalink) Old 05-31-2019, 11:49 AM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2019
Posts: 6
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
(Thread Starter)
Quote:
Originally Posted by Black Swan View Post
Yeah that sounds a little bit louder than the ticking I was talking about. You can use a screwdriver as a stethoscope to isolate exactly where the noise is coming from. Hold the plastic end to your ear and move the metal end onto different areas. It'll help you, and us, determine what the ticking is.
I will do that after work
Tumi4390 is offline  
post #9 of 13 (permalink) Old 05-31-2019, 11:51 AM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2019
Posts: 6
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
(Thread Starter)
Quote:
Originally Posted by wlb50 View Post
Could be lifter(s). My M119 SL had it but use of M1 and a good changing schedule seems to have eliminated it.
I been thinking about this. I bought this car 6 months ago from my boss. Car wasn’t driven for a year. I changed oil right away. Month ago I did oil change and it seems ticking stopped for some time. It’s around 2500 miles after last oil change and ticking is louder than before. You guys recommend putting seafoam and drive a little bit and do oil change?
Tumi4390 is offline  
post #10 of 13 (permalink) Old 05-31-2019, 11:51 AM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2019
Posts: 6
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
(Thread Starter)
What’s the best oil to use in E430? I might do oil change tomorrow and see if that helps
Tumi4390 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W210 E-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome