First post in the 210 forum - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 05-20-2019, 05:23 PM Thread Starter
BenzWorld Member
 
Date registered: Sep 2012
Vehicle: '95 S500 (sold), '97 E420
Posts: 222
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
(Thread Starter)
First post in the 210 forum

Will be pulling the trigger on a '97 E420 this Sat. I've smoked it over pretty good, and here's what I've found so far:
All the windows work just fine, oil is due for change, good tires, starts, and idles to about 1800 and stays that way, until putting it in gear, then it will idle at normal rpm, even in neutral, or park. Makes an awful racket. I determined the racket to be fan hitting the radiator. Subsequent start no more racket, fan not turning, wedged against radiator. Upon further inspection, I found that someone had run it up on a curb and shoved the lower core support back. Thus causing interference with the fan and radiator. Only the blade key comes with it, no fob. No structural rust that I can find, and for the most part seems to be in pretty fair shape cosmetically. Mechanically it seems to be sound, but there is a leak of tranny fluid at the radiator. I think an O ring is the culprit. Can't check the tranny fluid level, or quality, (yet). it appears that some time in it's life the fuel rail, and injectors have been replaced. (too dang clean compared to the rest of engine). Couple of vaccuum hoses need replaced, but not a deal breaker. CarFax shows a reported accident, about 6 years ago, but no details. Headlights aren't fogged, so I suspect a front end collision.
Seems to have been a decent repair. (30 years in the body shop business, I can usually spot a repair)
Needs hood struts, and tool kit is missing. radio needs code entered, (battery was disconnected)

I'll know more when I get it home on Sat. I'll be getting it towed, as I don't want to drive it with the fan/radiator interference.

'Bout it for now.

Thanx,
Shorty.

"If you set out to fail, and succeed, which have you done?"
bluerooster is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 05-21-2019, 04:50 AM
BenzWorld Elite
 
pfsantos's Avatar
 
Date registered: Nov 2005
Vehicle: '83 W123 200 '98 E200 Kompressor (both Euro-spec., 200 in Portugal, E200 Now in Canada!), '08 B200
Location: Toronto, Canada
Posts: 1,685
Mentioned: 3 Post(s)
Quoted: 124 Post(s)
Assume worst case scenario, that the rad is bad (transmission cooler). A fuel leak can sometimes clean up areas around it, but that would look a little different.

Paul (Paulo Santos)
Youtube:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'83 W123 200, '98 W210 E200K, '08 W245 B200
* Feel free to PM me if needed *
pfsantos is offline  
post #3 of 9 (permalink) Old 05-22-2019, 01:21 PM
BenzWorld Member
 
Date registered: Jan 2007
Vehicle: 96 E320
Location: Bloomfield, NJ
Posts: 138
Mentioned: 1 Post(s)
Quoted: 30 Post(s)
Congrats on your acquisition. Will you be able to bend the lower support back into shape? Or will it need a body shop? That's probably the biggest worry besides a new radiator like @pfsantos mentions above. I also wonder if the AC condenser also suffered damage. Does the AC work?

96 E320, 17 Hyundai Tucson
ptempel is offline  
Sponsored Links
Advertisement
 
post #4 of 9 (permalink) Old 05-22-2019, 02:55 PM
Supporting Vendor
 
AutohausAZ's Avatar
 
Date registered: Dec 2004
Vehicle: Too Many to List
Location: Phoenix, Arizona
Posts: 168
Mentioned: 3 Post(s)
Quoted: 31 Post(s)
Congratulations Bluerooster! Please let us know if you need any parts for your "new" E420.
https://www.autohausaz.com/catalog/c...7/1195624-e420

Visit the AutohausAZ Vendor Section for special pricing for Benzworld members:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
!
AutohausAZ is offline  
post #5 of 9 (permalink) Old 05-22-2019, 03:40 PM
BenzWorld Extremist
 
khomer2's Avatar
 
Date registered: Nov 2015
Vehicle: w163 02 ML500 W210 97 E50Amg w202 99 C230K w124 - need more space, time to build again
Location: Canada
Posts: 1,096
Mentioned: 4 Post(s)
Quoted: 232 Post(s)
Another 97. Keep us posted on your progress, bluerooster

btw, call in to MB stealership and provide them, if required, proof of ownership and vin# to obtain the radio code (IF its the original one), otherwise, the serial # of the radio will get you the radio code.
khomer2 is online now  
post #6 of 9 (permalink) Old 05-22-2019, 09:07 PM
Outstanding Contributor
SDS Guru
 
Deplore's Avatar
 
Date registered: Apr 2014
Vehicle: 1998 MB E300TD, 1997 MB E320
Location: LA, CA
Posts: 3,130
Mentioned: 122 Post(s)
Quoted: 752 Post(s)
Lower radiator support bracket is welded on, so to replace it you would need to grind off the old one and weld in the new one.

I have one sitting on the shelf to replace on my E300 in about two weeks time. Courtesy of my dearest sister who misjudged the parking lot stopper thingy and wacked the car against it.

--1998 MB E300TD 291k
--1997 MB E36 Frankenstein'd AMG 199k
--2011 Suzuki DL650 58k
--1997 MB E320 161k. SOLD...loved that stupid car.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

--1997 MB C36 AMG 273k -- stripped and junked
Deplore is online now  
post #7 of 9 (permalink) Old 05-25-2019, 02:50 PM Thread Starter
BenzWorld Member
 
Date registered: Sep 2012
Vehicle: '95 S500 (sold), '97 E420
Posts: 222
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
(Thread Starter)
Quote:
Originally Posted by Deplore View Post
Lower radiator support bracket is welded on, so to replace it you would need to grind off the old one and weld in the new one.
No need to replace, a few minutes on the EZ-Liner, and it will be good as new.

Quote:
I have one sitting on the shelf to replace on my E300 in about two weeks time. Courtesy of my dearest sister who misjudged the parking lot stopper thingy and wacked the car against it.
I assume that's what happened to this one.

Thanx,
Shorty.

"If you set out to fail, and succeed, which have you done?"
bluerooster is offline  
post #8 of 9 (permalink) Old 05-25-2019, 02:52 PM Thread Starter
BenzWorld Member
 
Date registered: Sep 2012
Vehicle: '95 S500 (sold), '97 E420
Posts: 222
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
(Thread Starter)
Quote:
Originally Posted by pfsantos View Post
Assume worst case scenario, that the rad is bad (transmission cooler). A fuel leak can sometimes clean up areas around it, but that would look a little different.
Radiator seems to be in good shape. No coolant leak, and oil leak appears to come from the fitting where the tranny cooler line attaches. I'll know more tomorrow.

Thanx,
Shorty.

"If you set out to fail, and succeed, which have you done?"
bluerooster is offline  
post #9 of 9 (permalink) Old 05-25-2019, 03:03 PM Thread Starter
BenzWorld Member
 
Date registered: Sep 2012
Vehicle: '95 S500 (sold), '97 E420
Posts: 222
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
(Thread Starter)
Got it home today. And somewhat cleaned up. Was some body damage on the right side, and a not so good repair.
It's OK for what I gave for the car. But looks like a Maaco job. Easy to fix, just needs a good block sand, and re-shoot.
Might as well go ahead and take care of a few parking lot dings while I'm at it, and a couple of handbag scratches on the decklid.

A/C doesn't blow cold, I assume evaporator, and hope stuck duo valve. I'll know more tomorrow.

A couple of buttons are missing off of switches, DS headrest switch "knob", and one on the console, that I've no clue what it is, or does. Just has a pic of a little person beside it. Head rest works fine, just the knob has popped off. And of course the radio knob is in sad shape.

I'll post a pic or two in a while.

Thanx,
Shorty.

"If you set out to fail, and succeed, which have you done?"
bluerooster is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W210 E-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Test Fonzi Test 14 05-02-2017 06:04 AM
troll 414228 Benzworld Site issues forum 3 05-19-2016 08:04 PM
How many forum members does it take to change a light bulb? cnd W126 S,SE,SEC,SEL,SD,SDL Class 23 03-07-2004 06:48 PM
OT - How many forum members does it take to change a lightbulb? Benza W163 M-Class 5 01-17-2004 02:37 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome