2001 E430 opinions needed - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 05-16-2019, 01:27 PM Thread Starter
BenzWorld Newbie
 
Date registered: May 2019
Location: Dallas, texas
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
2001 E430 opinions needed

I have a 2001 E430, that about 2 weeks ago i paid about $1500 to have the conductor plate replaced, & new map sensor put in. A few days ago i was driving the car when it appeared to go into limp mode again, resulting in me being stuck at a light for about 30 mins til it decided it wanted to move. Had the car towed back to my local repair place. I have my own code reader, & it shows these codes: P0130 (O2 SENSOR BAD), & P0700(TRASNMISSION CONTROL SYSTEM). The guy at the repair shop called me today & said it needs some transmission work that could be anywhere from $2000-$4000.

What I would like to know from ya'll is if it is worth repairing the car at almost 200k miles or putting that money towards another used car under $10k. My fear is that i have the car's transmission repaired & something else breaks, or that i spend 10k max on a used benz & the car give me similar problems with weeks/month/years. Please share your thoughts, Thanks.
vetteguy777 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 05-17-2019, 11:36 AM
DrX
Outstanding Contributor
 
DrX's Avatar
 
Date registered: Aug 2006
Vehicle: 2002 ML320, 2003 A160, 2002 ML500, 2018 GLS350d
Location: Brisbane, Australia
Posts: 4,122
Mentioned: 3 Post(s)
Quoted: 649 Post(s)
Ask him exactly what the codes are, from the ETC module (also known as TCM). If there is P0700, then there must be a corresponding 3-digit fault code that only a pro-level scanner can extract from the trans control system.

If it had transmission work just 2 weeks ago, return it to the workshop who changed the conductor plate. They probably overfilled the gearbox with trans fluid.

(wrong forum)
DrX is offline  
post #3 of 7 (permalink) Old 05-17-2019, 11:46 AM Thread Starter
BenzWorld Newbie
 
Date registered: May 2019
Location: Dallas, texas
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
the three digit code is "146", then says the transmission has sporadically an impermissible transmission ratio. He referred me to a transmission shop. is that necessary? or is it the overfilled gearbox?
vetteguy777 is offline  
Sponsored Links
Advertisement
 
post #4 of 7 (permalink) Old 05-17-2019, 11:48 AM Thread Starter
BenzWorld Newbie
 
Date registered: May 2019
Location: Dallas, texas
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
I forgot to mention that he said that he "cleared the code, which makes the car drive able, i assume till the code pops back up, & he told me that i could keep driving the car, just to clear the code with my reader the next time it came up... makes me think it's an electrical or ecu issue. I drove the car home from the repair shop about an hr ago with no hiccups thankfully.
vetteguy777 is offline  
post #5 of 7 (permalink) Old 05-17-2019, 01:14 PM
DrX
Outstanding Contributor
 
DrX's Avatar
 
Date registered: Aug 2006
Vehicle: 2002 ML320, 2003 A160, 2002 ML500, 2018 GLS350d
Location: Brisbane, Australia
Posts: 4,122
Mentioned: 3 Post(s)
Quoted: 649 Post(s)
For code 146, it was probably incorrect ATF level after the trans pan drop/refill. See the table under Figure 1 at “050 146 P0700”: STAR TekInfo

That lists potential causes as ATF level, wiring harness, and incorrectly reassembled piston B2/B3 guide (screws loose/missing), all of which sound fixable for under $2000. 🤔

Your basic code reader can’t clear code 146, but it can clear P0700. Might not get it out of limp mode. You can limp back to his shop to clear the ETC module.

Last edited by DrX; 05-17-2019 at 01:35 PM.
DrX is offline  
post #6 of 7 (permalink) Old 05-22-2019, 12:23 PM Thread Starter
BenzWorld Newbie
 
Date registered: May 2019
Location: Dallas, texas
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Just a quick update, the guy at the transmission shop called me today to tell me that nothing is wrong with the car...so I fear that I will be driving the car with my kid or something & It goes into limp mode or stalls or whatever.
vetteguy777 is offline  
post #7 of 7 (permalink) Old 05-23-2019, 08:39 PM
BenzWorld Extremist
 
Date registered: Sep 2016
Vehicle: 2002 E55 AMG Sedan
Location: Spring Hill, FL
Posts: 1,016
Mentioned: 6 Post(s)
Quoted: 270 Post(s)
You overpaid for the conductor plate replacement and map sensor.

When you had the conductor plate replaced, do you know what brand part was used? Also was the pilot bushing/electrical connector that always leaks replaced? I would also check your TCM for transmission fluid to see if there is any fluid in there which can cause issues. I would also check the fluid level.
illstplaya is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W210 E-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Help needed to get my 2001 clk convertible started dan84v General Mercedes-Benz 0 04-15-2013 01:52 PM
What is fair price to pay for 2001 e430 Taylors 420 W210 E-Class 5 08-11-2011 11:15 AM
2001 E430 Sport Rim spawnx1 W210 E-Class 6 05-13-2011 10:47 AM
10 Best Cars of the Past Decade Nightbird Off-Topic 2 12-30-2010 12:54 PM
2001 E430 Time to Sell? Opinions.... chino26 W210 E-Class 8 07-25-2010 04:26 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome