Instrument Cluster Pixel - 2001 W210 E-320 Station Wagon - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 05-15-2019, 07:41 AM Thread Starter
BenzWorld Member
 
Date registered: Nov 2005
Vehicle: 1997 E-420, 2001 E-320, 2007 S-550, 2009 E-350
Location: California
Posts: 307
Mentioned: 2 Post(s)
Quoted: 26 Post(s)
Send a message via Yahoo to hadam
(Thread Starter)
Instrument Cluster Pixel - 2001 W210 E-320 Station Wagon

Hi all, I have 2001 W210 E-320 Station Wagon. Recently the pixel on instrument cluster where you see the outside temperature are not showing the correct temperature.

I will be taking IC off this weekend for other troubleshooting. I wanted to do a easy quick temporary fix.

I found this on YouTube. I like to perform this on IC only for the outside temperature.

Has any one done this and how long this remedy lasted?

Thanks in advance for your support.


Attached Thumbnails
Click image for larger version

Name:	2019-05-15_06-30-33_841.jpg
Views:	5
Size:	40.1 KB
ID:	2512706   Click image for larger version

Name:	2019-05-15_06-30-40_269.jpg
Views:	5
Size:	33.0 KB
ID:	2512708  

2001 MB E-430 - 150K Miles Gone- Totaled
2009 MB E-350 - 107K Miles
2001 MB E-320 - 164K Miles
2003 MB CLK-320 Cabriolet - 126K Miles
1997 MB E-420 - 157K Miles
2007 MB S-550 - 140K Miles
2011 MB G-550 - 90K Miles

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
hadam is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 05-15-2019, 08:22 AM
Outstanding Contributor
 
Date registered: Jun 2012
Vehicle: 1998 E320 base sedan @ 160kmiles
Location: Boca Raton, FL
Posts: 4,917
Mentioned: 72 Post(s)
Quoted: 1111 Post(s)
Send a message via Skype™ to mrboca
It may work for a while, but if you want a better solution and have steady hands, and mechanical skills, you may consider the replacement of the ribbon cable.

AK speedo

They also have a Youtube video on how to do it.
mrboca is online now  
post #3 of 4 (permalink) Old 05-18-2019, 04:23 PM Thread Starter
BenzWorld Member
 
Date registered: Nov 2005
Vehicle: 1997 E-420, 2001 E-320, 2007 S-550, 2009 E-350
Location: California
Posts: 307
Mentioned: 2 Post(s)
Quoted: 26 Post(s)
Send a message via Yahoo to hadam
(Thread Starter)
mrboca, some update. I went easy way by adding some foam between the ribbon cable and factory pad on display in IC.

All good it is working fine. I just did the ambient temperature display, I did not do the time/gear shifter, may be next time.

It was Easy peasy job. Took me 1 hour from time to remove the IC from car and then working on IC plus re installing in car. Quite easy. Next I will do ambient temperature on my W208 2003 CLK-320, my summer baby.

Below are the photos.
Attached Thumbnails
Click image for larger version

Name:	2019-05-18_13-50-53_586.jpg
Views:	2
Size:	51.0 KB
ID:	2513834   Click image for larger version

Name:	2019-05-18_13-50-31_232.jpg
Views:	2
Size:	52.7 KB
ID:	2513836   Click image for larger version

Name:	2019-05-18_13-55-37_155.jpg
Views:	2
Size:	63.4 KB
ID:	2513838   Click image for larger version

Name:	2019-05-18_13-58-31_968.jpg
Views:	2
Size:	36.2 KB
ID:	2513840   Click image for larger version

Name:	2019-05-18_13-58-58_747.jpg
Views:	2
Size:	49.4 KB
ID:	2513842  

Click image for larger version

Name:	2019-05-18_13-59-08_188.jpg
Views:	2
Size:	40.4 KB
ID:	2513844   Click image for larger version

Name:	2019-05-18_14-30-47_236.jpg
Views:	2
Size:	41.1 KB
ID:	2513846   Click image for larger version

Name:	2019-05-18_14-33-54_767.jpg
Views:	2
Size:	41.4 KB
ID:	2513848   Click image for larger version

Name:	2019-05-18_14-56-58_770.jpg
Views:	2
Size:	29.0 KB
ID:	2513850   Click image for larger version

Name:	2019-05-18_15-35-49_774.jpg
Views:	2
Size:	44.9 KB
ID:	2513852  


2001 MB E-430 - 150K Miles Gone- Totaled
2009 MB E-350 - 107K Miles
2001 MB E-320 - 164K Miles
2003 MB CLK-320 Cabriolet - 126K Miles
1997 MB E-420 - 157K Miles
2007 MB S-550 - 140K Miles
2011 MB G-550 - 90K Miles

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by hadam; 05-18-2019 at 04:29 PM.
hadam is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 05-18-2019, 04:26 PM Thread Starter
BenzWorld Member
 
Date registered: Nov 2005
Vehicle: 1997 E-420, 2001 E-320, 2007 S-550, 2009 E-350
Location: California
Posts: 307
Mentioned: 2 Post(s)
Quoted: 26 Post(s)
Send a message via Yahoo to hadam
(Thread Starter)
Some more photos.
Attached Thumbnails
Click image for larger version

Name:	2019-05-18_15-36-36_538.jpg
Views:	2
Size:	49.9 KB
ID:	2513854   Click image for larger version

Name:	2019-05-18_15-36-42_510.jpg
Views:	2
Size:	46.0 KB
ID:	2513856   Click image for larger version

Name:	2019-05-18_15-38-02_200.jpg
Views:	1
Size:	50.6 KB
ID:	2513858   Click image for larger version

Name:	2019-05-18_15-53-40_484.jpg
Views:	2
Size:	61.6 KB
ID:	2513860   Click image for larger version

Name:	2019-05-18_15-53-46_121.jpg
Views:	2
Size:	52.2 KB
ID:	2513862  

Click image for larger version

Name:	2019-05-18_13-46-49_707.jpg
Views:	2
Size:	56.7 KB
ID:	2513864   Click image for larger version

Name:	2019-05-18_14-56-45_136.jpg
Views:	1
Size:	55.5 KB
ID:	2513866   Click image for larger version

Name:	2019-05-18_14-56-58_770.jpg
Views:	1
Size:	29.0 KB
ID:	2513868  

2001 MB E-430 - 150K Miles Gone- Totaled
2009 MB E-350 - 107K Miles
2001 MB E-320 - 164K Miles
2003 MB CLK-320 Cabriolet - 126K Miles
1997 MB E-420 - 157K Miles
2007 MB S-550 - 140K Miles
2011 MB G-550 - 90K Miles

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
hadam is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W210 E-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
W638 instrument cluster swap - 14" to 15" tyres & tools to reprogram speedo ratio Thirsty V-Class 0 05-07-2019 09:53 AM
FS: parting out several 98,99,00,01 ML's sc_mopar For Sale/Wanted/Trade/Giveaway 1 01-21-2016 01:06 AM
WANTED: Instrument Cluster for W210 E320 cqhall For Sale/Wanted/Trade/Giveaway 4 01-27-2007 12:13 AM
wanted w210 wagon instrument cluster nihilo For Sale/Wanted/Trade/Giveaway 0 04-26-2005 07:57 PM
from 2001 vette to 2002 320 wagon Guest (MBNZ) W203 C-Class 2 08-08-2001 09:55 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome