Looks Like the 2003 E320 Wagon I bought on Ebay is a LEMON - Page 4 - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #31 of 37 (permalink) Old 01-23-2016, 01:58 PM Thread Starter
BenzWorld Junior Member
 
JonBoyOhBoy's Avatar
 
Date registered: Nov 2015
Vehicle: 2003 E320 Wagon
Location: New York City
Posts: 48
Mentioned: 0 Post(s)
Quoted: 13 Post(s)
(Thread Starter)
Quote:
Originally Posted by Kajtek1 View Post
Your indy is not cheap, but that happens when you don't DIY.
I would double check leveling valve as $500 looks high and it might need simple adjustment.
Amazon has them for $410 but I see them on other sites as low as $260, but I get it- all shops jack up the prices of parts. Yea I wish I could do the work myself but I don't have the time or the mechanical talent.
I was told the rear shocks aren't leaking, then another guy told me the right rear has a very "slight" leak. I'm wondering if this will get worse when the fluid is pumped to the shocks under high pressure
JonBoyOhBoy is offline  
Sponsored Links
Advertisement
 
post #32 of 37 (permalink) Old 01-23-2016, 02:58 PM
BenzWorld Member
 
wagonz's Avatar
 
Date registered: Feb 2010
Vehicle: '02 E320 4matic Wagon
Location: New Jersey
Posts: 326
Mentioned: 0 Post(s)
Quoted: 14 Post(s)
I would try adjusting first, assuming you can loosen the adjuster nut. Probably pretty rusty. Hate to take those lines off, may open a can of worms.
wagonz is offline  
post #33 of 37 (permalink) Old 01-25-2016, 04:51 PM
BenzWorld Elite
 
Date registered: Feb 2010
Vehicle: 2007 E320 Bluetec, 2008 320ML CDI
Location: Western Michigan
Posts: 2,393
Mentioned: 2 Post(s)
Quoted: 272 Post(s)
From my SE Michigan perspective the underbody rust seems normal. Can't comment on the body rust.
The oil level sender requires removal of the lower oil pan. Not the end of the world, just reality.
I'd recheck to confirm its really the source before changing it.
On my '98 E320 the sender will occasionally send low oil messages usually during cold weather. None are true.
You suspension concerns seem more important for the moment.
Car looks OK from the pictures.

All the best, Skippy

Skippy,
SkippyJasper is offline  
Sponsored Links
Advertisement
 
post #34 of 37 (permalink) Old 01-30-2016, 06:36 PM Thread Starter
BenzWorld Junior Member
 
JonBoyOhBoy's Avatar
 
Date registered: Nov 2015
Vehicle: 2003 E320 Wagon
Location: New York City
Posts: 48
Mentioned: 0 Post(s)
Quoted: 13 Post(s)
(Thread Starter)
Well, there it is. another $2300 into the car. The gas lines were indeed rusted badly and liking, and so was the Hydraulic fluid lines, those weren't leaving though. And the level valve looked like it wa sitting on the bottom of the sea. But the car is now sitting at the right level. Did I over pay?
Now I am married to the car. If I sell it its an instant and painful loss. I NEED to get my moneys worth on the car, which translates into 3 years without any more MAJOR repairs
Attached Thumbnails
Click image for larger version

Name:	IMG_3615.jpg
Views:	51
Size:	63.4 KB
ID:	1760585  
JonBoyOhBoy is offline  
post #35 of 37 (permalink) Old 01-30-2016, 06:57 PM
BenzWorld Elite
 
Kajtek1's Avatar
 
Date registered: Dec 2005
Vehicle: E320/E250 Bluetec Ford F350 6.7l
Location: V E G A S
Posts: 35,407
Mentioned: 30 Post(s)
Quoted: 1980 Post(s)
Even if you buy 12 months old car, you will have to spend at least $500 for the scheduled service at dealer.
So frankly spending $2300 for car bought at auction with lot of problems known to address is cheap IMHO
Good luck with driving.
I can't guarantee you will drive it for 3 years without another bigger repair, but at least you have a base that once you fix the problem, it should not come back 6 months later .


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Kajtek1 is offline  
post #36 of 37 (permalink) Old 01-30-2016, 08:40 PM
Outstanding Contributor
SDS Guru
 
Deplore's Avatar
 
Date registered: Apr 2014
Vehicle: 1998 MB E300TD, 1997 MB E320
Location: LA, CA
Posts: 3,155
Mentioned: 125 Post(s)
Quoted: 763 Post(s)
Well, if it's any consolation, the motor mount replacement is CHEAP....especially since you have 4matic.
MAVA likes this.
Deplore is offline  
post #37 of 37 (permalink) Old 01-31-2016, 05:40 PM Thread Starter
BenzWorld Junior Member
 
JonBoyOhBoy's Avatar
 
Date registered: Nov 2015
Vehicle: 2003 E320 Wagon
Location: New York City
Posts: 48
Mentioned: 0 Post(s)
Quoted: 13 Post(s)
(Thread Starter)
Quote:
Originally Posted by Deplore View Post
Well, if it's any consolation, the motor mount replacement is CHEAP....especially since you have 4matic.
that makes me feel better, they were shot. Looked like cracked
pancakes full of oil.
JonBoyOhBoy is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W210 E-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome