What have you done for your W210 today/lately? - Page 50 - Mercedes-Benz Forum
Reply
LinkBack Thread Tools Display Modes
post #491 of 515 (permalink) Old 04-23-2019, 05:16 PM
BenzWorld Member
 
Date registered: Apr 2014
Vehicle: 2000 E320 (W210)
Location: Canberra, Australia
Posts: 71
Mentioned: 0 Post(s)
Quoted: 14 Post(s)
Am having flex disks and gearbox selector bushing replaced today. Both things need doing - disks are looking old and will probably see cracks when they are off. Selector bushing is no longer there.
brodi3 is offline  
Sponsored Links
Advertisement
 
post #492 of 515 (permalink) Old 04-29-2019, 04:52 AM
Lifetime Premium Member
 
Date registered: Jul 2012
Vehicle: E300
Location: Texas
Posts: 17
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Lifetime Premium Member
I replaced the fuel tank. The original tank rusted in the filler neck area and was seeping Diesel.

1999 E300
603,491 miles
dfleck63 is offline  
post #493 of 515 (permalink) Old 04-30-2019, 08:02 PM
BenzWorld Member
 
Date registered: Jun 2010
Vehicle: 2000 mercedes-benz e320
Location: Houston, TX
Posts: 53
Mentioned: 1 Post(s)
Quoted: 6 Post(s)
Just replaced the plugs, wires and coil packs on my 2000 e320. I put the job off for so long because I was really scared of the tight clearance on the rear 2 cylinders, but the job wasn't that bad with a 3 inch ratchet extension. Mileage: 166,500.
eliastfk is offline  
Sponsored Links
Advertisement
 
post #494 of 515 (permalink) Old 04-30-2019, 08:21 PM
BenzWorld Newbie
 
Date registered: Apr 2019
Vehicle: 2010 E63 (W212 09/2-L AMG-M156) & 2001 W210 E320
Location: Tennessee, USA
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
W210 Estate - Replaced Throttle Position Sensor

This was such an easy thing to do.

PROBLEM: after depressing the accelerator pedal agressively, the car would become almost unresponsive. Had to turn car off and back on again to accelerate.

SOLUTION: replaced TPS. Took 10 minutes and the problem went away.
k3net is offline  
post #495 of 515 (permalink) Old 05-01-2019, 08:26 PM
BenzWorld Member
 
JBA&LNS's Avatar
 
Date registered: Aug 2011
Vehicle: 2001 E320 4Matic Wagon named "Weecle von Diva"
Location: Upper East Coast
Posts: 86
Mentioned: 0 Post(s)
Quoted: 11 Post(s)
Replaced the hood struts in 10 minutes or less thanks to this simple tutorial, without which I would have been flummoxed.

https://www.benzworld.org/forums/w21...ml#post3179208
JBA&LNS is offline  
post #496 of 515 (permalink) Old 05-02-2019, 12:58 AM
Lifetime Premium Member
 
unimogken's Avatar
 
Date registered: May 2004
Vehicle: 1965 404, 1980 MB4/94, 1983 240D, 1999 E55, 2000 ML55
Location: Redmond, WA
Posts: 599
Mentioned: 0 Post(s)
Quoted: 78 Post(s)
Lifetime Premium Member
Got pulled over 2 times within 20 miles for a tail light bulb out!

I really need to get off of my arse to fix that silly Bulb Malfunction message! Ugh.
unimogken is offline  
post #497 of 515 (permalink) Old 05-06-2019, 01:06 AM
BenzWorld Member
 
Date registered: Apr 2009
Vehicle: 2000 E320 Sedan, 2002 E430 Sedan
Location: Bay Area, CA
Posts: 83
Mentioned: 1 Post(s)
Quoted: 16 Post(s)
For the 2002 E430, today I swapped out the sagging seat back pocket behind driver seat that's been buggin me for a while. I picked up a set of 2 seatbacks from eBay good condition and in matching color. Now I have a spare! A reminder for anyone doing this the 2 screws on the bottom are Torx 15 and be very careful when removing the little rectangular night light.

Also, passenger side windshield spray nozzle was not spraying while driver side nozzle stream was weak. I removed the passenger side spray nozzle assembly and reattached the hose that has a tendency to slip off on their own. This is not my first time with this problem- last year it was the driver side hose that came off, and I've had it happen in my old 2000 E320 in the past.
Attached Thumbnails
Click image for larger version

Name:	e430 seatback before.jpg
Views:	8
Size:	35.1 KB
ID:	2510248   Click image for larger version

Name:	e430 seatback underview.jpg
Views:	8
Size:	45.6 KB
ID:	2510250   Click image for larger version

Name:	e430 seatback after.jpg
Views:	7
Size:	40.1 KB
ID:	2510252  
MoveOverRover is offline  
post #498 of 515 (permalink) Old 05-07-2019, 10:56 AM
BenzWorld Member
 
Date registered: Jan 2008
Vehicle: 2001 E430 Sport 36K, Brilliant Silver / Charcoal 2002 E320 sedan / 41K sold, 1999 CLK 320 33K sold
Location: Maui Hawaii
Posts: 197
Mentioned: 0 Post(s)
Quoted: 32 Post(s)
Garage
wondering the mileage of your car needing the new flex discs?
mauipaul is offline  
post #499 of 515 (permalink) Old 05-10-2019, 06:47 AM
BenzWorld Member
 
Date registered: Jun 2011
Vehicle: 1998 E320 Sedan RWD 150k mi
Location: NW
Posts: 190
Mentioned: 1 Post(s)
Quoted: 23 Post(s)
AC compressor and driver side cat, just in time for 90 degree weather.
tmabiker is offline  
post #500 of 515 (permalink) Old 05-10-2019, 12:32 PM
BenzWorld Member
 
Smartchoice's Avatar
 
Date registered: Mar 2015
Vehicle: 2001 W210 E320
Location: Nigeria
Posts: 79
Mentioned: 0 Post(s)
Quoted: 7 Post(s)
replaced transmission twice, first one was incompatible 722.630, had to get a replacement of its exact type 722.618 and has been flawless for the last two weeks. Replaced the sagging headliner, now changed my rear tires to the 55 size while the front ones are 60. my multi function steering control going nuts.... ac has a mind of its own.... hope to get around to it, 02 sensors need replacement... mrboca has been very helpful, wonder where ohlord is?
Smartchoice is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W210 E-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 3 (0 members and 3 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome