What have you done for your W210 today/lately? - Page 40 - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #391 of 502 (permalink) Old 04-16-2018, 10:15 PM
BenzWorld Senior Member
 
Date registered: Jun 2011
Vehicle: 2001 E320 RWD- 2011 E350 4M
Location: Denver
Posts: 565
Mentioned: 1 Post(s)
Quoted: 16 Post(s)
Quote:
Originally Posted by spartan1994 View Post
Hey Fred - I see that you are nearby. I live in Concord!
I just bought a 2002 e320 and it has 140k miles. I have no history on it. It appears that the transmission fluid is ORIGINAL and has not been changed from the looks of it (original cap still on the transmission fill hole). My question is - do you think I should risk doing a drain/fill of the pan and replacing filter in transmission at this point? The car shifts okay (not as smooth as it probably should in my opinion) but I'm afraid of tampering with the fluid and making it worse. Any feedback is appreciated. I've been reading all about this on this forum and everyone has a different opinion......
At 140K miles you are not too late at all, my friend bought a 2005 E320 4M back in 2013 which is mechanically the same car as W210. He got it at 125ish miles, I’ve done a filter&gasket job for him at 136 or 138K something like that, interestingly the fluid in the car was yellowish color, we did not have any history so we drained and filled and drained&filled again twice after driving half hour each time so we got all that yellow crap out, I even posted pics here after break open his filter. 2 years later in 2016 we did another filter&gasket job at 216K miles and just last week we did another one at 305K. That car is a trooper.

I got my W210 in 2010 60K miles on the clock and my first job was a filter&gasket job at 65K, then at 84K I’ve done a fluid exchange aka Yumling Method here, it is in Stickies. Then fluid&filter&gasket jobs at 105, 120 and 141K. And just today I’ve done another filter&gasket job at 176K along with the belt and idler pulley.

As a side note; after completely changing out his fluid back in 2014, I let my friend drive his 4MAtic the first time and he kept going “oh woooww, oh woooww” every time the car shifts.

So I definitely say go for it and you’ll see the difference. I personally don’t like the flush idea especially at that mileage, I’d rather go baby steps, you can do a filter&gasket job now and another one in a week or so, just my $.002
GOOd luck.
spartan1994 likes this.
01blackhawk is offline  
Sponsored Links
Advertisement
 
post #392 of 502 (permalink) Old 04-17-2018, 06:25 AM
BenzWorld Member
 
spartan1994's Avatar
 
Date registered: May 2017
Vehicle: 2014 S550 (W222), 1995 S420 (W140), 2002 E320 (SOLD)
Location: Concord, California (SF East Bay Area)
Posts: 115
Mentioned: 0 Post(s)
Quoted: 25 Post(s)
Garage
Thank you Blackhawk! This makes me feel much better!! I think I will go ahead and do the drain/fill a couple times like you did (along with filter/gasket changes). Hopefully I won't destroy my transmission by changing the fluid at this point.....
spartan1994 is offline  
post #393 of 502 (permalink) Old 04-17-2018, 10:21 AM
BenzWorld Senior Member
 
Date registered: Jun 2011
Vehicle: 2001 E320 RWD- 2011 E350 4M
Location: Denver
Posts: 565
Mentioned: 1 Post(s)
Quoted: 16 Post(s)
Unless you make a huge mistake you cant really destroy these transmissions, they are so rugged and robust boxes, one advice thou, invest in a genuine dipstick from a stealer. I bought one back in 2010 from the stealer for $55, ebay or BS homemade ones are running $35 or 40 anyway so I paid a little more but that thing is legit and it paid for itself more than 3 times. I`ve done many changes myself on my car, I`ve changed my buddy`s fluid at least 3 or 4 times and I loaned it to another friend couple of times, I haven`t worked on his C class 4M but he borrowed it twice so it is really useful.
Another thing, be really careful and gentle when you opening the drain plug in the tranny pan, I`m sure if your fluid never changed it is pretty tight so be cautious both taking out and tightening back. Clean the pan with break cleaner and make sure it is bone dry when you install back, clean the magnet and install the new gasket tightly, dont over torque the pan bolts. Visiually inspect the plug and if its not leaking don`t mess with it, everybody advocates here that you need to change it every time you do a filter&gasket job but I dont. I`ve changed it once back in 2010 or 11 because it was leaking, I cleaned the TCM also with contact cleaner and kept an eye on it for a year once a month since then I check the TCM maybe once a year, every time I`m under the car I check the plug and it is bone dry. So if its ain`t broken I ain`t mess with it.
I sent you a PM also, if you have any questions just post here or shoot me a PM, will be more than happy to help.

Cheers
Al
83126 and Steve Miller E320 like this.
01blackhawk is offline  
Sponsored Links
Advertisement
 
post #394 of 502 (permalink) Old 04-23-2018, 07:46 AM
BenzWorld Newbie
 
Date registered: Aug 2010
Vehicle: E320 2001
Location: Richmond, VA
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
B Service
Air Filter
Carbon Cabin Filters
Transmission Service
Coolant Flush
Air Conditioner Freon

Last Week

New Tires
Wiper Blade
Fixed Brake light
New Battery

Next

Spring Perch Repair



Only 119,000 Miles on it. Its tight and runs perfectly. I am going to run this until it dies.
J-Meara is offline  
post #395 of 502 (permalink) Old 04-23-2018, 08:00 AM
BenzWorld Member
 
spartan1994's Avatar
 
Date registered: May 2017
Vehicle: 2014 S550 (W222), 1995 S420 (W140), 2002 E320 (SOLD)
Location: Concord, California (SF East Bay Area)
Posts: 115
Mentioned: 0 Post(s)
Quoted: 25 Post(s)
Garage
This weekend I replaced the ATF fluid, filter, gasket. Plan to do this a second time next weekend to get more of the old stuff out. After the first change it seems to shift much smoother!
Current mileage is about 142,430 and hoping to take care of it and have it last many more miles!
01blackhawk likes this.
spartan1994 is offline  
post #396 of 502 (permalink) Old 04-27-2018, 06:01 PM
BenzWorld Member
 
Date registered: Jun 2011
Vehicle: 1998 E320 Sedan RWD 150k mi
Location: NW
Posts: 188
Mentioned: 0 Post(s)
Quoted: 23 Post(s)
Put a new (reman) alternator in and rear sway bar bushings/links. Old alt seemed fine at 139K (it's on eBay right now if any is interested) but I figured at 20 years old maybe it would be smart as a preventative. Didn't notice much change with the sway bar stuff, old links didn't look bad, but the fronts are starting to squeak. Next up: figure out why the blower motor quit blowing...hopefully not related to the new alt. Also yanked out the washer fluid heater and shortened the coolant line, I suspect a little coolant was leaking into the washer fluid and it sounds like a good preventative even if not.
Steve Miller E320 likes this.
tmabiker is offline  
post #397 of 502 (permalink) Old 04-30-2018, 09:30 AM
BenzWorld Member
 
spartan1994's Avatar
 
Date registered: May 2017
Vehicle: 2014 S550 (W222), 1995 S420 (W140), 2002 E320 (SOLD)
Location: Concord, California (SF East Bay Area)
Posts: 115
Mentioned: 0 Post(s)
Quoted: 25 Post(s)
Garage
Did the 2nd transmission pan drop/refill and also replaced filter...... also was able to get the original drain plug out of the pan (head was stripped on it so had to drill it out) and replace with new drain plug.
Next weekend will do 3rd and final drain/fill of ATF, will replace the transmission connector plug, and should be good to go for another 30-40k miles!
Steve Miller E320 likes this.
spartan1994 is offline  
post #398 of 502 (permalink) Old 04-30-2018, 12:47 PM
BenzWorld Member
 
spartan1994's Avatar
 
Date registered: May 2017
Vehicle: 2014 S550 (W222), 1995 S420 (W140), 2002 E320 (SOLD)
Location: Concord, California (SF East Bay Area)
Posts: 115
Mentioned: 0 Post(s)
Quoted: 25 Post(s)
Garage
Beautiful Car! Do you still have it? I know this post is from almost a year ago....
A couple of months ago I got the same car you have - 2002 E320, Same color exterior and interior...with 141k miles....except my paint isn't nearly as nice as yours but I think once i do the clay bar/wax it should look much better!
I wasn't planning to tint the windows, but now that I see your car - it looks really good with the tint. Do you have a picture of the back window tint by chance? In the past on some of my cars the window tint people have made it so the defroster lines are visible and it doesn't look very good. Just curious if your back window is the same?
Anyways, beautiful car!
spartan1994 is offline  
post #399 of 502 (permalink) Old 04-30-2018, 04:31 PM
BenzWorld Newbie
 
Date registered: Apr 2018
Vehicle: 1998 E320 w210 sedan
Location: San Francisco, USA
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
I just changed all the spark plugs, coils, and wires; put new transmission mount; changed oil; cleaned EGR valve and pipe.

Put new stereo too.

———-
‘98 E320 non4Matic sedan 167k miles young
‘01 bmw 330Ci convertible 184k miles young
Steve Miller E320 likes this.
Kneedspeed is offline  
post #400 of 502 (permalink) Old 05-04-2018, 05:38 PM
BenzWorld Member
 
Date registered: Jun 2011
Vehicle: 1998 E320 Sedan RWD 150k mi
Location: NW
Posts: 188
Mentioned: 0 Post(s)
Quoted: 23 Post(s)
Engine air filter, motor blower regulator, silicone wiper blade, and 2 tires that wore badly when there was an alignment prob, and some blue devil oil stop leak to mitigate oil seepage from the breather plate thing and any other little ones that might pop up.
tmabiker is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W210 E-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome