ATF in Transmission Control Module: 99 E 320 - Page 17 - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #161 of 167 (permalink) Old 04-20-2014, 10:15 AM
BenzWorld Junior Member
 
Date registered: Sep 2008
Vehicle: 2006 E 350, 2007 c 280 4-matic
Location: Shawnee, Kansas City
Posts: 12
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
I know this is an old thread, but is the 2006 E 350 the same transmission? I have a 2006 E 350 non-4 matic, with two codes P2767 AND P2768 (Input/Turbine speed sensor "B" no signal and Input/Turbine speed sensor "B" circuit intermittent). So, if same or similar, do I just ned to replace the sped sensors only.......and of course, new filter, oil. etc.?
dcmsm is offline  
Sponsored Links
Advertisement
 
post #162 of 167 (permalink) Old 04-20-2014, 10:34 AM
BenzWorld Senior Member
 
Date registered: Jun 2011
Vehicle: 2001 E320 RWD- 2011 E350 4M
Location: Denver
Posts: 566
Mentioned: 1 Post(s)
Quoted: 17 Post(s)
As far as I know, If your car was a 4Matic then you`d have the same transmission, 5 speed 722.6 but you have a rear wheel drive car fitted with 7 speed 722.9 transmission.

I can`t really answer your other questions since I don`t know much about 722.9 transmissions but still it should not be too far off from the 5 speed 722.6.
01blackhawk is offline  
post #163 of 167 (permalink) Old 04-20-2014, 11:11 AM
Outstanding Contributor Always Remembered RIP
 
television's Avatar
 
Date registered: Sep 2005
Vehicle: 216 with everything. 2002 SL500 with everything. 2009 SL500 with everything.
Location: South coast .England
Posts: 6,543
Mentioned: 2 Post(s)
Quoted: 150 Post(s)
Quote:
Originally Posted by dcmsm View Post
I know this is an old thread, but is the 2006 E 350 the same transmission? I have a 2006 E 350 non-4 matic, with two codes P2767 AND P2768 (Input/Turbine speed sensor "B" no signal and Input/Turbine speed sensor "B" circuit intermittent). So, if same or similar, do I just ned to replace the sped sensors only.......and of course, new filter, oil. etc.?
Looks like the speed sensor plate gone down and so common, not that expensive and you get a fluid and filter change at the same time.
television is offline  
Sponsored Links
Advertisement
 
post #164 of 167 (permalink) Old 11-14-2014, 08:28 PM
BenzWorld Newbie
 
Date registered: Nov 2014
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Smile 2006 Mercedes Benz C230 Sport 2.5 V6 speed sensor failure. P2767

Hi everybody.
I got stuck in 2nd gear (limp mode) also got Check Engine lite ON. Scanned the system and got P2767 speed sensor no signal. Was reading a lot of forums and decided to replace the speed sensor, which is Conductor Plate.
I just started to replacing conductor plate on my 2006 MBZ C230 Sport 2.5 V6. I found out that my MBZ doesn't have transmission fill port. So, anyway I have to fix my MBZ myself. I don'n want to spend $xxxx... Will try to pump fluid after repairing, through the drain plug. So, I drained about 7 US quarters of fluid, simply removed the pan. Then I removed the valve body and then removed the conductor plate. So, the first valve and the fifth was very dirty. The fluid also very dirty (looks like I drained engine oil after 7k miles driving). My MBZ has only 54k miles on it. That's all for now, I will post updates as soon as I will get farther...
srglavor is offline  
post #165 of 167 (permalink) Old 02-28-2018, 05:31 PM
BenzWorld Member
 
Date registered: Dec 2009
Vehicle: 2002 E320 4Matic W210 w/ 230k as of 03/15/2018
Location: Northampton MA
Posts: 60
Mentioned: 0 Post(s)
Quoted: 17 Post(s)
What kind of bin is the valve body sitting in? I want one

See post #56 of this thread for the pic.

Quote:
Originally Posted by loubapache View Post
Everyone has a happy ending.

Op (Sri) had his conductor plate replaced by an Indie and all is well.

I replaced the conductor plate by myself today and all is also well. Here is a DIY writeup in PDF format (with photos) and also a picture of the valve body to get you in the mood reading the DIY article. It looks a little like open heart surgery, LOL.

We can happily close this thread now.

Edit: I re-uploaded the DPF file because I found a few typos.
Sibarks is offline  
post #166 of 167 (permalink) Old 07-08-2019, 08:33 AM
BenzWorld Newbie
 
Date registered: Jul 2019
Posts: 1
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
on my 98 mercedes e320 4matic its not shifting from first gear the rpm just keep going higher does anyone know why?

thanks kenny
kennethbrock1 is offline  
post #167 of 167 (permalink) Old 07-08-2019, 11:36 AM
BenzWorld Elite
 
Date registered: Jun 2012
Vehicle: 1998 E320 base sedan @ 160kmiles
Location: Boca Raton, FL
Posts: 5,308
Mentioned: 79 Post(s)
Quoted: 1191 Post(s)
Send a message via Skype™ to mrboca
Quote:
Originally Posted by kennethbrock1 View Post
on my 98 mercedes e320 4matic its not shifting from first gear the rpm just keep going higher does anyone know why?

thanks kenny
You mean when you shift the gear in Drive from Park or Neutral ?

How about Reverse ?

No-shift, right from the start, or after driving for a while ?
mrboca is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W210 E-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 2 (0 members and 2 guests)
 



Similar Threads
Topic Author Forum Replies Last Post
C230 Transmission control module question Behind Blue Eyes W202 C-Class 16 09-28-2015 11:09 AM
Help!!! Transmission Control Module eapen W210 E50 AMG, E55 AMG 2 05-01-2009 12:02 PM
E420 - Transmission Control Module Failure... chrisdpham W124 E,CE,D,TD Class 9 04-05-2008 02:37 AM
Transmission Control Module Change out baisdelr W163 M-Class 1 02-12-2008 03:40 PM
Transmission Electronic Control Module Tacjam W210 E50 AMG, E55 AMG 4 05-04-2006 10:23 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome