OE TUNING - HORRIBLE EXPERIENCE!!! - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 08-16-2018, 04:50 AM Thread Starter
BenzWorld Junior Member
 
chynatown's Avatar
 
Date registered: Sep 2010
Vehicle: 99 ML320 Elegance on 20's
Location: Peg City
Posts: 25
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
OE TUNING - HORRIBLE EXPERIENCE!!!

I just wanted to let everyone know about my horrible experience with OE Tuning and their service or lack there of!!!

After doing some research a couple of years ago, I decided to go with a stage 2 tune from OE Tuning. The tune was ok, great exhaust notes but the power wasn’t the best. Anyways, I noticed last month that they advertised a sale on a MB forum, plus they were offering updates for existing customers. I confirmed that they had an update to which they did, and they were also offering more “burble” for and up charge. I decided to go with both any away my ecu went. The turn around time was quick and I had my ecu back in my car in a couple of days!!!

Here’s where is all starts!!! When I got my ecu back, I took my car out for a cruise and noticed that I lost ALL of the exhaust notes and there was no increase in power at all. A stock C450/43 had more exhaust sounds than my car!!! I immediately called Tyler and told him what was going on, he said to drive it for the weekend and if nothing changed to send the ecu back and they would reimburse me the shipping charges. Drove the car all weekend and nothing changed!! I then proceeded to get a shipping quote to send the unit back overnight with insurance. Just so they had a heads up, I sent an email back to them with the amount and I got an email back right away saying that the shipping charges were too expensive and that they could get a better price. That worked for me as they would take care of everything and I wouldn’t be out of pocket.

Monday rolls around, FedEx picks up the package and it was delivered the next day. I called to see how the process went and they said they programmed it too aggressive and that’s why I lost all the exhaust notes. Tyler said that they completed it and it would be sent out that day. I was provided a tracking number so I tracked the package as I always do. This was sent out on July 10th and to this day I still don’t have my ecu!!!

LET ME BE CLEAR, OE Tuning did NOT lose my ecu, FedEx lost it but OE Tuning washed their hands of it!!!! I found out that they didn’t use my original box, they changed it to a med size Fedex box to save money!! I also found out that to save $25 they didn’t insure my package, so now i’m out $2000 for a new ecu and $2000 for a reputable company like Eurocharged to tune my new ecu!! This could of all been avoided if they paid the $25 insurance like I quoted them when they asked me to pay the shipping back. I’ve sent several emails trying to work something out and all they say is that they didn’t lose it and they did their part..........they also followed that up with a copy of their shipping policy.

They have not answered any of my emails or phone calls after this!!! These guys are a real class act!!
chynatown is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz AMG Forums > W205 C43 AMG, C63 AMG

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome