Cooling Fan runs on high very frequently - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 01-27-2018, 01:31 PM Thread Starter
BenzWorld Newbie
 
Date registered: May 2016
Vehicle: 2016 C63S
Location: Scottsdale, AZ
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Cooling Fan runs on high very frequently

Sorry for the duplicate post but I only now discovered the AMG specific W205 Thread:

I'm wondering if any other 16' W205 S owners are experiencing this issue. Even with low ambient temps, and relatively low operating temps during very relaxed driving, the cooling fan in my car runs a lot! I feel like this is new behavior as I've not noticed it before. I've been back for service twice and they insist the car and the fan system are FAD but I'd love to know some others observations. At the moment the attached picture was taken the cooling fan is running full on high. It's plainly audible inside the car with all windows closed. Thoughts?
Attached Thumbnails
Click image for larger version

Name:	IMG_3360.jpg
Views:	40
Size:	48.9 KB
ID:	2363033  
bgmix is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 01-28-2018, 05:38 PM
CH4S Artist
Outstanding Contributor
 
Teutone's Avatar
 
Date registered: Sep 2004
Vehicle: 1985 500SEC, 1991 190E 2.6.
Location: Los Angeles / Hannover Germany
Posts: 38,856
Mentioned: 19 Post(s)
Quoted: 1895 Post(s)
Lifetime Premium Member
I would try the simple and cheap things first, like put on a new pressure cap.
The spring wears out, and every reduction in system pressure will raise the temperature. I assume the thermostat opens the way its supposed to, and all hose connectors are snug?
Did your mechanic perform a pressure test on the cooling system? Remote IR thermometer are fairly inexpensive now, you can see whether your radiator has cool spots = blocked areas.

I had issues with frequently running electric fans on an older MB, ordered new Nissens radiator, thermostat, and hoses.
Changing the thermostat and pressure cap and checking all hose clamps didn't do much, but I had a new overflow container.
After installing the new overflow container, the electric fans stopped coming on (i shortened out the switch to make sure they workand the temperature gets to max 95 even on the hottest L.A. days.
Apparently older containers can develop small leaks along the seams.

So far there has been no need to install the new radiator

My nephew has a C63, and driving the car without traction control is fun.
Other than that, I don't know to what extend the above applies to your car.
Teutone is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz AMG Forums > W205 C43 AMG, C63 AMG

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome