Transmission downshifting issue - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 03-01-2018, 12:10 PM Thread Starter
Lifetime Premium Member
 
progolfer1's Avatar
 
Date registered: Mar 2014
Vehicle: 2004 CLK500 Cabriolet 2014 Mustang convertible 2016 C300 (wifes car) 55 TBird Old ford truck
Location: Now living on a Christmas tree farm in the hills of Carolina.
Posts: 567
Mentioned: 1 Post(s)
Quoted: 53 Post(s)
Lifetime Premium Member
(Thread Starter)
Transmission downshifting issue

I have a 2015 C300 with 7speed trans. just turned 50K today. Each time I took car in for service I told mechanic about hard downshifting from 3rd to 2nd and upshift from 2-3rd as well. Each time mechanic couldn't find a problem. I was reading review about the transmission when I ran across a Q&A about its shifting problems and they were saying that it was valve body and transmission had to be removed to be repaired . After reading others comments its apparent to me that MB doesn't want to own up to this problem . But I also read on several topics that MB finally issued a bulletin about the problem and having to repair it.
My question is where do I find this paper MB issued about the repair and how do I get my hands on one. And what do I do once I have this paper? Do I go storming to dealer for a "Look what I found" paper and discussion as to when to bring it in for repair ?

Any assistance would be appreciated as I have no idea where to look and the dealer is playing dumb.
Thanks

Be sure you're right then go ahead !
progolfer1 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 03-06-2018, 06:07 PM Thread Starter
Lifetime Premium Member
 
progolfer1's Avatar
 
Date registered: Mar 2014
Vehicle: 2004 CLK500 Cabriolet 2014 Mustang convertible 2016 C300 (wifes car) 55 TBird Old ford truck
Location: Now living on a Christmas tree farm in the hills of Carolina.
Posts: 567
Mentioned: 1 Post(s)
Quoted: 53 Post(s)
Lifetime Premium Member
(Thread Starter)
I find it hard to believe that no one has had a shifting issue . If I were the only one I don't think MB would issue a repair on the transmission. From the conversations I read it has been an issue since the 7 speed was first used . Any body able to direct me to where I find repair letters or what ever you call them ?

Be sure you're right then go ahead !
progolfer1 is offline  
post #3 of 9 (permalink) Old 03-10-2018, 08:30 PM
BenzWorld Elite
 
Date registered: Jul 2006
Vehicle: 1999 E55, 2001 E320, 1990 560 SEC, 2004 ML350, 2001 ML55, 1995 S500, 1998 SL500, 2010 E550 Sport zoo
Location: NW Arkansas, La Jolla CA, Hong Kong
Posts: 7,031
Mentioned: 6 Post(s)
Quoted: 157 Post(s)
Let me try to be of some help..since you don't seem concerned about passing thru 50K miles - did you buy your C300 new and have extended new car warranty - or you bought CPO so you are not concerned about the 50K mile mark on original new car warranty - which is ist ?


1. You specifically mention downshift to 3rd-to-2nd and upshift 2nd-to-3rd - is this in "automatic" or "manual" mode - and if automatic mode which driving profile are you normally using ?

2. After your 30K transmission service - (a) is that when the "problem" started to appear ? (b) if problem had started before 30K miles - after the 30K transmission service - initially did it get better or worse ?

3. Over the past 8 weeks or so - has your problem - (a) stayed about the same (b) has it gotten worse ?

How long ago (time and miles) was your last dealer service - and was this transmission "problem" listed on that service invoice as a problem ?

A bit more info from you - I can try to help direct you towards a effective solution..
fabbrisd1 is offline  
Sponsored Links
Advertisement
 
post #4 of 9 (permalink) Old 03-11-2018, 04:57 AM Thread Starter
Lifetime Premium Member
 
progolfer1's Avatar
 
Date registered: Mar 2014
Vehicle: 2004 CLK500 Cabriolet 2014 Mustang convertible 2016 C300 (wifes car) 55 TBird Old ford truck
Location: Now living on a Christmas tree farm in the hills of Carolina.
Posts: 567
Mentioned: 1 Post(s)
Quoted: 53 Post(s)
Lifetime Premium Member
(Thread Starter)
This is my wifes car. A retirement present. The car was bought new with 9 miles on the odometer. I don't drive it that much. So it may have been having issues before I noticed them. The car is driven in the Automatic mode "C" profile. Just before the car was taken in for its initial service I noticed the shifting problem. I told the dealer and they reprogrammed the computer. No change. Car was taken in for each service and was told of the issue. On 2 occasions it was reported that the problem could not be duplicated. The transmission issue is erratic .
Shifting has stayed about the same over the past 8 weeks. After transmission service problem happened the day it was picked up. To me it shifts like it has no fluid in it.
Transmission service was done as prescribed at 30K. Last service was about 2 months ago at 47000 miles. I have had this issue listed every time I take it in for service.
There are times when the down shifting is rough causing passengers to lean forward when it does downshift. Does not happen every time it shifts . When it operates normally car drives great.
I started looking for others that have had this same problem and ran across the discussion on some site about it and someone mentioned a Tech Bulletin issued by MB about it telling what to do for it. I have since looked for the site to no avail.
I am concerned about the 50K as that's the limit of the warranty so I was wanting something done but nobody can find it. Now that the warranty is expired I have some difficulty getting them to repair the transmission for free . But since I had the issue reported at every service I do have some proof on my side to have it done sine it happened before the warranty expired.
I just need to find the bulletin or someone else who has had the same problem.
The bulletin mentioned the valve body being replaced and later on mentioned removing and in some instances replacing the transmission. I can understand MB ignoring this issue since the costs involved to repair the issue in all the cars is very high. But at least they have come to the table and admitted the repair is necessary.
So, I just want to get all the info I can about it before I contact MB about it and start the process to get it fixed.
If you can provide some insight I will certainly appreciate it.
Thanks
Earl Dagenhart

Be sure you're right then go ahead !
progolfer1 is offline  
post #5 of 9 (permalink) Old 03-17-2018, 03:35 PM
BenzWorld Elite
 
Date registered: Jul 2006
Vehicle: 1999 E55, 2001 E320, 1990 560 SEC, 2004 ML350, 2001 ML55, 1995 S500, 1998 SL500, 2010 E550 Sport zoo
Location: NW Arkansas, La Jolla CA, Hong Kong
Posts: 7,031
Mentioned: 6 Post(s)
Quoted: 157 Post(s)
If you have original MB new car warranty - your warranty ended when you passed 50K miles - that's why I asked.

At you last service - which was before you passed 50K miles - if this downshifting issue was listed on the Service Repair Order and was not resolved by the dealer - then with that Dealer Service Invoice In Hand - then call Mercedes Customer Care Mon-Fri during normal business hrs - Mon thru Fri (morning best) at (800) 367-6372 - reference that most recent service invoice 1st - give them the facts from that specific invoice - current miles time of service from that invoice - and that you have asked to have that issue resolved over the past
fabbrisd1 is offline  
post #6 of 9 (permalink) Old 04-08-2019, 10:00 AM
BenzWorld Newbie
 
Bmddlton's Avatar
 
Date registered: Apr 2019
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Did you ever get this sorted out? I have the exact same issue with my 2016 and several trips to the dealership have resulted in nothing.
Bmddlton is offline  
post #7 of 9 (permalink) Old 05-23-2019, 10:00 AM
BenzWorld Member
 
Date registered: May 2009
Vehicle: 1999 C280, 2015 C300
Location: Bay Area CA
Posts: 339
Mentioned: 2 Post(s)
Quoted: 31 Post(s)
I believe there was a recent recall on the transmission for software upgrade. I had taken my car to the dealer for a different issue under warranty and they performed a software upgrade on the transmission. I was not having any problem with my transmission. The recall number listed on the invoice is 2019030023. However, I did not get any recall notice. You may want to discuss this with the dealer.
Georj is offline  
post #8 of 9 (permalink) Old Yesterday, 02:37 PM
BenzWorld Junior Member
 
Date registered: May 2011
Vehicle: 2015 C300, 2016 C300
Location: NY, USA
Posts: 18
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
I have almost the same issue with my 2016 C-class. When come to full stop tranny Kicks really hard into first gear. Also when I put the brake in HOLD position it kicks down twice. I took it to the dealer a few times and the car was there for more than three months. They changed the valve body and they changed the first gear clutches, but the problem is still there. They had an engineer from Mercedes look at the problem and says its normal.
I'm not happy with what they say at all. But after not having my car for so long, I took it back and right now I'm trying to get used to live with this problem.
E350CLK550 is online now  
post #9 of 9 (permalink) Old Today, 02:34 PM
BenzWorld Member
 
Date registered: May 2009
Vehicle: 1999 C280, 2015 C300
Location: Bay Area CA
Posts: 339
Mentioned: 2 Post(s)
Quoted: 31 Post(s)
I don't seem to have any problem with my 2015 C300 but then I have only 14K miles on it. I would suggest you guys who are having this issue create a WhatsApp or Google group and write a joint letter to the MB USA Corporate. If you guys report this problem as a group I think MB would take notice. Again, I am not a lawyer, this is just a suggestion.
Georj is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W205 C-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome