2012 c63 keeps stalling - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 06-18-2019, 04:51 PM Thread Starter
BenzWorld Newbie
 
Date registered: Jun 2019
Vehicle: 2012 C63 AMG
Location: Virginia, United States
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
2012 c63 keeps stalling

I'm new here so hopefully I'm posting this in the correct section. I'm really at a loss for what to do so I'm hoping maybe someone has an idea beyond what I've already tried. This is long, so hold on.

So currently, my c63 cannot stay idling - it stalls almost immediately unless I press the gas pedal (while in park). As soon as I let off the gas, it stalls. It currently has no codes, and using an iCarsoft handheld didn't provide any useful information.

So the background:

Current modifications: flex fuel kit with larger fuel injectors, long tube headers, built transmission, custom exhaust (primary and secondary cat delete), ROW air boxes, 85mm throttle body, and Eurocharged V7 Tune.

At first, it would stall only while idling. I could turn it back on, and keep driving, so long as I didn't have to idle for very long, but this pretty quickly devolved into it having more and more difficulty staying on. Still no code though. So the first thing I tried was a new throttle body (upgraded to the 85mm) and new spark plugs. It sounded terrible turning in back on and then wouldn't even start. I bought the iCarsoft at this point, and it showed a bunch of issues related to the ECU...

So I had it towed to Mercedes (if anyone has a trustworthy Mercedes mechanic in the No. VA/DC area, let me know) - and they determined it needed a new fuel pump, new intake gaskets, and a new crank sensor. Had all of that done, still didn't fix the problem. So then they put in a new ECU, siphoned out the e85, put in premium gas, and it still wouldn't stay on. It would idle for a few seconds and stall. My hope was maybe it can't stay on because it has larger fuel injectors, and needed an updated tune. So I sent the stock file from the new ECU to Eurocharged, they send me the new V7 tune, I tune it, and it idles (never sounded right, like it was trying to even itself out but couldn't) then stalled after about 3 minutes. Now it won't even turn back on... One of my friends who works on AMGs suggested I might want to switch back to the stock fuel injectors and see if it'll run on those, but other than that, I'm at a complete loss for what to do. The Mercedes dealer doesn't know what else it could be, and it doesn't seem to be a problem with the tune from Eurocharged as I've flashed it to stock and back and it still won't start; it only stays on if I'm mid-throttle on the gas, then dies immediately when the gas pedal is released. And there are no codes. So what am I missing?

If you read all of that, thank you. TL;DR: Changed every part imaginable, car won't stay on, and refuses to throw a code.
Sammy0220 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 06-19-2019, 02:38 PM
Moderately subtle
 
edfreeman's Avatar
 
Date registered: Dec 2003
Vehicle: 94 E500, 97 500SL
Location: Soddy Daisy, TN
Posts: 11,881
Mentioned: 9 Post(s)
Quoted: 175 Post(s)
Lifetime Premium Member
Send a message via AIM to edfreeman
85 octane in that car?

Can't do that.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
edfreeman is offline  
post #3 of 4 (permalink) Old 06-19-2019, 04:11 PM Thread Starter
BenzWorld Newbie
 
Date registered: Jun 2019
Vehicle: 2012 C63 AMG
Location: Virginia, United States
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by edfreeman View Post
85 octane in that car?

Can't do that.

Oh no it's not on 85 octane gas, it has a flex fuel kit so it's running on E85 (85% ethanol), which is a higher octane than premium gas.
Sammy0220 is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 06-19-2019, 07:25 PM
Moderately subtle
 
edfreeman's Avatar
 
Date registered: Dec 2003
Vehicle: 94 E500, 97 500SL
Location: Soddy Daisy, TN
Posts: 11,881
Mentioned: 9 Post(s)
Quoted: 175 Post(s)
Lifetime Premium Member
Send a message via AIM to edfreeman
Ok, so, yeah, having never used the stuff, I made a bad assumption. Sorry about that.

Having now looked up the fuel and the mod that was required, I wouldn't have had the guts to do that. Was it an MB mod or aftermarket?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
edfreeman is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz AMG Forums > W204 C63 AMG

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome