Hesitation at about 40 mph - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 06-26-2019, 11:02 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Jun 2017
Vehicle: 2008 C300
Location: USA
Posts: 14
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
(Thread Starter)
Hesitation at about 40 mph

All, I have a 2008 C300 4matic Sport and I get a hesitation or sputtering at about 40 mph. Usually it happens going up a hill. If I give it more gas it smooths out. I'm not throwing any codes but it's annoying. Also, I should add that if I apply the gas from a stationary position it seems to be sluggish.

Any ideas what could cause this?

Thanks in advance for the help.

Sent from my SM-G975U using Tapatalk
netengineer1 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 06-26-2019, 11:33 AM
Outstanding Contributor
 
Date registered: Jul 2010
Vehicle: '85 300D Turbo, '91 420SEL, '92 190E 2.6, '09 C350, '12 E63 Wagon
Location: Arcadia, CA
Posts: 2,952
Mentioned: 10 Post(s)
Quoted: 589 Post(s)
Lifetime Premium Member
Mileage? Last service?
jzchen is online now  
post #3 of 5 (permalink) Old 06-26-2019, 12:16 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Jun 2017
Vehicle: 2008 C300
Location: USA
Posts: 14
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
(Thread Starter)
Quote:
Originally Posted by jzchen View Post
Mileage? Last service?
140,000 miles and I had it served at a couple months ago when I had the airbags replaced due to a recall. I'm up to date with all my services.

Sent from my SM-G975U using Tapatalk
netengineer1 is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 06-28-2019, 12:43 AM
BenzWorld Member
 
Vincent713's Avatar
 
Date registered: Dec 2016
Vehicle: 2014 C250 Sport Sedan
Location: USA
Posts: 54
Mentioned: 0 Post(s)
Quoted: 7 Post(s)
This usually happens when you're low on fuel, try filling it up with gas and see if it still stutter.
Vincent713 is online now  
post #5 of 5 (permalink) Old 07-08-2019, 10:08 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Jun 2017
Vehicle: 2008 C300
Location: USA
Posts: 14
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
(Thread Starter)
Quote:
Originally Posted by Vincent713 View Post
This usually happens when you're low on fuel, try filling it up with gas and see if it still stutter.
It does it no mater how much I have in the tank.

Sent from my SM-G975U using Tapatalk
netengineer1 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W204 C-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome