instrument cluster mileage and gasoline gauges not working - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 06-06-2019, 08:17 PM Thread Starter
BenzWorld Member
 
Date registered: Jul 2008
Vehicle: 87 300 D Turbo, 95 E 300 D, 96 E300 D, 98 E300TD, 00 C230 Compressor, 02 C 320 Wagon, 2010 C300
Location: Downey, CA
Posts: 126
Mentioned: 0 Post(s)
Quoted: 8 Post(s)
(Thread Starter)
instrument cluster mileage and gasoline gauges not working

Hello guys, does anybody knows if the instrument cluster needs programming when swapped with a different vehicle? mine is a 2009 C300, I replaced with a 2011 C300 cluster, everything works except mileage (It shows --------) and gasoline gauge doesn't work..
Any feedback will be appreciated.
mymini1 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W204 C-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome