2012 C250 no start no click - dealer needs more history to help diagnose - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 06-05-2019, 05:40 PM Thread Starter
BenzWorld Junior Member
 
ususu's Avatar
 
Date registered: Mar 2010
Vehicle: 2007 ML350, 2012 C250
Location: Washington DC, USA
Posts: 34
Mentioned: 0 Post(s)
Quoted: 8 Post(s)
(Thread Starter)
2012 C250 no start no click - dealer needs more history to help diagnose

The car has 110k miles and no issues except the coolant return line replaced as in my previous post. All maintenance are according to the manual. The fluids are regularly checked.

The other night I went to a store and parked the car for 20 minutes, when I returned the car failed to start. Only one click for like one second when I turned the key, no sound no turn over. Tried many times still the same - no sound. Instrument panel lit okay, lights work. Battery was 3 years old. Tried to jump start with another car, same. The fuses under the hood were all tested okay.

The next morning it got towed to dealer, the tow truck driver tried to start several times only one tiny click.

It has been at dealer for 3 days, no report yet and the service advisor asked for history but no diagnostic results.

What could be wrong? I suspect a failed starter but dealer would have got that by now if thatís the case.

Thanks
ususu is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 06-07-2019, 10:12 AM
BenzWorld Member
 
Vincent713's Avatar
 
Date registered: Dec 2016
Vehicle: 2014 C250 Sport Sedan
Location: USA
Posts: 54
Mentioned: 0 Post(s)
Quoted: 7 Post(s)
It might be the dreaded tiny motor that unlocks the steering column might be dead. These motors are known to fail at some point so be prepared to fork out over $1k to have this fix if it's the case. Keep us posted on what they find.
Vincent713 is offline  
post #3 of 7 (permalink) Old 06-16-2019, 11:27 PM
BenzWorld Veteran
 
Date registered: Sep 2005
Vehicle: 1999 C280, 2000 C280, 2000 C230K,2011 C300
Location: los angeles
Posts: 629
Mentioned: 0 Post(s)
Quoted: 29 Post(s)
If you are able to turn the key to start, i.e. the steering lock does make that retracting sound when you first insert your key, then steering lock is probably OK.

glenmore
1999, 2000 C280
2000 C230K
2011 C300
glenmore is offline  
Sponsored Links
Advertisement
 
post #4 of 7 (permalink) Old 06-17-2019, 01:42 AM Thread Starter
BenzWorld Junior Member
 
ususu's Avatar
 
Date registered: Mar 2010
Vehicle: 2007 ML350, 2012 C250
Location: Washington DC, USA
Posts: 34
Mentioned: 0 Post(s)
Quoted: 8 Post(s)
(Thread Starter)
It turned out to be the starter - the technician found some oil leaking and wanted to know more about the history. They got very busy so I got one full week loaner, a CLA250 which is far less smooth than my C250.
ususu is offline  
post #5 of 7 (permalink) Old 06-17-2019, 05:53 PM
BenzWorld Member
 
Vincent713's Avatar
 
Date registered: Dec 2016
Vehicle: 2014 C250 Sport Sedan
Location: USA
Posts: 54
Mentioned: 0 Post(s)
Quoted: 7 Post(s)
Glad they found the culprit, just curious what a repair cost for a starter cost at the dealer? CLA are front wheel drive and they suck! I test drove one before I bought my C250 and didn't like it. Felt very cramped inside the cabin and the ride didn't felt as good as the C class.
Vincent713 is offline  
post #6 of 7 (permalink) Old 06-17-2019, 06:18 PM Thread Starter
BenzWorld Junior Member
 
ususu's Avatar
 
Date registered: Mar 2010
Vehicle: 2007 ML350, 2012 C250
Location: Washington DC, USA
Posts: 34
Mentioned: 0 Post(s)
Quoted: 8 Post(s)
(Thread Starter)
Quote:
Originally Posted by Vincent713 View Post
Glad they found the culprit, just curious what a repair cost for a starter cost at the dealer? CLA are front wheel drive and they suck! I test drove one before I bought my C250 and didn't like it. Felt very cramped inside the cabin and the ride didn't felt as good as the C class.


Total was $1100 including a $50 recycle fee.
ususu is offline  
post #7 of 7 (permalink) Old 06-17-2019, 06:26 PM
BenzWorld Member
 
Vincent713's Avatar
 
Date registered: Dec 2016
Vehicle: 2014 C250 Sport Sedan
Location: USA
Posts: 54
Mentioned: 0 Post(s)
Quoted: 7 Post(s)
Quote:
Originally Posted by ususu View Post
Total was $1100 including a $50 recycle fee.
I think this is a job I can tackle and repair on my own if my starter fails. At least I know what the symptom is, thanks for sharing and again glad you're up and running.
Vincent713 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W204 C-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome