W204 DIY Videos for those willing to have a go. - Page 10 - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #91 of 92 (permalink) Old 02-06-2019, 08:37 PM Thread Starter
Outstanding Contributor
 
Scott52's Avatar
 
Date registered: Oct 2012
Vehicle: W204 C320CDI 2009 and W639 Vito 115CDI 2006
Location: Perth, Western Australia
Posts: 891
Mentioned: 4 Post(s)
Quoted: 89 Post(s)
(Thread Starter)
Quote:
Originally Posted by casey124 View Post
Hi Scott, This is Casey from Sydney. Tried to send you a message, but your inbox looks full. Could you please clear your message box so that I could ask you some questions? Thanks a lot.
Inbox cleared.

I'm riding for you #52, my dear son Cameron 1985-2009

2009 W204 C320CDI C Class sedan with Quaife LSD
2006 W639 115CDI Vito LWB Van for hauling motorcycles
2008 W164 ML320CDI Edition 10 (daughter's but I look after it)
2018 Hyundai Kona Elite AWD 1.6 turbo 7 speed DSG
2008 Honda CBR600RR race/track motorcycle
2010 Suzuki GSXR750 race/track motorcycle
2011 KTM 530 EXC Enduro motorcycle
Scott52 is offline  
Sponsored Links
Advertisement
 
post #92 of 92 (permalink) Old 05-09-2019, 01:11 AM
BenzWorld Newbie
 
Date registered: May 2019
Vehicle: C280 2008
Location: Mozambique
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
C280 ecu issue

Hi everybody,
I'm new here and dont really know where to start...I have a C280 2008 model that doesnt want to start.
The battery died,Its been replaced but ever since then Im having problems. I did a diagnostic check with Launch software, seems like there is no current going to ecm,tcm and fuel pump module. Ive cleaned front SAM and now when i switch on the ignition the engine fan starts to run. But still when I diagnose it those three systems still dont function.
Any ideas or advice would be greatly appreciated.

Regards,
Niassa is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W204 C-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome