Codes from 2004 C55..... Need Advise - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 04-13-2019, 02:39 AM Thread Starter
eso
BenzWorld Newbie
 
Date registered: Jan 2019
Vehicle: 2004 W203 C55
Location: Hong Kong
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Codes from 2004 C55..... Need Advise

Dear All,

I have just went through a replacement of the following items:
  1. Replaced MAF
  2. Replace Exhaust Gas Recirculation Pump Unit

After driving the car for 30 mins, the engine light came back ON and I had it checked by the OBD scanner and the following codes come up. Can anyone suggest what might be wrong still?

Thanks
Eric
Attached Thumbnails
Click image for larger version

Name:	C55 - Code 2019-04-13_001.png
Views:	2
Size:	87.7 KB
ID:	2504152   Click image for larger version

Name:	C55 - Code 2019-04-13_002.png
Views:	2
Size:	85.1 KB
ID:	2504154   Click image for larger version

Name:	C55 - Code 2019-04-13_003.png
Views:	2
Size:	102.8 KB
ID:	2504156  
eso is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 04-13-2019, 03:15 AM Thread Starter
eso
BenzWorld Newbie
 
Date registered: Jan 2019
Vehicle: 2004 W203 C55
Location: Hong Kong
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
The results also stated :

1. Y58/1 (Purge Control Valve) : Open circuit / switchover valve permanently closed (P0444)
2. Malfunction of exhaust gas re-circulation (functional chain)(P0400)
3. Fault in CAN Comminuication with control unit N73(EIS (EZS) Control unit.
eso is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz AMG Forums > W203 C32 AMG, C55 AMG

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
2004 S500 A/C not working but no codes oliverp W220 S-Class 8 05-25-2018 05:47 PM
W203 - 2004 C320 4matic, Various Codes, please help. zisisme W203 C-Class 1 05-12-2017 07:06 PM
Fan keeps running bossjj98 W163 M-Class 311 08-14-2014 05:42 PM
7000 / 6600 Gs SOLD IN 2003/.2004 , Why close the line? Zé Bocaina G-Class 3 06-17-2005 08:40 PM
KVinning stands ..............alone Cap n Carageous Off-Topic 91 11-11-2004 07:38 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome