Mercedes-Benz Forum

Mercedes-Benz Forum (https://www.benzworld.org/forums/)
-   W203 C32 AMG, C55 AMG (https://www.benzworld.org/forums/w203-c32-amg-c55-amg/)
-   -   2002 C320 battery dead every morning (https://www.benzworld.org/forums/w203-c32-amg-c55-amg/2918745-2002-c320-battery-dead-every-morning.html)

Efrain.Gar 12-02-2017 01:11 PM

2002 C320 battery dead every morning
 
Have been having this issue for a while now where I have to jump start the car every morning, and when I turn the heat on or A/C, my dash starts blinking with the “Battery/Alternator visit workshop” messsage and everything else in my car pretty much starts to blink as well... I’m not able to drive the car at night because when i turn the heat on it shuts off my headlights and the low beams start to blink. Took the car to Mercedes Benz dealership and they told me to replace the alternator, I had it replaced and still nothing. Took it back and they tell me to replace the SAM -_- Does anyone have a clue of what might be causing this problem?

insame1 12-04-2017 08:10 AM

I would start with a new battery

MandMB781 12-04-2017 08:30 AM

Does it happen with or without A/C operation?


All times are GMT -7. The time now is 04:27 AM.

Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.