2005 CLK 550 charging issues - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 06-12-2017, 09:25 AM Thread Starter
BenzWorld Member
 
Date registered: Mar 2010
Vehicle: 1997 C230 184K
Location: Berkshire County Massachusetts
Posts: 136
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
(Thread Starter)
2005 CLK 550 charging issues

This is for a less tech savvy friend who has a 2005 CLK 70k miles. He has garaged it over the New England winters but never put a trickle charger on it, last year it began to not start he put a new battery in it and put it away for the winter. I looked at it yesterday it had no CEL codes but my meter isnt for newer cars. It will not start with a jump until the battery has charged enough to run it but i didnt start yesterday and only runs for a little while. Sounds to me like the alternator and charging circuit I looked at fuses and smelled relays but the alt is buried in the engine. The nearest MB Stealer is 45 minutes by flatbed but I am going to suggest he have theone guy that will work on it put it up on the lift and put in an alt and check the wiring ect I cant do it in my driveway like my 97. Ant thoughts as to where I could look without lifting it? Ty
MartySzy1 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 08-11-2017, 10:09 PM
BenzWorld Newbie
 
Date registered: Aug 2015
Vehicle: 2006 C55 AMG
Location: new zealand
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
volt test

Quote:
Originally Posted by MartySzy1 View Post
This is for a less tech savvy friend who has a 2005 CLK 70k miles. He has garaged it over the New England winters but never put a trickle charger on it, last year it began to not start he put a new battery in it and put it away for the winter. I looked at it yesterday it had no CEL codes but my meter isnt for newer cars. It will not start with a jump until the battery has charged enough to run it but i didnt start yesterday and only runs for a little while. Sounds to me like the alternator and charging circuit I looked at fuses and smelled relays but the alt is buried in the engine. The nearest MB Stealer is 45 minutes by flatbed but I am going to suggest he have theone guy that will work on it put it up on the lift and put in an alt and check the wiring ect I cant do it in my driveway like my 97. Ant thoughts as to where I could look without lifting it? Ty

test your battery voltage a good battery is 12.7 volts or higher when new and with the car off
test battery volt when engine running it should be 14.2 or higher 14.4 V
then test with all electrical parts on like head lights and fan this will load test alternator should hold 14.2 volts
duke749 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz AMG Forums > W203 C32 AMG, C55 AMG

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome