DIY - Intercooler Pump Replacement - Page 2 - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #11 of 22 (permalink) Old 08-22-2009, 10:03 AM
BenzWorld Newbie
 
Date registered: Aug 2009
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by 2002c230 View Post
The supercharger is bypassed while in neutral or park. The electromagnetic clutch never engages. I would assume the pump receives power anytime the supercharger is engaged. Why are you trying to test the pump if you haven't had any problems with it?

Hi, thanks for your reply. It makes sense and I hope thats the case. I tested the pump cause I had to retape that part of harness.
Giorgiojustini is offline  
Sponsored Links
Advertisement
 
post #12 of 22 (permalink) Old 08-23-2009, 01:52 PM
BenzWorld Elite
 
32krazy!'s Avatar
 
Date registered: Oct 2008
Vehicle: PROUD OWNER! 2002 slk32 AMG
Location: murfreesboro tn
Posts: 1,505
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
if you rev the engine to 2000 rpm the pump engages and stays engaged until the engine is shut off once engaged the pump runs even at idle
32krazy! is offline  
post #13 of 22 (permalink) Old 08-29-2009, 07:28 PM
BenzWorld Junior Member
 
Date registered: Dec 2006
Vehicle: c32 amg
Location: ohio
Posts: 18
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Nice work. I hope that wont happen to me...
bokeo_2005 is offline  
Sponsored Links
Advertisement
 
post #14 of 22 (permalink) Old 08-29-2009, 07:30 PM
BenzWorld Elite
 
32krazy!'s Avatar
 
Date registered: Oct 2008
Vehicle: PROUD OWNER! 2002 slk32 AMG
Location: murfreesboro tn
Posts: 1,505
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by bokeo_2005 View Post
Nice work. I hope that wont happen to me...
if you have a bosch pump you will have a failure. its simply a matter of time
32krazy! is offline  
post #15 of 22 (permalink) Old 09-12-2009, 03:35 AM Thread Starter
BenzWorld Elite
 
2002c230's Avatar
 
Date registered: Jun 2007
Vehicle: 2002 C32 AMG
Location: New Mexico, USA
Posts: 1,771
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
(Thread Starter)
I'm sure the johnson pump has electrical brushes also, and eventually fails over time. Guessing it's a more reliable build though, and doesn't have nearly as high early failure rate. Not to mention it flows slightly more fluid with the cm30... There are some differences between the lightning pump, and OE c32 pump too, so the lightning might not be defective as often as the OE c32 is. By the way, after fixing the wiring harness I have not had any problems with the pump. Everything is running good!


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2002 C32 AMG Sedan [111,000 Miles]
Clear Side Markers | CL Style Grille | Flat Emblem | CF Front Lip Spoiler | CF Rear Diffuser | CF Trunk Spoiler
K&N Air Filters | NGK IX (2 Step) | KV-85 | LET 185MM & ECU | TVT Thermostat | PSK Belt Wrap | CM30
DIY Intercooler Isolation | 26x7x2 FB H/E | Intercooler Reservoir | Battery Relocation | Lorinser Sides

Last edited by 2002c230; 01-27-2010 at 11:11 AM.
2002c230 is offline  
post #16 of 22 (permalink) Old 08-16-2010, 12:00 PM
BenzWorld Junior Member
 
Date registered: Jul 2010
Vehicle: 2002 SLK32 AMG
Location: Daytona Beach, FL
Posts: 25
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Very nice write up. This helps me out greatly, even though it is almost a year old!
I plan on replacing my defective BOSCH OE unit with a Johnson CM30. I'm sure it won't be as easy as your procedure due to the physical size difference between the Johnson and the OE pumps, but I'm sure it won't be too difficult to secure it to the OE clamp. Thanks for the info and the pics of your procedure.
DaytonaJae is offline  
post #17 of 22 (permalink) Old 08-31-2010, 01:46 PM
BenzWorld Member
 
Date registered: Oct 2009
Vehicle: 2004 ML500, 2002 SLK32 AMG
Location: Jhb, South Africa
Posts: 70
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Ah, good write up. I see I'll be doing this on my SLK in the near future. Had full power loss on Saturday with the car, so I'm guessing this is the issue. Also had a fairly dismal dyno test, running around 100hp short. Only 223whp. Possibly something else, or is the pump the issue here too?

'04 ML500 - Work Horse
'02 SLK32 AMG - Weekend Toy
'74 W114 280 - Project Car
Kibim is offline  
post #18 of 22 (permalink) Old 09-14-2010, 10:39 PM Thread Starter
BenzWorld Elite
 
2002c230's Avatar
 
Date registered: Jun 2007
Vehicle: 2002 C32 AMG
Location: New Mexico, USA
Posts: 1,771
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
(Thread Starter)
Your power loss is likely due to a bad charge air pump as you suspect.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2002 C32 AMG Sedan [111,000 Miles]
Clear Side Markers | CL Style Grille | Flat Emblem | CF Front Lip Spoiler | CF Rear Diffuser | CF Trunk Spoiler
K&N Air Filters | NGK IX (2 Step) | KV-85 | LET 185MM & ECU | TVT Thermostat | PSK Belt Wrap | CM30
DIY Intercooler Isolation | 26x7x2 FB H/E | Intercooler Reservoir | Battery Relocation | Lorinser Sides
2002c230 is offline  
post #19 of 22 (permalink) Old 10-11-2010, 07:34 PM Thread Starter
BenzWorld Elite
 
2002c230's Avatar
 
Date registered: Jun 2007
Vehicle: 2002 C32 AMG
Location: New Mexico, USA
Posts: 1,771
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
(Thread Starter)
Going on 106k without pump failure. Would rather have a pump failure than my radiator failure though. My Valeo gave out and coolant started to mix with transmission. Around $600 dollars later, and a week or so of DIY work it should be good as new with a BEHR radiator installed. Full coolant, and transmission flush... Thinking about finally upgrading my heat exchanger at the same time. Along with replacement of water pump. Do both of those I'm looking around $1000 spent on the C32 in the span of several days... Not to mention around 15 hours of work.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2002 C32 AMG Sedan [111,000 Miles]
Clear Side Markers | CL Style Grille | Flat Emblem | CF Front Lip Spoiler | CF Rear Diffuser | CF Trunk Spoiler
K&N Air Filters | NGK IX (2 Step) | KV-85 | LET 185MM & ECU | TVT Thermostat | PSK Belt Wrap | CM30
DIY Intercooler Isolation | 26x7x2 FB H/E | Intercooler Reservoir | Battery Relocation | Lorinser Sides
2002c230 is offline  
post #20 of 22 (permalink) Old 05-10-2011, 07:00 AM
BenzWorld Junior Member
 
Date registered: May 2011
Vehicle: C32 AMG 2002 Model
Location: South Africa - Gauteng province
Posts: 28
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
No problems

Thank you for all the valuable information. My car has done 63457km and there is absolutely no problems at all. This car goes like a dream and the consumption just gets better in time.
Stoffie is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz AMG Forums > W203 C32 AMG, C55 AMG

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
SLK32 Intercooler Pump Replacement 430 R170 SLK-Class 73 07-07-2014 12:33 PM
SLK230 Intercooler Mod (DIY): Do You Want One? manicdemise General Mercedes-Benz 3 08-31-2009 09:04 AM
Intercooler pump out again? themachinist R170 SLK-Class 3 12-11-2008 06:20 PM
Fuel Pump replacement DIY thread/link? philthompson W126 S,SE,SEC,SEL,SD,SDL Class 11 01-31-2007 08:28 AM
This Evenings Intercooler Pump Replacement Pics CCORLEY W203 C32 AMG, C55 AMG 3 10-02-2006 03:53 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome