06 C280 P0016 P0017 - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 15 (permalink) Old 06-13-2019, 07:31 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Jun 2019
Posts: 8
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
(Thread Starter)
06 C280 P0016 P0017

Hi all, new here and just purchased my first Mercedes. I bought it from a dealership and the sales person ensured me the CEL was nothing to be concerned about but was unable to provide a DTC printout due to them not doing an "official" inspection on it. The codes thrown are P0016 and P0017, crank/cam correlation bank 1 sensors A & B. As someone who was once a mechanic, this sounds like a cam gear/balancer issue to me. Any known problems I should look for first, and any tricks for diagnosing these?

Thanks!
Jubbsta is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 06-13-2019, 07:40 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Jun 2019
Posts: 8
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
(Thread Starter)
Edit: after doing some searching it would seem a faulty balancer shaft is common on these motors. I figure it's better to replace it before I skip a tooth. Does anybody have access to the repair procedures?
Jubbsta is offline  
post #3 of 15 (permalink) Old 06-13-2019, 08:47 PM
Moderator
 
rudeney's Avatar
 
Date registered: Dec 2004
Vehicle: CURRENT: 2011 SL550, 2010 ML350 FORMER: 2007 CLK550 Cabriolet, 2002 C240, 2001 ML320, 1984 300TD
Location: Birmingham, AL
Posts: 18,472
Mentioned: 37 Post(s)
Quoted: 1692 Post(s)
Lifetime Premium Member
Garage
Actually, it won't skip a tooth, but it could eventually damage the timing chain. This is an engine-out job. I think I have all the WIS docs here:

http://benzbits.com/M272/ReplaceBalanceShaft.zip

--

- RODNEY


So you want to send me a private message? Please read this first:


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My Stable:


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
rudeney is offline  
Sponsored Links
Advertisement
 
post #4 of 15 (permalink) Old 06-13-2019, 08:52 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Jun 2019
Posts: 8
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
(Thread Starter)
Quote:
Originally Posted by rudeney View Post
Actually, it won't skip a tooth, but it could eventually damage the timing chain. This is an engine-out job. I think I have all the WIS docs here:

http://benzbits.com/M272/ReplaceBalanceShaft.zip
Thank you very much! Ill post updates as they come along
Jubbsta is offline  
post #5 of 15 (permalink) Old 06-13-2019, 10:59 PM
BenzWorld Elite
 
tjts1's Avatar
 
Date registered: Apr 2009
Vehicle: 87 300D 5 speed
Location: The slums of Beverly Hills
Posts: 5,159
Mentioned: 5 Post(s)
Quoted: 691 Post(s)
Quote:
Originally Posted by Jubbsta View Post
Hi all, new here and just purchased my first Mercedes. I bought it from a dealership and the sales person ensured me the CEL was nothing to be concerned about but was unable to provide a DTC printout due to them not doing an "official" inspection on it. The codes thrown are P0016 and P0017, crank/cam correlation bank 1 sensors A & B. As someone who was once a mechanic, this sounds like a cam gear/balancer issue to me. Any known problems I should look for first, and any tricks for diagnosing these?

Thanks!

What state are you in? Most states have a grace period where you can return a used car to a dealer for a full refund.

Triggering religious fanatics since 1969

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by tjts1; 06-13-2019 at 11:01 PM.
tjts1 is offline  
post #6 of 15 (permalink) Old 06-13-2019, 11:41 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Jun 2019
Posts: 8
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
(Thread Starter)
Tjts1, I'm located in Michigan, I'm unable to return the vehicle due to it being sold "as is".. my salesperson told me there is nothing he can do. I've owned it for only 2 days now.
Jubbsta is offline  
post #7 of 15 (permalink) Old 06-14-2019, 03:32 AM
BenzWorld Junior Member
 
Date registered: Jan 2019
Posts: 10
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Quote:
Originally Posted by Jubbsta View Post
Hi all, new here and just purchased my first Mercedes. I bought it from a dealership and the sales person ensured me the CEL was nothing to be concerned about but was unable to provide a DTC printout due to them not doing an "official" inspection on it. The codes thrown are P0016 and P0017, crank/cam correlation bank 1 sensors A & B. As someone who was once a mechanic, this sounds like a cam gear/balancer issue to me. Any known problems I should look for first, and any tricks for diagnosing these?
https://www.autoguysland.com/best-car-diagnostic-tool/
Thanks!
Hi.

Do you have any engine running issues?
Have you tried deleting the codes to see how long it will take for them to come back?

In addition to balancer, there are few other possibilities:
- stretched chain
- weak tensioner
- failing craknshaft sensor.

Hope that helps.
harveyspecter1209 is offline  
post #8 of 15 (permalink) Old 06-14-2019, 07:09 AM
BenzWorld Elite
 
tjts1's Avatar
 
Date registered: Apr 2009
Vehicle: 87 300D 5 speed
Location: The slums of Beverly Hills
Posts: 5,159
Mentioned: 5 Post(s)
Quoted: 691 Post(s)
Quote:
Originally Posted by Jubbsta View Post
Tjts1, I'm located in Michigan, I'm unable to return the vehicle due to it being sold "as is".. my salesperson told me there is nothing he can do. I've owned it for only 2 days now.
Unfortunately situations like yours pop up on this forum regularly, usually with 06 and early 07 cars. As previously mentioned it's an engine out repair that will likely cost as much as the car is worth. NEVER buy a car with a check engine light, always do your homework before buying and get a PPI.

Triggering religious fanatics since 1969

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
tjts1 is offline  
post #9 of 15 (permalink) Old 06-14-2019, 10:24 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Jun 2019
Posts: 8
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
(Thread Starter)
Quote:
Originally Posted by harveyspecter1209 View Post
Quote:
Originally Posted by Jubbsta View Post
Hi all, new here and just purchased my first Mercedes. I bought it from a dealership and the sales person ensured me the CEL was nothing to be concerned about but was unable to provide a DTC printout due to them not doing an "official" inspection on it. The codes thrown are P0016 and P0017, crank/cam correlation bank 1 sensors A & B. As someone who was once a mechanic, this sounds like a cam gear/balancer issue to me. Any known problems I should look for first, and any tricks for diagnosing these?
https://www.autoguysland.com/best-car-diagnostic-tool/
Thanks!
Hi.

Do you have any engine running issues?
Have you tried deleting the codes to see how long it will take for them to come back?

In addition to balancer, there are few other possibilities:
- stretched chain
- weak tensioner
- failing craknshaft sensor.

Hope that helps.
Yesterday I cleared the codes and changed the oil, after the oil change i lrt it idle for 5-10 minutes, no CEL, then as soon ss i cranked it the next time CEL came on.. Very very lightly rough idle SOMETIMES, I found the inlet for the air pump was disconnected, after reconnecting it, seems to rub fine..
Jubbsta is offline  
post #10 of 15 (permalink) Old 06-14-2019, 10:27 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Jun 2019
Posts: 8
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
(Thread Starter)
Quote:
Originally Posted by tjts1 View Post
Quote:
Originally Posted by Jubbsta View Post
Tjts1, I'm located in Michigan, I'm unable to return the vehicle due to it being sold "as is".. my salesperson told me there is nothing he can do. I've owned it for only 2 days now.
Unfortunately situations like yours pop up on this forum regularly, usually with 06 and early 07 cars. As previously mentioned it's an engine out repair that will likely cost as much as the car is worth. NEVER buy a car with a check engine light, always do your homework before buying and get a PPI.
General ball park for the price of parts if i do it the proper way? I.E oil pump, chain n guides, the whole works..? Im going to pull the 4 pulse magnets and check the stampings on the cam gears, and maybe put a boroscope down to see if there's any damage to the walls from metal shavings..
Jubbsta is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W203 C-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome