Matching Power Steering Pumps? - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 06-08-2019, 05:05 PM Thread Starter
BenzWorld Member
 
Date registered: Dec 2017
Vehicle: 2003 C240 87k // 2002 C240 77k Miles
Location: Dallas TX
Posts: 148
Mentioned: 0 Post(s)
Quoted: 23 Post(s)
(Thread Starter)
Matching Power Steering Pumps?

2003 C240 89k miles

I need to replace my noisy/whirring PSP. Before heading to a parts re-sale store what other models would have a similar PSP, just in case the guys can't trace specifically a C240 unit?
Jay11 is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 06-08-2019, 05:16 PM
BenzWorld Elite
 
260e crusier's Avatar
 
Date registered: Nov 2010
Vehicle: 1999 E320, 2003 E320 Wagon, 2005 C230K SS, 2010 Accord LX w Eibach & Koni FSD's
Location: Fremont, California
Posts: 2,208
Mentioned: 4 Post(s)
Quoted: 494 Post(s)
Quote:
Originally Posted by Jay11 View Post
2003 C240 89k miles

I need to replace my noisy/whirring PSP. Before heading to a parts re-sale store what other models would have a similar PSP, just in case the guys can't trace specifically a C240 unit?
Most people purchase by part number so there isn't any problem with fitment.

ECS Tuning is one of the few places that provide a fitment list

https://www.ecstuning.com/b-luk-part...024669801~luk/
260e crusier is offline  
post #3 of 11 (permalink) Old 06-08-2019, 05:21 PM
BenzWorld Elite
 
260e crusier's Avatar
 
Date registered: Nov 2010
Vehicle: 1999 E320, 2003 E320 Wagon, 2005 C230K SS, 2010 Accord LX w Eibach & Koni FSD's
Location: Fremont, California
Posts: 2,208
Mentioned: 4 Post(s)
Quoted: 494 Post(s)
My Pick and Pull only charge $32.99 for a power steering pump. I see a lot of W203s and W209s there.

Have you check your fluid level and bearing/pulley with serpentine belt off?

Last edited by 260e crusier; 06-08-2019 at 05:23 PM.
260e crusier is offline  
Sponsored Links
Advertisement
 
post #4 of 11 (permalink) Old 06-08-2019, 10:36 PM Thread Starter
BenzWorld Member
 
Date registered: Dec 2017
Vehicle: 2003 C240 87k // 2002 C240 77k Miles
Location: Dallas TX
Posts: 148
Mentioned: 0 Post(s)
Quoted: 23 Post(s)
(Thread Starter)
Quote:
Originally Posted by 260e crusier View Post
My Pick and Pull only charge $32.99 for a power steering pump. I see a lot of W203s and W209s there.

Have you check your fluid level and bearing/pulley with serpentine belt off?
It's those prices that attracted me there.

Fluid level is normal.
How do you do that check?
Jay11 is offline  
post #5 of 11 (permalink) Old 06-09-2019, 06:16 AM
BenzWorld Elite
 
260e crusier's Avatar
 
Date registered: Nov 2010
Vehicle: 1999 E320, 2003 E320 Wagon, 2005 C230K SS, 2010 Accord LX w Eibach & Koni FSD's
Location: Fremont, California
Posts: 2,208
Mentioned: 4 Post(s)
Quoted: 494 Post(s)
Quote:
Originally Posted by Jay11 View Post
It's those prices that attracted me there.

Fluid level is normal.
How do you do that check?
Just grab the pulley in your hand and turn it. It should turn smoothly without any unusual noise or play/wobble.
260e crusier is offline  
post #6 of 11 (permalink) Old 07-18-2019, 10:50 AM Thread Starter
BenzWorld Member
 
Date registered: Dec 2017
Vehicle: 2003 C240 87k // 2002 C240 77k Miles
Location: Dallas TX
Posts: 148
Mentioned: 0 Post(s)
Quoted: 23 Post(s)
(Thread Starter)
Quote:
Originally Posted by 260e crusier View Post
Quote:
Originally Posted by Jay11 View Post
It's those prices that attracted me there.

Fluid level is normal.
How do you do that check?
Just grab the pulley in your hand and turn it. It should turn smoothly without any unusual noise or play/wobble.
Found a C 320 but the bolt at the back on left is next to AC pipes. There is no room for the bolt to come out. This is very different from the c240 which has more room to get that bolt out. On the c320 just how do I remove this bolt?
Jay11 is offline  
post #7 of 11 (permalink) Old 07-18-2019, 01:05 PM
BenzWorld Elite
 
260e crusier's Avatar
 
Date registered: Nov 2010
Vehicle: 1999 E320, 2003 E320 Wagon, 2005 C230K SS, 2010 Accord LX w Eibach & Koni FSD's
Location: Fremont, California
Posts: 2,208
Mentioned: 4 Post(s)
Quoted: 494 Post(s)
Quote:
Originally Posted by Jay11 View Post
Found a C 320 but the bolt at the back on left is next to AC pipes. There is no room for the bolt to come out. This is very different from the c240 which has more room to get that bolt out. On the c320 just how do I remove this bolt?
If you're at a Pick and Pull.........you take it out any way you can. Well.....short of dynamite
260e crusier is offline  
post #8 of 11 (permalink) Old 07-18-2019, 01:32 PM Thread Starter
BenzWorld Member
 
Date registered: Dec 2017
Vehicle: 2003 C240 87k // 2002 C240 77k Miles
Location: Dallas TX
Posts: 148
Mentioned: 0 Post(s)
Quoted: 23 Post(s)
(Thread Starter)
Quote:
Originally Posted by 260e crusier View Post
If you're at a Pick and Pull.........you take it out any way you can. Well.....short of dynamite
Yes I am at a junky. What a PITA! I am taking this to the next level - a crow bar, and anything else I can throw at it.

Apparently 2004-2006 Chrysler Crossfires have the same Power Steering Pump, per MercedesMedic?
Jay11 is offline  
post #9 of 11 (permalink) Old 07-18-2019, 08:56 PM Thread Starter
BenzWorld Member
 
Date registered: Dec 2017
Vehicle: 2003 C240 87k // 2002 C240 77k Miles
Location: Dallas TX
Posts: 148
Mentioned: 0 Post(s)
Quoted: 23 Post(s)
(Thread Starter)
Hey is there supposed to be a seal here - circled red below? Is that what Merc.Medic is saying in photo 2? Because I didn't see any when I carefully and slowly pulled out both my car's and the unit at the junk yard. Neither of the cars had any o-ring seal there. If there's supposed to be one there do I just slide one over there from my o-rings kit and push in the reservoir tank? Help ...confused.



From Merc.Medic here

Jay11 is offline  
post #10 of 11 (permalink) Old 07-19-2019, 02:51 AM
BenzWorld Elite
 
Benzyle's Avatar
 
Date registered: Nov 2013
Vehicle: MY05 CLK55 AMG , MY05 CLK320,Former,C180 Kompressor,Jensen Healey,Ford Capri V6,Alfa GTV.
Location: Australia's East Coast
Posts: 1,440
Mentioned: 3 Post(s)
Quoted: 306 Post(s)
There is a reservoir seal , it is not an o ring , it has a flat inner surface and bevelled outer surface.
Maybe yours stuck in the reservoir ?

Search any MB parts place will list them.
Benzyle is online now  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W203 C-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome