2005 C240 Armrest Lid Replacement - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 10-14-2016, 03:22 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Aug 2016
Vehicle: 2005 W203 C240 4MATIC Wagon
Location: USA
Posts: 18
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
(Thread Starter)
2005 C240 Armrest Lid Replacement

So the armrest lid on my C240 wagon is broken (it was like that since the day I bought it a month or so ago), and I'm thinking I want to replace it. However, the only part I can find on ebay seems to have a different button layout - the one I have has the front button and 2 side buttons, and the one on ebay has a split front button and no side buttons (see attached picture). Can I use that armrest on my car? Or do I have to wait for one just like mine to become available? I'd rather not pay for a brand-new one at the stealership, if possible.
Attached Thumbnails
Click image for larger version

Name:	s-l1600.jpg
Views:	147
Size:	64.4 KB
ID:	1996569  
BenzWagen is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 10-14-2016, 06:46 PM
Moderator
 
rudeney's Avatar
 
Date registered: Dec 2004
Vehicle: CURRENT: 2011 SL550, 2010 ML350 FORMER: 2007 CLK550 Cabriolet, 2002 C240, 2001 ML320, 1984 300TD
Location: Birmingham, AL
Posts: 18,589
Mentioned: 38 Post(s)
Quoted: 1718 Post(s)
Lifetime Premium Member
Garage
You must have the proper part with the buttons on the side. BTW, what's broken? Did the armrest just come off? There is a fix for that:

http://benzbits.com/w203/ConsoleLid.wmv

--

- RODNEY


So you want to send me a private message? Please read this first:


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My Stable:


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
rudeney is offline  
post #3 of 3 (permalink) Old 10-14-2016, 07:18 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Aug 2016
Vehicle: 2005 W203 C240 4MATIC Wagon
Location: USA
Posts: 18
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
(Thread Starter)
I don't have access to my car right now to take a picture, but the side buttons are broken off and (I'm not sure if I'm remembering it right) I think the retaining bits on the lid that go into the actual armrest may have broken off as well. Best guess is that the previous owner's kids played rough with the lid and broke it off. I might be able to reach inside the lid and activate what the button would normally actuate myself, assuming the retaining bits haven't actually broken off.
BenzWagen is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W203 C-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome