the engine fan is on all the time?? - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 39 (permalink) Old 04-19-2010, 02:43 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Apr 2010
Vehicle: MB C180 W203 2001
Posts: 17
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Question the engine fan is on all the time??

hello evry one,
i have thes problem for abut tow weaks ago that the engine fan is on wean ever the engine is on even if its in the morning and no nedded for the fan???!!! i have see the relay (7 or P) in the engine fuse box but its loock OK, the fan is working in a sevral speed samtime its lo and on the other is vary fast, in the vary bigining of this problem the fan was working for a few minets and thean its off.
haltamim is offline  
Sponsored Links
Advertisement
 
post #2 of 39 (permalink) Old 04-20-2010, 10:39 AM
BenzWorld Junior Member
 
Date registered: Feb 2009
Vehicle: mercedes A180 Auto diesel 2010
Location: telford uk
Posts: 29
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Engine fan on all the time

Hi Haltamin,
Not quite sure but it would help if you use the steering wheel menu to look at the temperature.

If the temperature of your engine is cold (or at outside temperature if you are in a hot country) but the display shows much higher suspect a sensor telling the computer that the engine is hot so the fan needs to run.

If the temperature of the inside and engine are similar suspect a thermal switch in the fan circuit.

I am really not sure if MB use a thermal switch to control the fan directly or a temperature sensor that tells the computer to run the fan.

Either way a look at the menu display will help forum members, best check it when cold and just starting out.

Good Luck
Timbosss
timbosss is offline  
post #3 of 39 (permalink) Old 04-21-2010, 12:49 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Apr 2010
Vehicle: MB C180 W203 2001
Posts: 17
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Engine fan on all the time

thanx for answering!
will i am living in sweden and the tempretur is abut +5 or less and the dash is not telling me any think that i can say its the problem, the tempretur is loking ok and its raising normaly untel the 80 C but its teack more time becaus of the fan working all the time. i think if the tempratue sanser is not working will it shuld show sam thing on the dash, right??!
haltamim is offline  
Sponsored Links
Advertisement
 
post #4 of 39 (permalink) Old 04-21-2010, 09:33 AM
BenzWorld Junior Member
 
Date registered: Feb 2009
Vehicle: mercedes A180 Auto diesel 2010
Location: telford uk
Posts: 29
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Engine fan on all the time...thermostat ?

Hello again,
Yes so the sensor is working ok to give you a correct display.

I did have the same problem a few years ago but cannot remember if it was on the merc or Puma.

I replaced a temperature switch that had failed shut, which if fitted to your merc would be exactly the same.
Sorry I do not know if mercs work the same way.

Anyone know??

Sorry I cannot be any more help.
Tim
timbosss is offline  
post #5 of 39 (permalink) Old 04-21-2010, 11:48 PM
BenzWorld Member
 
Date registered: Jul 2008
Vehicle: C200 Kompressor M111 2.0L Avantgarde Year 2002
Location: Thailand
Posts: 283
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
May be there is problem with this refrigerant sensor...I'm not sure if it control the fan or not. Try inspect for leak or functioning.


W203 C200K M111 2002
Denso Iridium IK20
Ground wires SARD
DangTH is offline  
post #6 of 39 (permalink) Old 04-22-2010, 06:10 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Apr 2010
Vehicle: MB C180 W203 2001
Posts: 17
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
thanx allot for the fead back i well see if the cooling system is ok because the fan has been ternd of for a few minets wean i bush the RC reset in the cope (cooling system).
haltamim is offline  
post #7 of 39 (permalink) Old 04-22-2010, 01:10 PM
BenzWorld Junior Member
 
Date registered: Feb 2009
Vehicle: mercedes A180 Auto diesel 2010
Location: telford uk
Posts: 29
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Fan running all the time cooling not air con

Hi Again,
Thanks for the last post but I think we are at cross purposes.
My fault is with air conditioning and an EC light.

Haltamim issue of the fan is on the cooling part of the car not the air conditioning.

The sensor shown in the diagram is for air conditioning.

The sensor we need to find is actually a temperature switch somewhere in the cooling system and may have failed safe in the closed position causing the fan to run all the time.
Regards
Tim
timbosss is offline  
post #8 of 39 (permalink) Old 04-23-2010, 06:40 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Apr 2010
Vehicle: MB C180 W203 2001
Posts: 17
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
the engine fan is on all the time

what abut if i connect the car to the OBD II? i can bay one if that can tell me the problem within my car?
haltamim is offline  
post #9 of 39 (permalink) Old 04-24-2010, 07:42 PM
BenzWorld Member
 
ontmiss's Avatar
 
Date registered: Apr 2010
Vehicle: 2007 C280 4Matic Avantgarde
Location: Mississauga, Ont
Posts: 149
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
OBD II will tell you only if you have check engine light on on display


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
ontmiss is offline  
post #10 of 39 (permalink) Old 04-25-2010, 12:59 AM
BenzWorld Member
 
Date registered: Jul 2008
Vehicle: C200 Kompressor M111 2.0L Avantgarde Year 2002
Location: Thailand
Posts: 283
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
If you disconnect the connector of sensor B12/2 and found the fan shut down, 100% you have problem with this sensor.

W203 C200K M111 2002
Denso Iridium IK20
Ground wires SARD
DangTH is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W203 C-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 2 (0 members and 2 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Constant whine from the engine fan/fan clutch? driver450190 W201 190-Class 4 03-27-2010 12:15 PM
Long time fan, first time owner here. mehugtree Unimog 13 12-17-2008 11:12 AM
engine fan or radiator fan fuse and relays ?? DnBtekhnic W203 C-Class 0 04-21-2008 08:40 AM
Aux fan run when Engine fan runs? Is it possible? Haroundb W123 E,CE,D,CD,TD,TE Class 48 07-22-2007 08:17 AM
E430 engine warning lamp lights up from time to time maciek W210 E-Class 2 10-30-2006 05:51 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome