the engine fan is on all the time?? - Page 4 - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #31 of 39 (permalink) Old 04-30-2010, 02:41 AM
BenzWorld Member
 
Date registered: Jul 2008
Vehicle: C200 Kompressor M111 2.0L Avantgarde Year 2002
Location: Thailand
Posts: 283
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Quote:
Originally Posted by keyhole View Post
I have already told you what controls this fan. See post #16!

The exterior temperature sensor is for a/c and driver information - not for coolant control.
Yes, it is. The coolant temp sensor is located infront of engine. It have effect to fan control too.

Now I think there are 3 sensors that have effect to the fan operation.
1. Outside temp sensor
2. Freon pressure/temp sensor ( B12 )
3. Coolant temp sensor.
Attached Thumbnails
Click image for larger version

Name:	Coolant.jpg
Views:	1227
Size:	53.7 KB
ID:	305528  

W203 C200K M111 2002
Denso Iridium IK20
Ground wires SARD

Last edited by DangTH; 04-30-2010 at 02:46 AM.
DangTH is offline  
Sponsored Links
Advertisement
 
post #32 of 39 (permalink) Old 04-30-2010, 02:58 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Apr 2010
Vehicle: MB C180 W203 2001
Posts: 17
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
hay
now i think the problem is in the B12 sensor becaus its maight tern the fan on and the car stell thinking that the AC is on (sam how) and because of the temperature rising well in the dash i think the collent sensor is ok allso the out side tempretur is given the exact valeu and even when i ternd the AC off or the cabin fan off the car stell have no answer from the sensore B12 to shut the fan of, any way we will find out evry think abut it on monday.
thanx allot guys
haltamim is offline  
post #33 of 39 (permalink) Old 04-30-2010, 03:12 AM
BenzWorld Member
 
Date registered: Jul 2008
Vehicle: C200 Kompressor M111 2.0L Avantgarde Year 2002
Location: Thailand
Posts: 283
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Quote:
Originally Posted by haltamim View Post
hay
now i think the problem is in the B12 sensor becaus its maight tern the fan on and the car stell thinking that the AC is on (sam how) and because of the temperature rising well in the dash i think the collent sensor is ok allso the out side tempretur is given the exact valeu and even when i ternd the AC off or the cabin fan off the car stell have no answer from the sensore B12 to shut the fan of, any way we will find out evry think abut it on monday.
thanx allot guys
Yes, B12 is most to be the cause. I think the the sensor may have hit by some thing on the road or in the high grass field, may pull the connector off and break the plastic housing of sensor.

W203 C200K M111 2002
Denso Iridium IK20
Ground wires SARD
DangTH is offline  
Sponsored Links
Advertisement
 
post #34 of 39 (permalink) Old 05-03-2010, 10:01 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Apr 2010
Vehicle: MB C180 W203 2001
Posts: 17
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
fainaly the fan is off i have changed the B12 sensore and the freon.
thanx guys for all help
Hussam
haltamim is offline  
post #35 of 39 (permalink) Old 05-04-2010, 03:33 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Apr 2010
Vehicle: MB C180 W203 2001
Posts: 17
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
A/C freon pressure

how can i make sure that the freon pressure is in level, i am fread that the man will put less than the requaird pressure in the sysytem thats y i need to know sam numbers? how match shuld the pressure be whean the pump is on and how match shuld the pressure be att the releas ( the pump is off), pleas help me i will do thes today .
thanx allot
haltamim is offline  
post #36 of 39 (permalink) Old 05-04-2010, 04:18 AM
BenzWorld Member
 
Date registered: Jul 2008
Vehicle: C200 Kompressor M111 2.0L Avantgarde Year 2002
Location: Thailand
Posts: 283
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Quote:
Originally Posted by haltamim View Post
how can i make sure that the freon pressure is in level, i am fread that the man will put less than the requaird pressure in the sysytem thats y i need to know sam numbers? how match shuld the pressure be whean the pump is on and how match shuld the pressure be att the releas ( the pump is off), pleas help me i will do thes today .
thanx allot
If you here hissing noise and the air is not cool as it should be, the freon is low and need charge up more. But if you turn on the Air-con to be cold but the compressor is not engage, the freon is very low that need recharge by fully vaccuum and charge again.

W203 C200K M111 2002
Denso Iridium IK20
Ground wires SARD
DangTH is offline  
post #37 of 39 (permalink) Old 05-04-2010, 04:22 AM
BenzWorld Member
 
Date registered: Jul 2008
Vehicle: C200 Kompressor M111 2.0L Avantgarde Year 2002
Location: Thailand
Posts: 283
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Too much freon will danger than freon too low. Because it will make compressor fail fast and the Air-con will not make good coolling.

W203 C200K M111 2002
Denso Iridium IK20
Ground wires SARD
DangTH is offline  
post #38 of 39 (permalink) Old 05-04-2010, 04:38 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Apr 2010
Vehicle: MB C180 W203 2001
Posts: 17
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
i saw the AC guy yasterday charging another car and tha pressure meter was on 2 LP whean the pumpe is on and its abut 3 wean the pump is off (the cabin is coold) is this numbers ok becaus wean he start to empty the AC pipe i think the pressure was mor then that, is that becaus the engine was off as he toald me??
haltamim is offline  
post #39 of 39 (permalink) Old 06-13-2019, 05:01 AM
BenzWorld Newbie
 
Date registered: Jun 2019
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Hello Gyus!

I have the problem with B12/2 sensor in my mercedes CLC 1.8 Kompressor. I lost the connector, all I have is a cables now. I found and bought the new one from other mecedes, but the colors of the cables are different. Now I don't know how to connect them . Does anyone have maybe a picture of the connector? I would appreciate that a lot!

Have a nice day.
Malgosia Skonieczna is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W203 C-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Constant whine from the engine fan/fan clutch? driver450190 W201 190-Class 4 03-27-2010 12:15 PM
Long time fan, first time owner here. mehugtree Unimog 13 12-17-2008 11:12 AM
engine fan or radiator fan fuse and relays ?? DnBtekhnic W203 C-Class 0 04-21-2008 08:40 AM
Aux fan run when Engine fan runs? Is it possible? Haroundb W123 E,CE,D,CD,TD,TE Class 48 07-22-2007 08:17 AM
E430 engine warning lamp lights up from time to time maciek W210 E-Class 2 10-30-2006 05:51 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome