the engine fan is on all the time?? - Page 3 - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #21 of 39 (permalink) Old 04-28-2010, 11:03 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Apr 2010
Vehicle: MB C180 W203 2001
Posts: 17
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
the sensor B12 is broken to tow pice

hello all
i have see the sensor B12 is broken the plastik head is all of and the rest is stell on the pipe i think this is the problem!! :-( now how i will replace it? shuld i get the gas out from the pipe and fel them after ganching the sensor or i can do it direktly, not that the fan is stell working haha. the obd show that the car have no error.
thanx all guys
haltamim is offline  
Sponsored Links
Advertisement
 
post #22 of 39 (permalink) Old 04-29-2010, 02:06 AM
BenzWorld Member
 
Date registered: Jul 2008
Vehicle: C200 Kompressor M111 2.0L Avantgarde Year 2002
Location: Thailand
Posts: 283
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
You can stop the fan by remove fuse NO.51 in the front fuse panel inside the bonet.
Simply unscrew sensor, don't worry the freon will not leak.

W203 C200K M111 2002
Denso Iridium IK20
Ground wires SARD
DangTH is offline  
post #23 of 39 (permalink) Old 04-29-2010, 03:09 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Apr 2010
Vehicle: MB C180 W203 2001
Posts: 17
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
i have calld the mercedes parts and i will get the sensore tomorow, if i remove the fuse 51 the fan will not working at all, is that ok? even wean the engine can be overheated? or shuld i replace the broken sensore and see what will hapen?
do you have any drawing that i can use as a guid to replace the sensore, and how match shuld i tight the sensore scrow?
thanx for the answering
haltamim is offline  
Sponsored Links
Advertisement
 
post #24 of 39 (permalink) Old 04-29-2010, 03:38 AM
BenzWorld Member
 
Date registered: Jul 2008
Vehicle: C200 Kompressor M111 2.0L Avantgarde Year 2002
Location: Thailand
Posts: 283
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Quote:
Originally Posted by haltamim View Post
i have calld the mercedes parts and i will get the sensore tomorow, if i remove the fuse 51 the fan will not working at all, is that ok? even wean the engine can be overheated? or shuld i replace the broken sensore and see what will hapen?
do you have any drawing that i can use as a guid to replace the sensore, and how match shuld i tight the sensore scrow?
thanx for the answering
Yes, the fan will not operate at all. So if you want to start engine or drive the car, you must put the fuse back on.

For the sensor B12, I will try to check spec with WIS program. May take some time and I will update info again soon.

W203 C200K M111 2002
Denso Iridium IK20
Ground wires SARD
DangTH is offline  
post #25 of 39 (permalink) Old 04-29-2010, 04:18 AM
BenzWorld Member
 
Date registered: Jul 2008
Vehicle: C200 Kompressor M111 2.0L Avantgarde Year 2002
Location: Thailand
Posts: 283
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
B12 Replacement

Please see attach files for info about sensor B12 replacement.
You must have R134a compressor oil and a new seal ring along with the sensor.
Sensor tightening torque is 6 Nm.
Attached Thumbnails
Click image for larger version

Name:	B12.jpg
Views:	2423
Size:	40.6 KB
ID:	305377   Click image for larger version

Name:	B12 replace.jpg
Views:	1653
Size:	44.5 KB
ID:	305378  

W203 C200K M111 2002
Denso Iridium IK20
Ground wires SARD
DangTH is offline  
post #26 of 39 (permalink) Old 04-29-2010, 04:43 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Apr 2010
Vehicle: MB C180 W203 2001
Posts: 17
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
hello
the mercedes guys call me now and thay say that if i unscrow the sensor the freon gas will get out and its vary dangres, thay say the lek well be 100% sure??? shuld i beleav them??
haltamim is offline  
post #27 of 39 (permalink) Old 04-29-2010, 08:51 AM
BenzWorld Member
 
Date registered: Jul 2008
Vehicle: C200 Kompressor M111 2.0L Avantgarde Year 2002
Location: Thailand
Posts: 283
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Quote:
Originally Posted by haltamim View Post
hello
the mercedes guys call me now and thay say that if i unscrow the sensor the freon gas will get out and its vary dangres, thay say the lek well be 100% sure??? shuld i beleav them??
Sorry, I'm wrong. Yes..Mercedes guy is correct, the freon will get out when remove B12 sensor. It is no pin valve inside the pipe block as I see from diagram.

I think you should bring the sensor to the air-con shop for replace and recharge new freon into the system again. Some repair shop could recycle the old freon to recharge again for saving cost of new freon too.
You may think of changing the dryer cartridge in the same time also for better cooling performance.
Attached Thumbnails
Click image for larger version

Name:	AC Part NO.jpg
Views:	3328
Size:	46.1 KB
ID:	305395  

W203 C200K M111 2002
Denso Iridium IK20
Ground wires SARD
DangTH is offline  
post #28 of 39 (permalink) Old 04-30-2010, 01:13 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Apr 2010
Vehicle: MB C180 W203 2001
Posts: 17
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
shuld i bay the sealring allso or i will get it directly with the sensor?
thanx allot for all the digrams that u have send thay was vary helpfull.
one last think whay the fan is stell working? its no mor connection to the temperature sensor (B12)?
allso when i disconnect the outside temperature sensor the fan is off!!
thanx allot for the feedback.
haltamim is offline  
post #29 of 39 (permalink) Old 04-30-2010, 01:36 AM
Outstanding Contributor
 
keyhole's Avatar
 
Date registered: Sep 2006
Vehicle: 2004 CLK 240 Coupe
Location: Norfolk. UK
Posts: 11,335
Mentioned: 20 Post(s)
Quoted: 600 Post(s)
Quote:
Originally Posted by haltamim View Post
thanx allot for all the digrams that u have send thay was vary helpfull.
one last think whay the fan is stell working? its no mor connection to the temperature sensor (B12)?
I have already told you what controls this fan. See post #16!

The exterior temperature sensor is for a/c and driver information - not for coolant control.
keyhole is offline  
post #30 of 39 (permalink) Old 04-30-2010, 02:18 AM
BenzWorld Member
 
Date registered: Jul 2008
Vehicle: C200 Kompressor M111 2.0L Avantgarde Year 2002
Location: Thailand
Posts: 283
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Quote:
Originally Posted by haltamim View Post
shuld i bay the sealring allso or i will get it directly with the sensor?
thanx allot for all the digrams that u have send thay was vary helpfull.
one last think whay the fan is stell working? its no mor connection to the temperature sensor (B12)?
allso when i disconnect the outside temperature sensor the fan is off!!
thanx allot for the feedback.
The seal ring you may ask at the air-con shop, they may have the same size for you. I think it is rubber O-ring. But if they don't have, you could buy the seal ring from your dealer and also the dryer cartridge if you need to replace too.

If disconnect outside temp sensor, it report minus...Celcies. That's mean the cabin need to be warm. Then the compressor will cut off and the fan is shut down that commanded from climate system.

For sensor B12, I think the sensor logic coud be NC ( normal contact ) when freon pressure low and the fan is shut off.
Other logic, sensor break contact ( contact open ) when freon pressure is high as compressor engage, the fan turn on.
And when the connector disconnected or the wire break, it is the same condition of sensor contact open and the fan turn on. This is my understand.

Other thing in the same sensor is the temperature value that might have effect to fan control too.

I know that some car will switch to safe mode when some sensor malfunction. The air-con still operate and the fan can turn on by command from climate system.

W203 C200K M111 2002
Denso Iridium IK20
Ground wires SARD

Last edited by DangTH; 04-30-2010 at 02:33 AM.
DangTH is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W203 C-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Constant whine from the engine fan/fan clutch? driver450190 W201 190-Class 4 03-27-2010 12:15 PM
Long time fan, first time owner here. mehugtree Unimog 13 12-17-2008 11:12 AM
engine fan or radiator fan fuse and relays ?? DnBtekhnic W203 C-Class 0 04-21-2008 08:40 AM
Aux fan run when Engine fan runs? Is it possible? Haroundb W123 E,CE,D,CD,TD,TE Class 48 07-22-2007 08:17 AM
E430 engine warning lamp lights up from time to time maciek W210 E-Class 2 10-30-2006 05:51 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome