2005 C240 - Weak reception of key signal - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 22 (permalink) Old 10-03-2008, 10:35 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Oct 2008
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
2005 C240 - Weak reception of key signal

Very strange issue. One day, my 2005 C240 wouldn't lock/unlock with the key fob / remote unless I was standing right next to the drivers side door. At any other distance, it wouldn't work.

Naturally, I grabbed my spare set - same problem.

Then I replaced both batteries - same problem.

Then, next time I got my service, I ordered a new set of keys - same problem.

I asked the technician, he was baffled and basically told me to just live with it.

So it is definitely a "reception" problem of the car, rather than something wrong with the keys. Has anyone seen this before?
gmoore4464 is offline  
Sponsored Links
Advertisement
 
post #2 of 22 (permalink) Old 10-03-2008, 03:04 PM
BenzWorld Elite
 
2002c230's Avatar
 
Date registered: Jun 2007
Vehicle: 2002 C32 AMG
Location: New Mexico, USA
Posts: 1,771
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
The remote key has both IR, and radio signal control. To narrow it down, have you tried using the IR at a distance? Just point the front of the key directly at the IR receiver on the driver side door handle.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2002 C32 AMG Sedan [111,000 Miles]
Clear Side Markers | CL Style Grille | Flat Emblem | CF Front Lip Spoiler | CF Rear Diffuser | CF Trunk Spoiler
K&N Air Filters | NGK IX (2 Step) | KV-85 | LET 185MM & ECU | TVT Thermostat | PSK Belt Wrap | CM30
DIY Intercooler Isolation | 26x7x2 FB H/E | Intercooler Reservoir | Battery Relocation | Lorinser Sides
2002c230 is offline  
post #3 of 22 (permalink) Old 10-06-2008, 07:14 PM
BenzWorld Senior Member
 
UK-C200's Avatar
 
Date registered: Nov 2007
Vehicle: RHD C200K Sport Coupe, RHD SLK-55, LHD SLK-350
Location: London, GB & Louisiana
Posts: 451
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
How's the reception on your radio? The remote shares the same antenna (unless I'm getting mixed up with the R171) - I'd look at the antenna and the splitter wiring - I'd bet one has come loose..
UK-C200 is offline  
Sponsored Links
Advertisement
 
post #4 of 22 (permalink) Old 10-07-2008, 08:10 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Oct 2008
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Ah - the IR thing makes sense - its best when I point the key right at the IR reciever, but if I point it in the other direction, even close, it doesn't work.

My radio reception is fine... I'm going to take a look in the fuse boxes tonight to see if one may have popped, now that I know that IR/Radio are different systems.

Thanks for your help!
gmoore4464 is offline  
post #5 of 22 (permalink) Old 10-07-2008, 05:11 PM
BenzWorld Junior Member
 
Date registered: Mar 2007
Posts: 39
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
UK-C200 is right, generally its the antenna for the radio and remote, its tied together. we call it a combi antenna, Its on the rear glass, but you have to pull the head liner down on some cars. I would go back to the dealer and complain. Was the the tech a new guy? tell him its most likely that combi antenna, comming from another techs
Motioneffects is offline  
post #6 of 22 (permalink) Old 01-05-2009, 10:54 AM
BenzWorld Junior Member
 
Date registered: Jan 2009
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Weak remote signal

Did you find a solution to this problem? What happened when you looked at the fuses? I'd hate to work around the headliner to find the antenna on the back window.
mheinrich is offline  
post #7 of 22 (permalink) Old 01-05-2009, 11:14 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Oct 2008
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
All of the fuses were ok... and the radio reception works perfectly.

My solution has been using just the IR, close range by the driver's side door. Infuriating.

I'm not experienced enough to work around the back window, and the fact that the radio reception is fine makes me hesitant to get someone that knows what they are doing to charge me $1,000 for this.

I'll send a bottle of 18 year old scotch to anyone who can come up with a solution!!
gmoore4464 is offline  
post #8 of 22 (permalink) Old 01-05-2009, 11:57 AM
BenzWorld Extremist
 
C230 Sport Coup's Avatar
 
Date registered: Feb 2007
Vehicle: 2002 C230 Sport Coup and 2006 ML350
Location: Norcal Coast
Posts: 1,125
Mentioned: 0 Post(s)
Quoted: 32 Post(s)
Quote:
Originally Posted by gmoore4464 View Post
All of the fuses were ok... and the radio reception works perfectly.

My solution has been using just the IR, close range by the driver's side door. Infuriating.

I'm not experienced enough to work around the back window, and the fact that the radio reception is fine makes me hesitant to get someone that knows what they are doing to charge me $1,000 for this.

I'll send a bottle of 18 year old scotch to anyone who can come up with a solution!!
Seriously? I'll take McCallan's or Sherry finish Glenmorangie...

Now that being said, did you tint your windows recently?
What was the last thing done to your car just prior to the problem occurring?
Think hard...it might be something small....


2006 ML350 - Stock
2002 C7 Evolution Orion Blue 2.3L C230 Coupe
Auto-Pano-Oyster Leather-Audio 10
AMG Front bar 22mm-17" Wheels- C32 Brakes- H&R 19mm rear sway
TEIN SS Coilovers -
Clear sides- 2005 tails, Blinkers & Grill- Tinted Windows
Bi-Xenons-Clear Fogs- Clear Side/Stealth Bulbs



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
C230 Sport Coup is offline  
post #9 of 22 (permalink) Old 01-05-2009, 01:05 PM
BenzWorld Junior Member
 
Date registered: Jan 2009
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Ok, Here's what I did. It solved the problem.....for now.

Pulled fuses, 9,10 in the trunk panel and 21,22,32,33 in the fuse panel next to the drivers side. I looked to make sure they were intact and then put them back. I pried my fingers under the headliner at the back window and ran my fingers along the edge and found what I guess is the antenna wires for both the radio and the IR remote antenna. I moved the wires a bit and then tried the key.

It worked from 5' then 10' then i really pushed it and went accross the street.....about 75' and it still worked.

I'm not confident that it is a permanent fix but it's worth a shot.

Let me know if it works for you.
mheinrich is offline  
post #10 of 22 (permalink) Old 01-07-2009, 01:23 AM
BenzWorld Elite
 
2002c230's Avatar
 
Date registered: Jun 2007
Vehicle: 2002 C32 AMG
Location: New Mexico, USA
Posts: 1,771
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Just a little side note to add... The remote key works best if unlock/lock is held for at least one second. For some reason a quick click will work close up, but not futher away. This is when you need to hold the button down.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2002 C32 AMG Sedan [111,000 Miles]
Clear Side Markers | CL Style Grille | Flat Emblem | CF Front Lip Spoiler | CF Rear Diffuser | CF Trunk Spoiler
K&N Air Filters | NGK IX (2 Step) | KV-85 | LET 185MM & ECU | TVT Thermostat | PSK Belt Wrap | CM30
DIY Intercooler Isolation | 26x7x2 FB H/E | Intercooler Reservoir | Battery Relocation | Lorinser Sides
2002c230 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W203 C-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
C240- 2005 Need Key Fob spare egamb General Mercedes-Benz 2 09-21-2008 09:56 PM
Weak signal from comand to optic fibre. austlight General Mercedes-Benz 0 03-03-2007 05:14 AM
Weak Radio Reception 2002 S430 kingjnod W220 S-Class 3 05-24-2006 03:05 PM
Weak RemoteKey Signal Mod? Dudeuh60 General Mercedes-Benz 3 04-27-2005 01:23 AM
weak LED turn signal bulb LOCHS 2 W163 M-Class 7 03-31-2005 06:02 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome