2005 C240 - Weak reception of key signal - Page 3 - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #21 of 22 (permalink) Old 09-19-2015, 09:05 AM
BenzWorld Junior Member
 
Date registered: Nov 2012
Vehicle: (sold 99 ML320) + 05 C240 4matic
Location: New England
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Well thank you all for these responses.

We still have the issue this vehicle - just living with it for now.

It works, albeit slightly not to spec.

Thanks
(oh sorry for the year deal this)
Mikes ML320 is offline  
Sponsored Links
Advertisement
 
post #22 of 22 (permalink) Old 06-13-2019, 04:57 PM
BenzWorld Newbie
 
Date registered: Jun 2019
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Hey everyone!!! I found an answer that worked for my 2007 cls550 (W219). I've had the same problem where my key would unlock and lock but only if it was right next to the car either having to touch the key to the IR receptor in the driver door or put it against the glass to work.

Reading through here they talked about fuzes or the combo antenna on the back glass possibly being culprits. I checked my fuzes and number 13 in the trunk (15amp) and another 15amp was blown under the hood. Replacing both of those first did nothing but they did not blow when I put the new fuzes in.

Then I checked the antenna by pulling down both sides and headliner just enough to see the edge of the window and I found on the driver side of the rear window 6 wires running to a plug. My plug wasn't plugged into anything so I pulled the plastic interior panel back a little further and there was a plug in for it.

The antenna not being plugged in is what fixed it!! After 2 years of this problem I finally have it working at 25+ feet away which is better than ever!

PS. Thank you everyone for your advic! This forum is the only way I was able to figure this out. 😁😁
Bcwalbeck is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W203 C-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
C240- 2005 Need Key Fob spare egamb General Mercedes-Benz 2 09-21-2008 09:56 PM
Weak signal from comand to optic fibre. austlight General Mercedes-Benz 0 03-03-2007 05:14 AM
Weak Radio Reception 2002 S430 kingjnod W220 S-Class 3 05-24-2006 03:05 PM
Weak RemoteKey Signal Mod? Dudeuh60 General Mercedes-Benz 3 04-27-2005 01:23 AM
weak LED turn signal bulb LOCHS 2 W163 M-Class 7 03-31-2005 06:02 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome