Anyone know how to adjust clutch on sunroof motor please? - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 08-07-2003, 10:57 PM Thread Starter
BenzWorld Member
 
Date registered: Feb 2003
Location: London / Manchester (UK)
Posts: 162
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Anyone know how to adjust clutch on sunroof motor please?

My mum's got a L reg (1993/4) c180 with just 11k on the clock!

However, the previous owner never used the sunroof, and my mum has only just started to use it this week, due to to heatwave here in the UK.

This means that the sunroof is a bit stiff.

I have WD40'd the rails every 6 months or so, and this makes it appear to move smoothly, however, the windows and sunroof are wired to the clifford alarm to automatically close, and when closing by remote, the sunroof now closes, but the rear edge remains approx 1/2 cm too low, but if manually closed, it closes correctly.

This led me to try and change the clutch setting.

On a w126 post i read the motor was in the boot!, but all i could find was electric ariel and (i think) fuel pump.

Does anyone know where the motor is, and how to adjust the clutch?

And before any smart ass says just close it manually, I would, but this is for my mum who forgets things like this every now and then - this problem only came to light when she left her car overnight and returned to find it with sunroof only 2 inch shut in the morning!

RobinG is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 08-12-2003, 03:02 PM
BenzWorld Member
 
Date registered: Nov 2002
Vehicle: SL280
Location: Oxford UK
Posts: 196
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
I think you might do well to check the rails for any signs of preventing it closing. The r...

I think you might do well to check the rails for any signs of preventing it closing. The runners have some limited adjustment which might do the trick.

I had one where the roof was not running square in the runners which never really got sorted despite many adjustments.

The motor is in the boot - follow the cable rack down from under the parcel shelf. I cannot remember though if it has any cutch adjustment. Does the motor sound as if it is running on despite the roof not closing or does it labour? if the latter, doubt its clutch..

Hal
J62105 is offline  
post #3 of 4 (permalink) Old 08-14-2003, 11:41 PM
BenzWorld Junior Member
 
Date registered: Aug 2003
Location: CA, USA
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
RobinG, there is a resistance sensor built-in to the module that controls the closure of...


RobinG, there is a resistance sensor built-in to the module that controls the closure of the sunroof that is connected to your alarm system.

Since the old owner havent ever used the sunroof, that means the alarm was trying to close the sunroof every time the alarm was turned on even the roof is closed thus making the module more sensitive to the resistance causing to automatic shut-off before it is even closed completely.

it is a safety feature in case someone gets their arm, hand, or whatever stuck when the roof is closing.

Try "helping" the roof close when you turn on the alarm system by pushing it forward and if it does the trick, then you either need a new module with adjustable resistance settings and or check the guage of the wire that leads to the module(14ga-16ga min or connection problem)also ground wire, or you may need a new motor(if the tracks and rails are smooth) or just close it manually with the switch(switch always works cause it doesnt have to do with the module)module usually has a independent suplly and if branched off to other power draining components can cause this problem also.

SPortMP5

SportMP5 is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 08-22-2003, 05:00 PM Thread Starter
BenzWorld Member
 
Date registered: Feb 2003
Location: London / Manchester (UK)
Posts: 162
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks a lot for info.


RobinG is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W202 C-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome