95 c280 lights left on, battery died no sound at jump - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 06-25-2019, 08:03 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Jun 2006
Vehicle: 1995 c280
Location: illinois
Posts: 7
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
(Thread Starter)
Angry 95 c280 lights left on, battery died no sound at jump

Last night, I left my lights on and after about 1 hour came back to see dim lights. cop tried to jump, no sound at all. called insurance and towed to house. googled information 1. corrosion 2. starter 3. alternator. did anyone go through same, please advise. I will purchase scanner and update the report.
Thanks.
sirphira is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 06-25-2019, 10:16 AM
BenzWorld Elite
 
khomer2's Avatar
 
Date registered: Nov 2015
Vehicle: w163 02 ML500 W210 97 E50Amg w202 99 C230K w124 - need more space, time to build again
Location: Canada
Posts: 1,216
Mentioned: 4 Post(s)
Quoted: 269 Post(s)
No history other than a dead battery so...

"Jumping" will not necessarily get you going if the battery is deader than dead.
When was the last time you replaced your battery? You do realize they too have a limited lifespan, right?

You need a real booster.

One of these - it's a chick (and neighbor) magnet
Free BBQs, meals and beer most of the time.
Attached Thumbnails
Click image for larger version

Name:	booster.png
Views:	8
Size:	341.6 KB
ID:	2523628  
sirphira likes this.
khomer2 is offline  
post #3 of 7 (permalink) Old 06-25-2019, 10:48 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Jun 2006
Vehicle: 1995 c280
Location: illinois
Posts: 7
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
(Thread Starter)
battery replacement, got it.
scanner shows p1700 and p1444.

how about preventive measure. is there any product or mechanism that lights go off if left on by mistake? i will appreciate input as proactive measure.
Thanks.
sirphira is offline  
Sponsored Links
Advertisement
 
post #4 of 7 (permalink) Old 06-25-2019, 11:00 AM
BenzWorld Elite
 
khomer2's Avatar
 
Date registered: Nov 2015
Vehicle: w163 02 ML500 W210 97 E50Amg w202 99 C230K w124 - need more space, time to build again
Location: Canada
Posts: 1,216
Mentioned: 4 Post(s)
Quoted: 269 Post(s)
Quote:
Originally Posted by sirphira View Post
battery replacement, got it.
scanner shows p1700 and p1444.

how about preventive measure. is there any product or mechanism that lights go off if left on by mistake? i will appreciate input as proactive measure.
Thanks.
P1444 is a EVAP code.
P1700 is for a tranny upshift delay, typically caused by a vacuum leak somewhere.
You need to check all your vacuum lines for breakage and hairline cracks, or you can opt to do a smoke test

Erase the codes and test again to see if the codes reappear.

https://www.benzworld.org/forums/w20...e-problem.html

As for preventative measures, nothing worth installing imo unless you have $$ to burn.
Treat it like a baby.... "if you dont feed the baby, the bay will die"
khomer2 is offline  
post #5 of 7 (permalink) Old 06-25-2019, 11:54 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Jun 2006
Vehicle: 1995 c280
Location: illinois
Posts: 7
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
(Thread Starter)
battery changed --> starts perfecto

Quote:
Originally Posted by khomer2 View Post
P1444 is a EVAP code.
P1700 is for a tranny upshift delay, typically caused by a vacuum leak somewhere.
You need to check all your vacuum lines for breakage and hairline cracks, or you can opt to do a smoke test

Erase the codes and test again to see if the codes reappear.

https://www.benzworld.org/forums/w20...e-problem.html

As for preventative measures, nothing worth installing imo unless you have $$ to burn.
Treat it like a baby.... "if you dont feed the baby, the bay will die"
Thanks a lot.
Changed battery from Sams
Wallah, it works again
Still have concern, the cop tried to jump and there was no sound (not even faint clicking), mystery
All is well that ends well.
Thanks Khomer2
sirphira is offline  
post #6 of 7 (permalink) Old 06-25-2019, 01:07 PM
BenzWorld Elite
 
khomer2's Avatar
 
Date registered: Nov 2015
Vehicle: w163 02 ML500 W210 97 E50Amg w202 99 C230K w124 - need more space, time to build again
Location: Canada
Posts: 1,216
Mentioned: 4 Post(s)
Quoted: 269 Post(s)
Even a jump to a dead battery can give you a 'no click' (depending on the condition of the battery)
sirphira likes this.
khomer2 is offline  
post #7 of 7 (permalink) Old 06-26-2019, 07:34 AM
BenzWorld Elite
 
MB-W202's Avatar
 
Date registered: May 2010
Vehicle: 1995 C280 (165K mi)
Location: Wash. DC, USA
Posts: 1,507
Mentioned: 0 Post(s)
Quoted: 128 Post(s)
Learn about batt maintenance online. Lots of info. Easy.

Erase the codes and check them again in a few weeks. If they come up again search the forum. Those are common fault codes.

How many miles? As stated your car has lots of vacuum tubes which are brittle and needs changing. Also, have you replaced the engine and trans wiring harness? They're definitely a goner.

Last edited by MB-W202; 06-26-2019 at 10:49 PM.
MB-W202 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W202 C-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome