1999 C280 rough idle - Mercedes-Benz Forum
 
LinkBack Thread Tools
Old 06-11-2019, 06:37 PM Thread Starter
BenzWorld Newbie
 
Date registered: Jan 2012
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
1999 C280 rough idle

I have a 1999 C280 with rough idle issues.

It is most notable when I'm sitting at a traffic light in gear with the air conditioning on.
If I turn off the a/c the idle increases and the vibration stops.
With the a/c on the idle slows and the shaking begins.
If I take it out of gear, the vibration stops, even with the a/c on.
I have had this issue for a few months.
I recently installed new coils, spark plugs, spark plug wires, new valve over gaskets and breather hoses.
This did help, but it only reduced the intensity of the vibrations.
Prior to this I did replace the crank position sensor also.
I would appreciate any suggestions you may offer.

Thank you
my2ndmb is offline  
Sponsored Links
Advertisement
 
Old 06-12-2019, 09:53 AM
BenzWorld Elite
 
MB-W202's Avatar
 
Date registered: May 2010
Vehicle: 1995 C280 (165K mi)
Location: Wash. DC, USA
Posts: 1,509
Mentioned: 0 Post(s)
Quoted: 128 Post(s)
I think your initial idle is too low. A load when not driving causes it to go below your min idle. You may need to increase your resting idle.

My car idles at ~650 rpm in park. Yours may be different.
MB-W202 is offline  
Old 06-12-2019, 11:01 AM
BenzWorld Elite
 
khomer2's Avatar
 
Date registered: Nov 2015
Vehicle: w163 02 ML500 W210 97 E50Amg w202 99 C230K w124 - need more space, time to build again
Location: Canada
Posts: 1,241
Mentioned: 4 Post(s)
Quoted: 273 Post(s)
Concur with MB-w202.
Ours idles at ~650rpm.
khomer2 is online now  
Sponsored Links
Advertisement
 
Old 06-12-2019, 11:00 PM Thread Starter
BenzWorld Newbie
 
Date registered: Jan 2012
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
That's where mine idles in park also.
I don't think that's the issue.
my2ndmb is offline  
Old 06-12-2019, 11:35 PM
BenzWorld Member
 
Date registered: Aug 2014
Vehicle: 1995 C280 1997 S320
Location: Surrey, BC Canada
Posts: 177
Mentioned: 3 Post(s)
Quoted: 14 Post(s)
First id start looking for possible vacuum leaks..
Second clean MAF sensor

Whats your Long term fuel trim?

Sent from my LG-H873 using Tapatalk

you can watch all my MB repair videos on

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
andy_1100 is offline  
Old 06-14-2019, 10:40 PM
BenzWorld Veteran
 
Date registered: Sep 2005
Vehicle: 1999 C280, 2000 C280, 2000 C230K,2011 C300
Location: los angeles
Posts: 630
Mentioned: 0 Post(s)
Quoted: 29 Post(s)
Rough idle in gear at stop.>>>>>>>>>
Smooth idle in neutral at stop.>>>>>>

This is bad engine mounts.

If they haven't been done like ever, then most likely.

Put the car on ramps or jack stands and take a look to see if they are squashed or maybe even leaking oil.

Go to the online parts sites to see what they look like.

glenmore
1999, 2000 C280
2000 C230K
2011 C300
glenmore is online now  
Old 06-15-2019, 03:09 PM
BenzWorld Elite
 
MB-W202's Avatar
 
Date registered: May 2010
Vehicle: 1995 C280 (165K mi)
Location: Wash. DC, USA
Posts: 1,509
Mentioned: 0 Post(s)
Quoted: 128 Post(s)
great point glenmore. slipped my mind completely.

yes, check the mounts.
MB-W202 is offline  
Old 07-02-2019, 05:54 PM Thread Starter
BenzWorld Newbie
 
Date registered: Jan 2012
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thank you to all that offered suggestions.

The problem was the motor mounts.
The 2 front motor mounts and transmission mount were replaced and the vibration is gone.
andy_1100 likes this.
my2ndmb is offline  
Sponsored Links
Advertisement
 
 

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W202 C-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Thread Tools



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome